Results 1 to 7 of 7

Thread: AMD Catalyst center, driver issues

Hybrid View

  1. #1
    Join Date
    Jun 2012

    AMD Catalyst center, driver issues

    I recently upgraded xubuntu 12.04 to 12.10 on 2 laptops. Video on the one with Intel integrated graphics works fine.

    On the one with ATI/AMD graphics Vlc works properly but smplayer does not work unless I select the x11 module, which it did not do before. With other modules either mplayer crashes or I get audio but no video depending upon the selected o/p module.

    If I go into Settings Manager and click AMD Catalyst Control Center (non-admin) I get:

    Initialization error

    There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

    No AMD graphics driver is installed, or the AMD driver is not functioning properly.
    Please install the AMD driver appropriate for you AMD hardware, or configure using aticonfig.
    I got the same error message when I ran:
    gksudo amdcccle
    Tried this thread:
    but it doesn't seem to have 12.10 specific information.

    Here's a little more information:

    $ lspci | grep VGA
    01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series]
    $ cat /etc/X11/xorg.conf

    Section "Screen"
    Identifier "Default Screen"
    DefaultDepth 24

    Section "Module"
    Load "glx"
    Under Ubuntu 12.04 (which I replaced with xubuntu 12.04 by just reinstalling) on this machine I got a proprietary video driver listed but I never installed it. Under xubuntu 12.10 this driver doesn't appear at all in the update manager section.

    Perhaps I should be glad I never installed it before ... are there compatibility issues in 12.10?

    I downloaded the linux 64 bit installer: AMD Catalyst™ 12.6 Proprietary Linux x86 Display Driver from the amd site but needless to say I haven't installed it yet.

  2. #2
    Join Date
    May 2007

    Re: AMD Catalyst center, driver issues

    IF the AMD chipset is really a 4200 -- then it will NOT work with Ubuntu 12.10 -- because that upgraded the X-server to 1.13, and this summer, AMD dropped support for its Linux drivers for the HD 2x/3x/4x chipsets. The older driver (legacy 12.6) will NOT work with the X-server v1.13.

    So basically, there are no restricted AMD drivers that will work with Ubuntu 12.10 and AMD HD 2x/3x/4x chipsets.
    Ubuntu 15.04 Mate, Mint 17.1; MS Win 8.1, Win10 TP.
    Will not respond to PM requests for support -- use the forums.

  3. #3
    Join Date
    Jun 2012

    Re: AMD Catalyst center, driver issues

    Thanks for the reply. I suspected something like that when the driver didn't come up on the list..

    It's not a big issue on that machine ... it's a single core and I don't use it for playing video much anyway. I never even noticed any issues with smplayer for a while.

  4. #4
    Join Date
    Aug 2011

    Re: AMD Catalyst center, driver issues

    Add this ppa and you will have Catalyst for your older AMD cards.

  5. #5
    Join Date
    Jun 2012

    Re: AMD Catalyst center, driver issues

    Thanks, I'll look at that.

  6. #6
    Join Date
    Jul 2008
    The Left Coast of the USA

    Re: AMD Catalyst center, driver issues

    Before you look at that, and for all others who might see this:

    The process given downgrades X Server to 1.12, where Ubuntu 12.10 uses 1.13. It also uses an older, patched proprietary driver rather than the most recent one. You need to read the PPA description before launching into it.

    This does not "solve" the problem. It takes you a step back. That may be fine and it's up to you, but you should be aware what you are doing.

    Those who propose this solution to users should make this clear.
    Last edited by QIII; November 17th, 2012 at 01:53 PM.
    The Left Coast Geek * The Community ATI Driver Wiki * Find what you need in the Ubuntu Community wikis

    Don't let the truth get in the way of a good story!
    This universe is crazy. I'm going back to my own.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts