Results 1 to 10 of 31

Thread: Not able to control Brightness in my VAIO CW15FG laptop

Hybrid View

  1. #1
    Join Date
    Nov 2012
    Beans
    18

    Question Not able to control Brightness in my VAIO CW15FG laptop

    I've installed Ubuntu 12.10 recently.
    When ever I press Fn keys along with F5/F6 it shows that the brightness decreases / increases accordingly. But no difference on the screen.

    I tried modifying the grub , xorg.conf files as mentioned in many other posts. But none helped me. I'm new to the Ubuntu environment and I'm completely clueless about what to do.

    In my /sys/class/backlight directory, I find two folders (shortcuts)
    nv_backlight &
    sony
    And when I change my brightness I find the value changes accordingly in brightness file present inside 'sony' folder.

    Earlier I tried to install nvidia driver for my G210M graphics card and failed. I get a blank screen after the boot screen after installation. So reverted the settings to work on my default driver

    I even tried kubuntu 12.10 live cd (KDE environment) and found the same problem there.
    Plz someone help me with this brightness issue. it is even Ok for me to work without my nvidia drivers as I'm not a big fan of games.
    Last edited by wizardvenkat; November 14th, 2012 at 03:53 PM.

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not able to control Brightness in my VAIO CW15FG laptop

    Quote Originally Posted by wizardvenkat View Post
    I tried modifying the grub
    What modifications did you make to grub? Did you try the acpi_backlight=vendor parameter?

  3. #3
    Join Date
    Nov 2012
    Beans
    18

    Re: Not able to control Brightness in my VAIO CW15FG laptop

    Quote Originally Posted by Toz View Post
    What modifications did you make to grub? Did you try the acpi_backlight=vendor parameter?
    This info is available in my /etc/default/grub
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=sony"
    GRUB_CMDLINE_LINUX="acpi_backlight=sony"

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not able to control Brightness in my VAIO CW15FG laptop

    The parameter should say exactly acpi_backlight=vendor, the vendor keyword indicating to use the vendor-specific driver instead of the acpi driver.

    acpi_backlight=sony is not a valid parameter.

    Make sure to also run:
    Code:
    sudo update-grub
    ...afterwards to commit the edits.

    If it still doesn't work on reboot, can you post back the results of:
    Code:
    cat /proc/cmdline
    ...and the contents of your dmesg log file? Use this command:
    Code:
    pastebinit /var/log/dmesg
    ...and post back the link that is generated.

  5. #5
    Join Date
    Nov 2012
    Beans
    18

    Re: Not able to control Brightness in my VAIO CW15FG laptop

    acpi_backlight=vendor statement is also not working.

    These are my results for cat proc/cmdline :

    BOOT_IMAGE=/boot/vmlinuz-3.5.0-18-generic root=UUID=446e1f28-d397-4eef-a7fb-fa0eda88129a ro acpi_backlight=vendor quiet splash acpi_backlight=vendor vt.handoff=7

    And my PasteBin URL is here

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Not able to control Brightness in my VAIO CW15FG laptop

    Can you remove both of the acpi_backlight=vendor parameters from grub and reboot the computer? This time post back the results of:

    Code:
    cat /proc/cmdline
    lsmod
    ...and the links to the following two log files:
    Code:
    pastebinit /var/log/dmesg
    pastebinit /var/log/Xorg.0.log
    You also mentioned that you tried to install the nvidia driver and that it didn't work. How did you try to install it? Was it through the additional drivers tab via:
    Code:
    software-properties-gtk
    ...(or Ubuntu Software Centre, select Edit->Software Sources and on the Additional Drivers tab)?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •