Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Can't see any text with NX on 12.10

Hybrid View

  1. #1
    Join Date
    Apr 2009
    Beans
    23

    Unhappy Can't see any text with NX on 12.10

    There is something wrong with NX for remote access. It was working fine on 12.04, but on 12.10 all of the text on menus, etc. is missing.

    Apparently there is a known issue with 12.10 + NX (http://www.nomachine.com/tr/view.php?id=TR10J02752), but I tried some of the workarounds mentioned in the link and the text is still invisible.

    I can see the text just fine through VNC, though.

    This issue might be related to the one Maphrox reported in another thread (http://ubuntuforums.org/showthread.php?t=2081531).

    Any ideas?

    Thanks

  2. #2
    Join Date
    Nov 2012
    Beans
    2

    Re: Can't see any text with NX on 12.10

    Same problem here.

  3. #3
    Join Date
    Apr 2009
    Beans
    23

    Smile Re: Can't see any text with NX on 12.10

    Workaround found! Many thanks to ice9 and boof from the ArchLinux forums (https://alderaan.archlinux.org/viewt...hp?pid=1107447) for the idea of downgrading the libcairo library.

    Here are the steps I followed for my 64-bit install of Ubuntu 12.10. I suppose the workaround is the same for the 32-bit version, except you change the libcairo package and the file system paths accordingly:

    1. Terminate your NX sessions
    2. cd ~/Downloads
    3. wget http://mirror.pnl.gov/ubuntu//pool/m...ntu2_amd64.deb
    4. mkdir libcairo
    5. dpkg -x libcairo2_1.10.2-6.1ubuntu2_amd64.deb libcairo/
    6. sudo mkdir /usr/lib/x86_64-linux-gnu/libcairo_orig
    7. sudo mv /usr/lib/x86_64-linux-gnu/libcairo.so.2* /usr/lib/x86_64-linux-gnu/libcairo_orig/
    8. sudo cp ~/Downloads/libcairo/usr/lib/x86_64-linux-gnu/libcairo.so.2* /usr/lib/x86_64-linux-gnu/
    9. Re-connect to your machine via NX.
    Last edited by Zoide7777; November 9th, 2012 at 10:07 PM.

  4. #4
    Join Date
    Nov 2012
    Beans
    9

    Re: Can't see any text with NX on 12.10

    Thanks for the workaround, fixes my issues too!

    I'm on Xubuntu 12.10 though, and text is correct initially. It is only after disconnecting and resuming a session that text disappears.

  5. #5
    Join Date
    Nov 2012
    Beans
    2

    Re: Can't see any text with NX on 12.10

    Awesome. Thanks. Worked great.

  6. #6
    Join Date
    Nov 2009
    Beans
    6

    Re: Can't see any text with NX on 12.10

    The workaround leads to evince not being able to open any pdf files. I think the disabling Disable the render extension in client works: http://askubuntu.com/questions/21458...ubuntu-upgrade

  7. #7
    Join Date
    Apr 2009
    Beans
    23

    Re: Can't see any text with NX on 12.10

    Just as a heads-up, you may have to downgrade libcairo-gobject as well using the one at libcairo-gobject2_1.10.2-6ubuntu3_amd64.deb

  8. #8
    Join Date
    Jan 2007
    Beans
    11

    Re: Can't see any text with NX on 12.10

    Amazing! Thanks for the downgrade-tip!

  9. #9
    Join Date
    Dec 2012
    Beans
    2

    Re: Can't see any text with NX on 12.10

    Quote Originally Posted by Zoide7777 View Post
    Just as a heads-up, you may have to downgrade libcairo-gobject as well using the one at libcairo-gobject2_1.10.2-6ubuntu3_amd64.deb
    I can confirm that downgrade works for me
    - ubuntu 12.10 server 64-bit, headless with mate-desktop

    both libraries:
    wget http://mirror.pnl.gov/ubuntu//pool/m...ntu3_amd64.deb
    wget http://mirror.pnl.gov/ubuntu//pool/m...ntu2_amd64.deb


    By the way disabling render extension did not help - fonts were still missing after session reconnect.
    Is there an open bug report created for libcairo ?

  10. #10
    Join Date
    Apr 2006
    Beans
    1

    Re: Can't see any text with NX on 12.10

    Quote Originally Posted by Zoide7777 View Post
    Workaround found! Many thanks to ice9 and boof from the ArchLinux forums (https://alderaan.archlinux.org/viewt...hp?pid=1107447) for the idea of downgrading the libcairo library.

    Here are the steps I followed for my 64-bit install of Ubuntu 12.10. I suppose the workaround is the same for the 32-bit version, except you change the libcairo package and the file system paths accordingly:

    1. Terminate your NX sessions
    2. cd ~/Downloads
    3. wget http://mirror.pnl.gov/ubuntu//pool/m...ntu2_amd64.deb
    4. mkdir libcairo
    5. dpkg -x libcairo2_1.10.2-6.1ubuntu2_amd64.deb libcairo/
    6. sudo mkdir /usr/lib/x86_64-linux-gnu/libcairo_orig
    7. sudo mv /usr/lib/x86_64-linux-gnu/libcairo.so.2* /usr/lib/x86_64-linux-gnu/libcairo_orig/
    8. sudo cp ~/Downloads/libcairo/usr/lib/x86_64-linux-gnu/libcairo.so.2* /usr/lib/x86_64-linux-gnu/
    9. Re-connect to your machine via NX.
    The modified for 32-bit instructions:

    1. Terminate your NX sessions
    2. cd ~/Downloads
    3. wget http://mirror.pnl.gov/ubuntu//pool/m...untu2_i386.deb
    4. mkdir libcairo
    5. dpkg -x libcairo2_1.10.2-6.1ubuntu2_i386.deb libcairo/
    6. sudo mkdir /usr/lib/i386-linux-gnu/libcairo_orig
    7. sudo mv /usr/lib/i386-linux-gnu/libcairo.so.2* /usr/lib/i386-linux-gnu/libcairo_orig/
    8. sudo cp ~/Downloads/libcairo/usr/lib/i386-linux-gnu/libcairo.so.2* /usr/lib/i386-linux-gnu/
    9. Re-connect to your machine via NX.


    Worked great for me. Thanks for the instructions!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •