Results 1 to 7 of 7

Thread: ACPI Time is one hour late since upgrade to 0.26

Hybrid View

  1. #1
    Join Date
    Aug 2012
    Beans
    20

    ACPI Time is one hour late since upgrade to 0.26

    I am running version 0.26 now. Since I upgraded the backend sends now the wrong wakeuptime to setwakeup.sh. It is probably connected to the new timetable feature in 0.26. The problem is now that mythbuntu wakes up one hour too late (since we are in time zone UTC+1) thus missing the scheduled recordings.
    The system time is set to UTC and the timeshift UTC+1 is correctly recognized while the system is live. Therefore, it is probably a bug in the system regarding the time handing over procedure from the backend to setwakeup.sh during the shutdown procedure.
    Does anybody else recognized the problem?
    Does anybody know if this bug has been detected for fixing?
    Does anybody know what I can enter into setwakeup.sh in order to have a quick fix until it is fixed in the mythbuntu development?

  2. #2
    Join Date
    Mar 2012
    Beans
    44

    Re: ACPI Time is one hour late since upgrade to 0.26

    I suffered from a similar problem in early 0.26 (August).
    Raised ticket http://code.mythtv.org/trac/ticket/10995.
    Later releases of 0.26 fixed it for me (UK based) but the ticket is still open. As a workround add 1 hour to StartupSecsBeforeRecording. You can do this in Mythweb.

  3. #3
    Join Date
    Aug 2012
    Beans
    20

    Re: ACPI Time is one hour late since upgrade to 0.26

    Thanks for the hint. It works as a workaround.
    Nevertheless, it is a little odd approach. In MythWeb I can enter 3600 secs, although in the backup setting you cannot enter more than 1200 secs and only the 1200 secs are shown even if I entered the 3600 secs in MythWeb. But as I said, it is a workaround solution until the bug is fixed in the system.

  4. #4
    Join Date
    Jul 2012
    Beans
    63

    Re: ACPI Time is one hour late since upgrade to 0.26

    As another workaround, you can tweak your setwakeup.sh.

    Replace
    Code:
    SECS=$1
    with
    Code:
    SECS=`expr $1 - 3600`
    I used this, because I will never ever remember to remove those additional 3600 secs from the startup time, but I will recognize if a recording fails, once the bug is fixed.
    Last edited by Rotak; November 12th, 2012 at 07:03 AM.

  5. #5
    Join Date
    Aug 2012
    Beans
    20

    Re: ACPI Time is one hour late since upgrade to 0.26

    Thanks, I was also thinking about tweaking setwakeup.sh, but was not sure about the exact code. Have not tried the option but looks reasonable.

  6. #6
    Join Date
    Aug 2012
    Beans
    20

    Re: ACPI Time is one hour late since upgrade to 0.26

    Looks like the problem disappeared now after I made a patch on 26th/Dec.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •