Results 1 to 10 of 11

Thread: 11.10 to 12.04.1 LTS distribution upgrade

Hybrid View

  1. #1
    Join Date
    Nov 2009
    Location
    Sofia, Bulgaria
    Beans
    302
    Distro
    Ubuntu 14.04 Trusty Tahr

    Question 11.10 to 12.04.1 LTS distribution upgrade

    Yesterday I made a distribution upgrade on my 11.10 install. I followed the instructions exactly, first I checked whether my system has got all of the most recent updates. I installed them and than I hit the distribution upgrade. I waited patiently for about an hour, maybe less. All the packages were downloaded and installed. Than a restart.
    Now the issue I'm having is that the desktop environment doesn't start. I'm gaining access to TTY1 and when I switch to TTY7, I see all of the messages you normally see during booting. There's a messages saying that the LightDM Display Manager daemon has failed to start... obviously. How can I recover from this? Where should I look for clues, maybe there's something missing
    Registered Linux User #534948

  2. #2
    Join Date
    Apr 2010
    Beans
    212

    Re: 11.10 to 12.04.1 LTS distribution upgrade

    sudo cat /var/log/lightdm/lightdm.log

    then paste the content
    Last edited by funicorn; October 21st, 2012 at 02:12 PM.

  3. #3
    Join Date
    Nov 2009
    Location
    Sofia, Bulgaria
    Beans
    302
    Distro
    Ubuntu 14.04 Trusty Tahr

    Post Re: 11.10 to 12.04.1 LTS distribution upgrade

    [+0.02s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.02s] DEBUG: Starting Light Display Manager 1.2.1. OID=0 PID=1235
    [+0.02s] DEBUG: Loaded configuration from /etc/lightdm/lightdm.conf
    [+0.02s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.02s] DEBUG: Registered seat module xlocal
    [+0.02s] DEBUG: Registered seat module xremote
    [+0.02s] DEBUG: Adding default seat
    [+0.02s] DEBUG: Starting seat
    [+0.02s] DEBUG: Starting new display for greeter
    [+0.02s] DEBUG: Starting local X display
    [+0.03s] DEBUG: X server :0 will replace Plymouth
    [+0.05s] DEBUG: Using VT 7
    [+0.20s] DEBUG: Activating VT 7
    [+0.20s] DEBUG: Logging to /var/log/lightdm/x-0.log
    [+0.38s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0
    [+0.38s] DEBUG: Launching X Server
    [+0.38s] DEBUG: Launching process 1279: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
    [+0.38s] DEBUG: Waiting for ready signal from X server :0
    [+0.38s] DEBuG: Aquired bus name org.freedesktop.DisplayManager
    [+0.38s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
    [+4.46s] DEBUG: Process 1279 exited with return value 127
    [+4.46s] DEBUG: X server stopped
    [+4.46s] DEBUG: removing X server authority /var/run/lightdm/root/:0
    [+4.46s] DEBUG: Releasing VT 7
    [+4.46s] DEBUG: Stopping Plymouth, X server failed to start
    [+4.47s] DEBUG: Display server stopped
    [+4.47s] DEBUG: Stopping display
    [+4.47s] DEBUG: Display stopped
    [+4.47s] DEBUG: Stopping X local seat, failed to start a display
    [+4.47s] DEBUG: Stopping seat
    [+4.47s] DEBUG: Seat stopped
    [+4.47s] DEBUG: Required seat has stopped
    [+4.47s] DEBUG: Stopping display manager
    [+4.47s] DEBUG: Display manager stopped
    [+4.47s] DEBUG: Stopping daemon
    [+4.47s] DEBUG: Exiting with return value 1
    Registered Linux User #534948

  4. #4
    Join Date
    Nov 2009
    Location
    Sofia, Bulgaria
    Beans
    302
    Distro
    Ubuntu 14.04 Trusty Tahr

    Lightbulb Re: 11.10 to 12.04.1 LTS distribution upgrade

    Hm... the issue I'm having looks almost exactly if not exactly like the one mentioned here:
    http://askubuntu.com/questions/16272...ati-video-card

    I wonder whether the fglrx driver fails on me...
    Registered Linux User #534948

  5. #5
    Join Date
    Nov 2009
    Location
    Sofia, Bulgaria
    Beans
    302
    Distro
    Ubuntu 14.04 Trusty Tahr

    Lightbulb Re: 11.10 to 12.04.1 LTS distribution upgrade

    All right, so my /var/log/lightdm/x-0.log states:

    (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found /usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: GlxInitVisuals2D

    Exactly like on the link I mentioned above. Hm... it makes me wonder, how can I purge the fglrx driver from command line
    That ATI video card... again....
    Registered Linux User #534948

  6. #6
    Join Date
    Nov 2009
    Location
    Sofia, Bulgaria
    Beans
    302
    Distro
    Ubuntu 14.04 Trusty Tahr

    Exclamation Re: 11.10 to 12.04.1 LTS distribution upgrade

    Hm... after purging the fglrx driver by doing this:
    sudo apt-get remove --purge xorg-driver-fglrx fglrx* sudo apt-get install --reinstall libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64 sudo dpkg-reconfigure xserver-xorgNow I only get a black screen after the system boots up
    Is there any way to stop the normal booting process ans gain access to tty1. How could I check what's going on?
    I'm starting to hate ATI....
    Registered Linux User #534948

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •