Results 1 to 10 of 16

Thread: Guitar Pro doesn't work after upgrade to 12.10

Hybrid View

  1. #1
    Join Date
    Nov 2010
    Beans
    93

    Guitar Pro doesn't work after upgrade to 12.10

    I upgraded yesterday to 12.10 and now guitar pro 6 stopped working. Since I had/have the 64bit version I used thisto install it and guitar pro worked without problems in 12.04.

    Now in 12.10 guitar pro will not launch. If I click on the the app through the dash nothing happens happens and if I execute launcher.sh in a terminal, the terminal immediately closes.

    Do you have any idea what the cause might be or how to diagnose the problem?

    Thanks in advance!

  2. #2
    Join Date
    Feb 2010
    Location
    WI USA
    Beans
    10,374
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Guitar Pro doesn't work after upgrade to 12.10

    Did you check compatibility prior to upgrade ? Try opening the the application via the terminal by typing the name and post the output in code tags using # symbol on the reply tool bar. The application is not available in the 12.10 software center and it looks like it was not easy to get running on 12.04.
    Infinite diversity in infinite combination.

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  3. #3
    Join Date
    Nov 2010
    Beans
    93

    Re: Guitar Pro doesn't work after upgrade to 12.10

    The app isn't officially compatible with 64bit systems in the first place and since 12.10 is not even out I doubt that there is any official compability with it (A quick google search does not bring any results concerning guitar pro and 12.10).

    I tried to run it from the terminal and it just says command not found when I type in GuitarPro which I believe was the name. Also I think normally the program runs by executing the launcher.sh but if I try to execute in the terminal, the terminal immediately closes so I can't even inspect any potential error outputs.

  4. #4
    Join Date
    Feb 2010
    Location
    WI USA
    Beans
    10,374
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Guitar Pro doesn't work after upgrade to 12.10

    You should be able to start almost any application from the terminal. Command not found usually indicates the name was not entered correctly. Try lower case.

    The correct package name will be displayed in the synaptic package manager if installed. 12.10 is based on Gnome 3.6 and 12.04 is based on 3.4 so there could be dependency problems.Program compatibility problems occurred during the switch from 3.2 to 3.4 also.

    To check compatibility with Gnome 3.6 you would have had contact the developer prior to upgrade. The two main problems are the application is not an official Ubuntu package and not 64 bit compatible. Bug reports for non official applications don't normally get a response.
    Infinite diversity in infinite combination.

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  5. #5
    Join Date
    Nov 2010
    Beans
    93

    Re: Guitar Pro doesn't work after upgrade to 12.10

    So I checked the dependencies and for some reason the program does complain:

    Code:
    /opt/GuitarPro6$ ldd GuitarPro | grep found./GuitarPro: /opt/GuitarPro6/./libz.so.1: version `ZLIB_1.2.3.3' not found (required by /usr/lib/i386-linux-gnu/libxml2.so.2)
    Does anybody know what libz.so.1 is and where I can find it? It's not in synaptic...

    Edit: Probably it's the other way around, I need zlib for libz.so.1 to work?

  6. #6
    Join Date
    Jul 2012
    Beans
    Hidden!

    Re: Guitar Pro doesn't work after upgrade to 12.10

    I haven't heard of Guitar Pro before but am interested to know the capabilities, and what
    you like/dislike about it. Thank's

  7. #7
    Join Date
    Nov 2010
    Beans
    93

    Re: Guitar Pro doesn't work after upgrade to 12.10

    Another problem is, I would like to execute to see launcher.sh to see whether it gives some errors. If I double click in nautilus, then I get an option to run it in an terminal. When I do that, it instantly closes. If I use the terminal and go to the directory and type launcher.sh, then the terminal says command not found. How do I execute the script from the terminal?

    Edit: Used sh launcher.sh and it complains about the missing library too:
    Code:
    ./GuitarPro: /opt/GuitarPro6/./libz.so.1: version `ZLIB_1.2.3.3' not found (required by /usr/lib/i386-linux-gnu/libxml2.so.2)
    Last edited by xedi; October 14th, 2012 at 08:35 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •