Results 1 to 3 of 3

Thread: GRUB wont show fedora partition on start up

Hybrid View

  1. #1
    Join Date
    Oct 2012

    GRUB wont show fedora partition on start up

    I've spent countless hours trying to solve this with no luck. I tried ubuntu's boot repair but that still didn't work. It generated a report which you can find here. Hopefully there is enough information provided in that report to solve the issue but if you guys need more info I'll gladly respond. Thanks in advance.

  2. #2
    Join Date
    Mar 2011
    Pizza Hut
    Kubuntu 13.10 Saucy Salamander

    Re: GRUB wont show fedora partition on start up

    Have you tried:
    sudo update-grub
    Ubuntu user #35115 - Linux user #555707 - My Ubuntu Wik page
    Join the Ubuntu Forums' IRC room (#ubuntuforums on!

  3. #3
    Join Date
    Jun 2009
    Chicago Suburbs
    Ubuntu 14.04 Trusty Tahr

    Re: GRUB wont show fedora partition on start up

    +1 on dniMretsaM suggestion.

    Fedora's default install usually uses LVM and grub has issues finding that. The work around was mounting it (and installing the lvm2 driver) before running the sudo update-grub. But it looks like you just installed to a ext4 partition with a separate /boot. Grub2's os-prober should find it. If not you can copy Fedora boot stanza to 40_custom.
    For more info on UEFI boot install & repair - Updated Oct 2015:
    Please use Thread Tools above first post to close thread when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts