Results 1 to 7 of 7

Thread: Installing IDLE compatible with python 2.5.6

Hybrid View

  1. #1
    Join Date
    Oct 2012
    Beans
    6

    Question Installing IDLE compatible with python 2.5.6

    SOOOO I am trying to follow this course from MIT that teaches an introduction to computer science and programming, in which they use Python 2.5.6 as a teaching tool. Does anyone know how to install a 2.5.6 compatible version of IDLE? The course is available through http://ocw.mit.edu (opencourseware) and can be viewed on youtube at http://www.youtube.com/watch?v=bX3jv...BE3D6CA77BB8F7
    Last edited by cariboo907; October 8th, 2012 at 11:49 PM. Reason: Remove bold formatting to comply with C of C

  2. #2
    Join Date
    Jun 2011
    Location
    United Kingdom
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Installing IDLE compatible with python 2.5.6

    Why are they using 2.5.x? Python is on 2.7.x (and 3.x!) and has been for a while. I believe Ubuntu has dropped it from their repositories.

    That said, this: http://welcometoubuntu.blogspot.co.u...untu-1004.html explains how to do it (works for all ubuntu releases AFAIK: nothing 10.04-specific in there). I wouldn't make python 2.5 the default python though, I think stuff may break.

  3. #3
    Join Date
    Oct 2012
    Beans
    6

    Re: Installing IDLE compatible with python 2.5.6

    it is opencourseware http://www.youtube.com/watch?v=bX3jv...BE3D6CA77BB8F7 the class is from spring 2011.

  4. #4
    Join Date
    Oct 2012
    Beans
    6

    Re: Installing IDLE compatible with python 2.5.6

    http://ocw.mit.edu and thank you for the warm welcome. also i have python 2.5.x 2.7.x and 3 installed already as well, along with both IDLE's for them. just can't figure out how to install the IDLE compatible with 2.5.x
    Last edited by SubRosa3; October 7th, 2012 at 08:07 PM.

  5. #5
    Join Date
    Jun 2011
    Location
    United Kingdom
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Installing IDLE compatible with python 2.5.6

    Quote Originally Posted by SubRosa3 View Post
    it is opencourseware http://www.youtube.com/watch?v=bX3jv...BE3D6CA77BB8F7 the class is from spring 2011.
    It wasn't a serious question, I was just amazed. Good choice, those lectures are nice.

    Quote Originally Posted by SubRosa3 View Post
    http://ocw.mit.edu and thank you for the warm welcome. also i have python 2.5.x 2.7.x and 3 installed already as well, along with both IDLE's for them. just can't figure out how to install the IDLE compatible with 2.5.x
    Do you really need IDLE? I imagine you can get it from somewhere (sorry, don't knoww for sure), but if not, what's wrong with a text editor and the command line?

  6. #6
    Join Date
    Oct 2012
    Beans
    6

    Re: Installing IDLE compatible with python 2.5.6

    definitely need IDLE. I can't find it anywhere either.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •