Results 1 to 8 of 8

Thread: How to force stop pulseaudio service

Hybrid View

  1. #1
    Join Date
    Apr 2010
    Beans
    12

    How to force stop pulseaudio service

    Hello,

    I'm trying to get the proper suspend/resume functionality in my desktop computer (Ubuntu 12.04). It's running MythTV (backend and frontend) with the help of Hauppauge 1300 DVB-T tuner card and doesn't work currently - after the resume myth is reporting that all tuner cards are in use.
    To fix it I want to restart myth and tuner modules:
    1) stop mythbackend
    2) unload all tuner card modules (cx88_dvb, cx88_blackbird, cx88xx, cx88_alsa.. etc)
    and on resume start it again.
    But it seems that I cannot unload cx88_alsa because pulseaudio is using it. I've tried
    Code:
    sudo service pulseaudio stop
    but it didn't stop the daemon.
    When I edited the /etc/pulse/client.conf and set:
    Code:
    autospawn = no
    daemon-binary = /usr/bin/true
    then I could stop the service but after the reboot I haven't got any sound.
    So what is the proper way to handle pulseaudio stop?

  2. #2
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to force stop pulseaudio service

    service pulseaudio force-stop
    maybe ??

  3. #3
    Join Date
    Apr 2010
    Beans
    12

    Re: How to force stop pulseaudio service

    Quote Originally Posted by BicyclerBoy View Post
    service pulseaudio force-stop
    maybe ??
    Yes, I know but the same effect - didn't stop the pulseaudio daemon.

  4. #4
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to force stop pulseaudio service

    ps ch -C pulseaudio -o pid

    Then using kill on the pid value.

    Or start the daemon with option use-pid-file=, then use the value in that file to kill it..
    It respawns unless set not to (as you have done)

    pasuspender docs mention it is able to do this ?

  5. #5
    Join Date
    Apr 2010
    Beans
    12

    Re: How to force stop pulseaudio service

    Quote Originally Posted by BicyclerBoy View Post
    ps ch -C pulseaudio -o pid

    Then using kill on the pid value.

    Or start the daemon with option use-pid-file=, then use the value in that file to kill it..
    It respawns unless set not to (as you have done)

    pasuspender docs mention it is able to do this ?
    Thanks, I'll try this. But I'm thinking that I'm doing it wrong because I have a default per-user pulse audio instance. So that's the reason why stopping it by service pulseaudio stop doesn't work.

    I think I need to kill the pulseaudio as you suggested (or by pulseaudio -k, with autospawn=no) but after resume start pulseuadio as a user which was running pulse before suspend (hmmm, how to do it?)

  6. #6
    Join Date
    Oct 2008
    Location
    colachel
    Beans
    513
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: How to force stop pulseaudio service

    run the below command in terminal

    killall -9 pulseaudio

    or

    ps -ax | grep -i pulseaudio

    it list the PID value

    then run

    kill -9 PID

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •