Results 1 to 2 of 2

Thread: Scilab JVM/libjava error

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Beans
    9

    Question Scilab JVM/libjava error

    Hi. I installed Scilab advaced client om my Ubuntu x86_64 box from the Ubuntu software center. The scilab-cli works great, but the gui scilab-adv-cli fails to load due to a JVM/libjava error.

    Code:
    Could not load JVM dynamic library (libjava).
    Error: libjvm.so: cannot open shared object file: No such file or directory
    If you are using a binary version of Scilab, please report a bug http://bugzilla.scilab.org/.
    If you are using a self-built version of Scilab, update the script bin/scilab to provide the path to the JVM.
    The problem might be related to SELinux. Try to deactivate it.
    Please also check that you are not trying to run Scilab 64 bits on a 32 bits system (or vice versa).
    
    Scilab cannot open JVM library.
    I have disabled selinux as is recomended, but it don't help. Need scilab for my studies, so any help would be very appreciated!

  2. #2
    Join Date
    Jan 2006
    Beans
    1

    Re: Scilab JVM/libjava error

    Quote Originally Posted by kimothy1987 View Post
    Hi. I installed Scilab advaced client om my Ubuntu x86_64 box from the Ubuntu software center. The scilab-cli works great, but the gui scilab-adv-cli fails to load due to a JVM/libjava error.

    Code:
    Could not load JVM dynamic library (libjava).
    Error: libjvm.so: cannot open shared object file: No such file or directory
    If you are using a binary version of Scilab, please report a bug http://bugzilla.scilab.org/.
    If you are using a self-built version of Scilab, update the script bin/scilab to provide the path to the JVM.
    The problem might be related to SELinux. Try to deactivate it.
    Please also check that you are not trying to run Scilab 64 bits on a 32 bits system (or vice versa).
    
    Scilab cannot open JVM library.
    I have disabled selinux as is recomended, but it don't help. Need scilab for my studies, so any help would be very appreciated!
    Update Scilab and install openjdk than it should run
    Last edited by j.behrendt; December 5th, 2012 at 12:55 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •