Page 1 of 3 123 LastLast
Results 1 to 10 of 63

Thread: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

Hybrid View

  1. #1
    Join Date
    Jun 2012
    Beans
    11

    Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    So I've installed Ubuntu 12.04 LTS on my laptop that uses a Centrino Wireless-N + WiMAX 6150. I try to connect to my college campus wifi, which it recognizes, but whenever I put in my login information, it attempts to connect for a while before it spits out the "Wireless Network Authentication Required" screen before it finally disconnects from the wireless. It does this ad nauseum. I am able to get a wired connection, which is what I am currently using right now.

    I did try to do my homework on this, which ultimately lead me here. I've been to http://intellinuxwireless.org/?n=Info to make sure my drivers up to date, and then I found out that since I'm using 12.04, all the drivers should have been up to date anyway. I also found out that kernels later than 2.6.38 are broken with the Centrino Wireless-N + WiMAX 6150 wireless cards, but since this was a fresh install of Ubuntu and not an upgrade, I didn't think this was a feasible option and that it really apply to me. So, I'm currently at a loss.

    Also, after poking around the forums for a bit, here are my outputs of the following:

    Code:
    cat /etc/lsb-release; uname -a 
    lspci -nnk | grep -iA2 net 
    lsusb 
    iwconfig 
    rfkill list all 
    lsmod
    My outputs:
    Code:
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"
    Linux WLT 3.2.0-25-generic #40-Ubuntu SMP Wed May 23 20:30:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    
    02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N + WiMAX 6150 [8086:0885] (rev 67)
        Subsystem: Intel Corporation Centrino Wireless-N + WiMAX 6150 BGN [8086:1305]
        Kernel driver in use: iwlwifi
    --
    04:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
        Subsystem: ASUSTeK Computer Inc. Device [1043:1851]
        Kernel driver in use: atl1c
    
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 003: ID 8087:07d6 Intel Corp. 
    Bus 001 Device 004: ID 13d3:5710 IMC Networks 
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              
    eth0      no wireless extensions.
    
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: asus-wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    2: asus-wimax: WiMAX
        Soft blocked: yes
        Hard blocked: no
    
    Module                  Size  Used by
    dm_crypt               23125  1 
    rfcomm                 47604  0 
    parport_pc             32866  0 
    ppdev                  17113  0 
    bnep                   18281  2 
    bluetooth             180104  10 rfcomm,bnep
    snd_hda_codec_hdmi     32474  1 
    snd_hda_codec_realtek   223867  1 
    joydev                 17693  0 
    arc4                   12529  2 
    snd_hda_intel          33773  3 
    snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              13668  1 snd_hda_codec
    snd_pcm                97188  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi           13324  0 
    snd_rawmidi            30748  1 snd_seq_midi
    snd_seq_midi_event     14899  1 snd_seq_midi
    snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
    asus_nb_wmi            12710  0 
    asus_wmi               24456  1 asus_nb_wmi
    sparse_keymap          13890  1 asus_wmi
    snd_timer              29990  2 snd_pcm,snd_seq
    snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
    snd                    78855  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    iwlwifi               332672  0 
    mac80211              506816  1 iwlwifi
    mac_hid                13253  0 
    soundcore              15091  1 snd
    psmouse                87692  0 
    serio_raw              13211  0 
    uvcvideo               72627  0 
    videodev               98259  1 uvcvideo
    mei                    41616  0 
    snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
    cfg80211              205544  2 iwlwifi,mac80211
    v4l2_compat_ioctl32    17128  1 videodev
    lp                     17799  0 
    parport                46562  3 parport_pc,ppdev,lp
    atl1c                  41717  0 
    i915                  468745  4 
    wmi                    19256  1 asus_wmi
    drm_kms_helper         46978  1 i915
    drm                   242038  5 i915,drm_kms_helper
    i2c_algo_bit           13423  1 i915
    video                  19596  1 i915
    Thank you greatly in advance!

  2. #2
    Join Date
    Jun 2012
    Beans
    11

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Bump. I need some help please and thanks.

  3. #3
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,234
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Just to humor an old driver dawg, please try:
    Code:
    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi 11n_disable=1
    Any improvement? If so, we'll write a quick file to make it persistent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #4
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,738
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Hi, I can tell you things that usually keeps that driver from connecting but it gets harder to fix certain issues when a college comes into play, because it may require changing router settings and such but we will start with the basics.

    Does it connect at home?
    Please do:
    Code:
    echo "blacklist asus_wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Code:
    echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi
    does it connect know? if not post the output of:
    Code:
    nm-tool
    sudo cat /var/log/syslog | grep -e iwl -e firmware -e wpa -e wlan -e etork | tail -n55
    Thanks

  5. #5
    Join Date
    Jun 2012
    Beans
    11

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Quote Originally Posted by wildmanne39 View Post
    Hi, I can tell you things that usually keeps that driver from connecting but it gets harder to fix certain issues when a college comes into play, because it may require changing router settings and such but we will start with the basics.

    Does it connect at home?
    I'm apologize, I forgot to mention that I can't connect to any wireless. I've tried with my home wifi, my friend's wifi, and my campus's wifi and had no such luck.

    Quote Originally Posted by wildmanne39 View Post
    Please do:
    Code:
    echo "blacklist asus_wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Code:
    echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi
    When I did this:
    Code:
    sudo modprobe -v iwlwifi
    I got this error message:
    Code:
    insmod /lib/modules/3.2.0-25-generic/kernel/net/wireless/cfg80211.ko 
    insmod /lib/modules/3.2.0-25-generic/kernel/net/mac80211/mac80211.ko 
    insmod /lib/modules/3.2.0-25-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko lln_disable=1
    FATAL: Error inserting iwlwifi (/lib/modules/3.2.0-25-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    Quote Originally Posted by wildmanne39 View Post
    does it connect know? if not post the output of:
    Code:
    nm-tool
    sudo cat /var/log/syslog | grep -e [ -e firmware -e wpa -e wlan -e etork | tail -n55
    Thanks
    Code:
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: eth0  [Auto Ethernet] ------------------------------------------------
      Type:              Wired
      Driver:            atl1c
      State:             connected
      Default:           yes
      HW Address:        C8:60:00:4D:50:B9
    
      Capabilities:
        Carrier Detect:  yes
        Speed:           100 Mb/s
    
      Wired Properties
        Carrier:         on
    
      IPv4 Settings:
        Address:         192.168.0.100
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.0.1
    
        DNS:             192.168.0.1
    
    Jun 26 13:39:48 WLT NetworkManager[854]: <info> (wlan0): bringing up device.
    Jun 26 13:39:48 WLT NetworkManager[854]: <info> (wlan0): deactivating device (reason 'managed') [2]
    Jun 26 13:49:53 WLT NetworkManager[854]: <info> (wlan0): now unmanaged
    Jun 26 13:49:53 WLT NetworkManager[854]: <info> (wlan0): device state change: unavailable -> unmanaged (reason 'sleeping') [20 10 37]
    Jun 26 13:51:09 WLT kernel: [  626.396863] iwlwifi 0000:02:00.0: restoring config space at offset 0xf (was 0x100, writing 0x105)
    Jun 26 13:51:09 WLT kernel: [  626.396901] iwlwifi 0000:02:00.0: restoring config space at offset 0x4 (was 0x4, writing 0xde800004)
    Jun 26 13:51:09 WLT kernel: [  626.396909] iwlwifi 0000:02:00.0: restoring config space at offset 0x3 (was 0x0, writing 0x10)
    Jun 26 13:51:09 WLT kernel: [  626.396921] iwlwifi 0000:02:00.0: restoring config space at offset 0x1 (was 0x100000, writing 0x100006)
    Jun 26 13:51:10 WLT NetworkManager[854]: <info> (wlan0): now managed
    Jun 26 13:51:10 WLT NetworkManager[854]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
    Jun 26 13:51:10 WLT NetworkManager[854]: <info> (wlan0): bringing up device.
    Jun 26 13:51:10 WLT NetworkManager[854]: <info> (wlan0): deactivating device (reason 'managed') [2]
    Jun 27 16:36:47 WLT kernel: [   15.845484] iwlwifi 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    Jun 27 16:36:47 WLT kernel: [   15.845497] iwlwifi 0000:02:00.0: setting latency timer to 64
    Jun 27 16:36:47 WLT kernel: [   15.845703] iwlwifi 0000:02:00.0: pci_resource_len = 0x00002000
    Jun 27 16:36:47 WLT kernel: [   15.845706] iwlwifi 0000:02:00.0: pci_resource_base = ffffc900057bc000
    Jun 27 16:36:47 WLT kernel: [   15.845708] iwlwifi 0000:02:00.0: HW Revision ID = 0x67
    Jun 27 16:36:47 WLT kernel: [   15.845797] iwlwifi 0000:02:00.0: irq 52 for MSI/MSI-X
    Jun 27 16:36:47 WLT kernel: [   15.845835] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N + WiMAX 6150 BGN, REV=0x84
    Jun 27 16:36:47 WLT kernel: [   15.846070] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
    Jun 27 16:36:47 WLT kernel: [   15.856421] iwlwifi 0000:02:00.0: device EEPROM VER=0x557, CALIB=0x6
    Jun 27 16:36:47 WLT kernel: [   15.856425] iwlwifi 0000:02:00.0: Device SKU: 0X150
    Jun 27 16:36:47 WLT kernel: [   15.856427] iwlwifi 0000:02:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
    Jun 27 16:36:47 WLT kernel: [   15.856578] iwlwifi 0000:02:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
    Jun 27 16:36:47 WLT kernel: [   15.922400] iwlwifi 0000:02:00.0: loaded firmware version 41.28.5.1 build 33926
    Jun 27 16:36:47 WLT kernel: [   15.944693] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
    Jun 27 16:36:47 WLT kernel: [   16.195544] psmouse serio4: elantech: assuming hardware version 3 (with firmware version 0x450f01)
    Jun 27 16:36:47 WLT NetworkManager[862]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/pci0000:00/0000:00:1c.1/0000:02:00.0/net/wlan0, iface: wlan0)
    Jun 27 16:36:47 WLT NetworkManager[862]:    SCPlugin-Ifupdown: device added (path: /sys/devices/pci0000:00/0000:00:1c.1/0000:02:00.0/net/wlan0, iface: wlan0): no ifupdown configuration found.
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> monitoring kernel firmware directory '/lib/firmware'.
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> (wlan0): using nl80211 for WiFi device control
    Jun 27 16:36:47 WLT NetworkManager[862]: <warn> (wlan0): driver supports Access Point (AP) mode
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> (wlan0): new 802.11 WiFi device (driver: 'iwlwifi' ifindex: 3)
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> (wlan0): exported as /org/freedesktop/NetworkManager/Devices/0
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> (wlan0): now managed
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> (wlan0): bringing up device.
    Jun 27 16:36:47 WLT NetworkManager[862]: <info> (wlan0): deactivating device (reason 'managed') [2]
    Jun 27 16:36:47 WLT kernel: [   16.767952] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    Jun 27 16:58:49 WLT NetworkManager[862]:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/pci0000:00/0000:00:1c.1/0000:02:00.0/net/wlan0, iface: wlan0)
    Jun 27 16:58:49 WLT NetworkManager[862]: <info> (wlan0): now unmanaged
    Jun 27 16:58:49 WLT NetworkManager[862]: <info> (wlan0): device state change: unavailable -> unmanaged (reason 'removed') [20 10 36]
    Jun 27 16:58:49 WLT kernel: [ 1336.399337] iwlwifi 0000:02:00.0: PCI INT A disabled
    Jun 27 16:59:06 WLT kernel: [ 1353.565218] iwlwifi: Unknown parameter `lln_disable'
    Jun 27 16:59:32 WLT kernel: [ 1378.881020] iwlwifi: Unknown parameter `lln_disable'
    Jun 27 17:08:44 WLT kernel: [ 1930.078805]  <IRQ>  [<ffffffff810672af>] warn_slowpath_common+0x7f/0xc0
    Jun 27 17:08:44 WLT kernel: [ 1930.078826]  [<ffffffff810673a6>] warn_slowpath_fmt+0x46/0x50
    Jun 27 17:21:00 WLT NetworkManager[862]: <info> kernel firmware directory '/lib/firmware' changed
    Jun 27 17:22:09 WLT kernel: [   17.001380] iwlwifi: Unknown parameter `lln_disable'
    Jun 27 17:22:09 WLT kernel: [   17.292539] psmouse serio4: elantech: assuming hardware version 3 (with firmware version 0x450f01)
    Jun 27 17:22:10 WLT NetworkManager[828]: <info> monitoring kernel firmware directory '/lib/firmware'.
    Jun 27 19:22:40 WLT kernel: [   15.906406] iwlwifi: Unknown parameter `lln_disable'
    Jun 27 19:22:40 WLT kernel: [   16.191383] psmouse serio4: elantech: assuming hardware version 3 (with firmware version 0x450f01)
    Jun 27 19:22:41 WLT NetworkManager[894]: <info> monitoring kernel firmware directory '/lib/firmware'.
    Jun 27 19:42:38 WLT kernel: [ 1212.586899] iwlwifi: Unknown parameter `lln_disable'
    Thank you.

  6. #6
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,738
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Hi, I did not see chili555 there when I posted we must have been posting at the same time, I will let him handle this since he was here first and he is the best at these issues.
    Last edited by Wild Man; June 28th, 2012 at 01:40 AM.

  7. #7
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,234
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Haha! I'm not at all sure I know any more than the Wild Man. Please post:
    Code:
    cat /etc/modprobe.d/iwlwifi.conf
    If it says anything different than:
    Code:
    options iwlwifi 11n_disable=1
    ...then you'll net to edit the file to make it so:
    Code:
    sudo gedit /etc/modprobe.d/iwlwifi.conf
    Amend, proofread and save. Close gedit. Now do:
    Code:
    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi
    Any errors, warnings, smoke or sparks? Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    done. but changed to /etc/modprobe.d | grep iwl. response was iwl.conf. The iwl was in bold.

  9. #9
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    rebooted and same issue: will not connect.

    Ran :
    Code:
    gksudo gedit /etc/modprobe.d/iwl.conf
    the following text was in box:

    [CODE]options iwlwifi 11n_disable=1[CODE]


    A question: should the gedit command have been [CODE] gksudo gedit /etc/modprobe.d/iwlwifi.conf [CODE]

    With the iwl.conf changed to iwlwifi.conf?
    Last edited by pauleskey; May 13th, 2013 at 05:54 PM.

  10. #10
    Join Date
    May 2012
    Beans
    8

    Re: Centrino Wireless-N + WiMAX 6150 recognizes Wifi but doesn't connect

    Thanks. Problem is resolved. I used gedit and pasted

    Code:
    options iwlwifi bt_coex_active=0
    Connects after numerous reboots and is a very fast connection. No unintended consequences as of yet. Please let me know if you think this may cause problems down the line.... Thanks again. I appreciate it.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •