Results 1 to 10 of 10

Thread: Mytharchive error

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Beans
    35

    Mytharchive error

    Hi,
    I'm using mythbuntu 11.10
    I installed mytharchive and tried to create a DVD from a recording.
    It failed with the error
    "cannot write mode I as jpeg"
    log implied error was from line 425 of /usr/lib/python/dist-packages/PIL/jpegimageplugin.py
    Can anyone advise as to what is going wrong.
    If I try to create the DVD using the simple autostart DVD with no menu etc it seems to work ok but would like to create with menus etc.
    I've tried googling but am getting nowhere and I know little about python....
    I suspect the error occurs when an attempt is made to extract a frame to use as a menu thumbnail. Could the issue be that the script did not anticipate the codec/format used in the UK digital terrestiral trasnmissions DVB-T?
    Thanks
    Last edited by Leechpool; April 17th, 2012 at 12:02 PM. Reason: Adding detail

  2. #2
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mytharchive error

    I've made DVDs from similar DVB-T recordings..but not using 11.10..

    I'd guess there is a missing dependency for package "libmng1".

    The python file in your error log has a different path(s) on my PC..
    /usr/lib/python2.6/...
    & /usr/lib/python2.7/...

  3. #3
    Join Date
    Jun 2007
    Beans
    49

    Re: Mytharchive error

    Using 12.04 and myth 0.25 I have the same error as @BicyclerBoy, but there also seems to be a permissions problem.

    Code:
    Truncated text = 
    chmod: changing permissions of `/var/lib/mytharchive/temp/': Operation not permitted
    ------------------------------------------------------------
    Traceback (most recent call last):
      File "/usr/share/mythtv/mytharchive/scripts/mythburn.py", line 5182, in main
        processJob(job)
      File "/usr/share/mythtv/mytharchive/scripts/mythburn.py", line 4891, in processJob
        createMenu(format, dpi, files.length)
      File "/usr/share/mythtv/mytharchive/scripts/mythburn.py", line 3552, in createMenu
        bgimage.save(os.path.join(getTempPath(),"background-%s.jpg" % page),"JPEG", quality=99)
      File "/usr/lib/python2.7/dist-packages/PIL/Image.py", line 1439, in save
        save_handler(self, fp, filename)
      File "/usr/lib/python2.7/dist-packages/PIL/JpegImagePlugin.py", line 425, in _save
        raise IOError("cannot write mode %s as JPEG" % im.mode)
    IOError: cannot write mode I as JPEG
    ------------------------------------------------------------

  4. #4
    Join Date
    Mar 2008
    Beans
    1,086

    Re: Mytharchive error

    Recordings files are usually best stored under /var/lib/mythtv/ of course, but mytharchive itself is mostly a front-end activity initiated by the main user account, and so I found I always had permission problems with mytharchive unless I put mytharchive's temp working directory under the main user's home directory, rather than under /var/lib/mythtv/

    That said, in my own experience mytharchive has just not worked very well when it has worked at all since around Mythtv 0.20 or so. So consequently now, on the rare occasion when I want to make a DVD of a show or group of shows, I tend just to use nuvexport to export the recording(s) to a working directory and then use a 3rd-party tool like DeVeDe to transcode and prepare the actual .iso file for burning. Fewer synch issues, fewer coasters, generally a smoother experience.

  5. #5
    Join Date
    Jun 2007
    Beans
    49

    Re: Mytharchive error

    Thanks for the advice. But I can't find nuvexport. I recall using it several years ago. Is it still part of myth?

    And how do I change the mytharchive working directory? I can't find the entry among the myth setup menus.

    Thanks.

  6. #6
    Join Date
    Mar 2008
    Beans
    1,086

    Re: Mytharchive error

    nuvexport has been back in Mythtv since about 0.23.

    Mytharchive is a frontend utility. Its params are usually set from the frontend setup; see here: http://www.mythtv.org/wiki/User_Manu...ideos_Settings under "MythArchive Settings"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •