Results 1 to 9 of 9

Thread: How To restore Firefox as default browser for Thunderbird

Hybrid View

  1. #1
    Join Date
    Jun 2005
    Location
    Coimbatore, India
    Beans
    182
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Exclamation How To restore Firefox as default browser for Thunderbird

    In Kubuntu 11.10, my default mail and browser applications are Thunderbird and Firefox respectively.

    After installing Google Chrome (primarily for its integrated PDF viewing capabilities) I found that Thunderbird was suddenly opening http/https links in Google Chrome rather than Firefox.

    After double checking that Google Chrome was not my default browser and that Firefox was my default browser, I still experienced the same behaviour.

    After a search, I found this link that explained what happened in a Fedora setup:

    http://www.geeklab.info/2011/05/love...m-thunderbird/

    I did what was advised there:

    1. sudo edit /usr/share/applications/defaults.list

    2. Change

    Code:
    [Default Applications]
    text/html=google-chrome.desktop
    text/xml=google-chrome.desktop
    application/xhtml_xml=google-chrome.desktop
    x-scheme-handler/http=google-chrome.desktop
    x-scheme-handler/https=google-chrome.desktop
    x-scheme-handler/ftp=google-chrome.desktop
    to

    3.
    Code:
    [Default Applications]
    text/html=firefox.desktop
    text/xml=firefox.desktop
    application/xhtml_xml=firefox.desktop
    x-scheme-handler/http=firefox.desktop
    x-scheme-handler/https=firefox.desktop
    x-scheme-handler/ftp=firefox.desktop
    Note that in Kubuntu it is firefox rather than mozilla-firefox that is the replacement string.

    I do not know how this default setting happened in Kubuntu as gvfs-open is not installed. Anyway, the default was set in a sneaky fashion on my system without my explicit intervention, and I am grateful that David at GeekLab found out what had happened and how to fix it.

    I hope this helps others.

  2. #2
    Join Date
    Aug 2011
    Location
    Auckland, New Zealand
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How To restore Firefox as default browser for Thunderbird

    Thanks for posting this. I was having similar problems (I run Ubuntu 10.10 with the Stable Thunderbird and Firefox PPAs) and hadn't been able to find much else useful til I found this thread....

    That said my defaults.list didn't have the same stuff in it.

    I'd simultaneously posted to the NZLUG and one of the contributors there suggested the following:
    That might be true. Use gconf-editor and check the following: /desktop/gnome/url-handlers/http/ /desktop/gnome/url-handlers/https/
    I checked these and whilst http was set up as 'firefox %s', https was set up with 'sensible-browser %s' (and running this called Chromium).

    Changing it to Firefox appears to have resolved my problems.

    Hope this is of assistance to others, thus my posting it here. Cheers.

  3. #3
    Join Date
    Sep 2009
    Beans
    2

    Re: How To restore Firefox as default browser for Thunderbird

    Thanks, this solution works on kubuntu 12.04 as well.

  4. #4
    Join Date
    Aug 2011
    Location
    Auckland, New Zealand
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How To restore Firefox as default browser for Thunderbird

    I just switched from Ubuntu 10.10 to Xubuntu 12.04. With no gconf-editor shipped (and seemingly a list of package dependencies a mile long when I looked at installing it) I took a different approach. in /etc/alternatives I did this:
    Code:
    root@hawkeye:/etc/alternatives# ls -l | grep browser
    lrwxrwxrwx 1 root root  25 Mar 14 20:50 gnome-www-browser -> /usr/bin/chromium-browser
    
    (irrelevant lines removed)
    
    lrwxrwxrwx 1 root root  25 Mar 14 20:50 x-www-browser -> /usr/bin/chromium-browser
    
    root@hawkeye:/etc/alternatives# rm gnome-www-browser 
    root@hawkeye:/etc/alternatives# rm x-www-browser 
    root@hawkeye:/etc/alternatives# ln -s /usr/bin/firefox gnome-www-browser
    root@hawkeye:/etc/alternatives# ln -s /usr/bin/firefox x-www-browser
    This was provoked by having similar browser-inconsistency problems with links sent to me via Instant Messenger (pidgin).... they all seemed to open in chromium despite default-browser state being pointed at Firefox.

    A bit hackery, but so far seems to work. Anyone aware of an equivalent to gconf-editor for Xfce?

  5. #5
    Join Date
    Jan 2008
    Beans
    13

    Re: How To restore Firefox as default browser for Thunderbird

    HI,
    indeed the easiest solution is to simply do the following in Firefox:
    Edit->Preference -> Advanced -> General -> Set Firefox as default (check now)
    and restart Thunderbird.
    no need of extra settings.
    see you.

  6. #6
    Join Date
    Aug 2011
    Location
    Auckland, New Zealand
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How To restore Firefox as default browser for Thunderbird

    Yeah, er, no... no such menu item.

    My little hack stopped working after a couple of weeks, fortunately a local guru posted the following instructions onto my blog in response to an article I posted:



    Code:
      sudo update-alternatives --config x-www-browser
    Perfect.

  7. #7
    Join Date
    Feb 2009
    Location
    Cymru (Wales)
    Beans
    58
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: How To restore Firefox as default browser for Thunderbird

    Quote Originally Posted by NGSG View Post
    HI,
    indeed the easiest solution is to simply do the following in Firefox:
    Edit->Preference -> Advanced -> General -> Set Firefox as default (check now)
    and restart Thunderbird.
    no need of extra settings.
    see you.
    Nice one. That worked just fine for me. Another annoying quirk ironed out. Thanks.

    P

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •