Page 1 of 2 12 LastLast
Results 1 to 10 of 85

Thread: Can't connect to wireless after 11.10 upgrade

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Beans
    22

    Can't connect to wireless after 11.10 upgrade

    11.10 upgrade - can see networks but connection times out
    I using an ASUS-U56E netbook. I just upgraded then installed 11.10 and the wireless stopped connecting. I can see all the networks but when I try to connect it just times out. Here is some basic information to start.


    Centrino Wireless-N + WiMAX 6150 (Rev 67) -iwlagn driver

    #iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11bgn ESSID:off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=15 dBm
    Retry long limit:7 RTS thr:off Fragment thr:off
    Power Management:on

    #rfkill list all

    0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: asus-wimax: WiMAX
    Soft blocked: no
    Hard blocked: no
    2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

    #lsmod
    Module Size Used by
    parport_pc 36962 0
    ppdev 17113 0
    bnep 18436 2
    rfcomm 47946 0
    bluetooth 166112 10 bnep,rfcomm
    snd_hda_codec_hdmi 32040 1
    snd_hda_codec_realtek 330769 1
    binfmt_misc 17540 1
    joydev 17693 0
    arc4 12529 2
    snd_hda_intel 33390 2
    snd_hda_codec 104802 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel
    snd_hwdep 13668 1 snd_hda_codec
    snd_pcm 96755 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi 13324 0
    snd_rawmidi 30547 1 snd_seq_midi
    snd_seq_midi_event 14899 1 snd_seq_midi
    snd_seq 61896 2 snd_seq_midi,snd_seq_midi_event
    snd_timer 29991 2 snd_pcm,snd_seq
    snd_seq_device 14540 3 snd_seq_midi,snd_rawmidi,snd_seq
    uvcvideo 72711 0
    videodev 93004 1 uvcvideo
    v4l2_compat_ioctl32 17083 1 videodev
    asus_nb_wmi 12517 0
    asus_wmi 20035 1 asus_nb_wmi
    sparse_keymap 13890 1 asus_wmi
    snd 68266 14 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,s nd_seq,snd_timer,snd_seq_device
    wmi 19256 1 asus_wmi
    iwlagn 314213 0
    mac80211 310872 1 iwlagn
    i915 566711 3
    cfg80211 199587 2 iwlagn,mac80211
    drm_kms_helper 42558 1 i915
    psmouse 73882 0
    drm 236330 4 i915,drm_kms_helper
    serio_raw 13166 0
    soundcore 12680 1 snd
    snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
    lp 17799 0
    i2c_algo_bit 13423 1 i915
    mei 41480 0
    video 19412 1 i915
    parport 46562 3 parport_pc,ppdev,lp
    xhci_hcd 78641 0
    ahci 26002 2
    libahci 26861 1 ahci
    atl1c 41643 0

    #lshw -C network
    *-network
    description: Wireless interface
    product: Centrino Wireless-N + WiMAX 6150
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: wlan0
    version: 67
    serial: 40:25:c2:52:02:f0
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-12-generic firmware=41.28.5.1 build 33926 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
    resources: irq:50 memory:de800000-de801fff
    *-network
    description: Ethernet interface
    product: AR8151 v2.0 Gigabit Ethernet
    vendor: Atheros Communications
    physical id: 0
    bus info: pci@0000:04:00.0
    logical name: eth0
    version: c0
    serial: 14:da:e9:4f:2a:51
    size: 100Mbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=192.168.1.104 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
    resources: irq:53 memory:dd400000-dd43ffff ioport:a000(size=128)
    Last edited by ajcjh; October 17th, 2011 at 02:15 AM.

  2. #2
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,459
    Distro
    Ubuntu Development Release

    Re: Can't connect to wireless after 11.10 upgrade

    wlan0 IEEE 802.11bg
    Do you still have a config file to remove "N" from card.
    gksudo gedit /etc/modprobe.d/iwlagn.conf

    Comment the one line out "#" sign in front of line. (without quotes)
    and reboot will put "N" back in card functions.
    3.0 and up works with iwlagn driver by intel in N.

    Do not know if that will fix your problem but should fix the config file anyway.
    Last edited by garvinrick4; October 17th, 2011 at 12:44 AM.
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  3. #3
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,772
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't connect to wireless after 11.10 upgrade

    Hi garvinrick4, is this what you are talking about?
    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f iwlagn
    sudo modprobe iwlagn 11n_disable=1
    sudo ifconfig wlan0 up
    To the client please try this code one line at a time and if it works we will need to make it permanent.
    Thank you
    Last edited by Wild Man; October 17th, 2011 at 02:23 AM.

  4. #4
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,459
    Distro
    Ubuntu Development Release

    Re: Can't connect to wireless after 11.10 upgrade

    Quote Originally Posted by wildmanne39 View Post
    Hi garvinrick4, is this what you are talking about?
    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f iwlagn
    sudo modprobe iwlagn 11n_disable=1
    sudo ifconfig iwlagn up
    To the client please try this code one line at a time and if it works we will need to make it permanent.
    Thank you
    I believe he has a the N disabled and does not need to be with "iwlagn" driver with
    kernel 3.0 and up.
    Going around for a while was to just make a config file and place the line
    options iwlagn 11n_disable50=1 11n_disable=1

    In the config file /etc/modprobe.d/iwlagn.conf that user made. (I noticed the his card said 802.11 bg) And it is an N card.


    #You take over this thread wildmanne39 you are better with Network cards and their drives than I. I can do a little bcm cards and iwlagn driver for intel's.





    Last edited by garvinrick4; October 17th, 2011 at 01:20 AM. Reason: Talk to wildmanne39 a bit.
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  5. #5
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,772
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't connect to wireless after 11.10 upgrade

    Hi, you are correct that is the way to make it permanent,and it has been needed since upgrading to kernel 3.0.

    You are doing fine.

    I too struggle with some issues.

  6. #6
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,459
    Distro
    Ubuntu Development Release

    Re: Can't connect to wireless after 11.10 upgrade

    it has been needed since upgrading to kernel 3.0.
    Typo post 5, should be:
    it has not been needed since upgrading to kernel 3.0
    "N" in 'iwlagn" will work in 3.0 and up kernels.

    If you owned a "g'' router never new was a problem with "iwlagn",

    If you owned a "N" router had to remove "N" with config file from card. "iwlagn" driver would depreciate to not working at all without config file. (11.04 and down)

    Or install a kernel of 3.0 and up. (maverick and Natty) with upgrade in module-init-tools both links below to .deb files.
    http://kernel.ubuntu.com/~kernel-ppa/mainline/
    https://launchpad.net/ubuntu/+source.../3.13-1ubuntu1

    It is my driver, you get to no em like the back of your hand.

    Some users that upgraded still have config file in /etc/modprobe.d/iwlagn.conf and should be removed to work with N in 3.0 and up.
    Last edited by garvinrick4; October 17th, 2011 at 02:34 AM.
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  7. #7
    Join Date
    Feb 2008
    Beans
    22

    Re: Can't connect to wireless after 11.10 upgrade

    Quote Originally Posted by wildmanne39 View Post
    Hi garvinrick4, is this what you are talking about?
    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f iwlagn
    sudo modprobe iwlagn 11n_disable=1
    sudo ifconfig iwlagn up
    To the client please try this code one line at a time and if it works we will need to make it permanent.
    Thank you
    I got this message for the last command

    jupiter@jupiter-U56E:~$ sudo ifconfig iwlagn up
    iwlagn: ERROR while getting interface flags: No such device

    how do I re-enable n?
    Last edited by ajcjh; October 17th, 2011 at 02:27 AM.

  8. #8
    Join Date
    Feb 2008
    Beans
    22

    Re: Can't connect to wireless after 11.10 upgrade

    yes thank you. i did fix the config file and have not changed the post. Still doesn't affect wireless connectivity but good catch

  9. #9
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,772
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't connect to wireless after 11.10 upgrade

    Hi, did you run this command one line at a time? Make sure you disconnect your wired connection first and do not restart your computer after you run the commands.
    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f iwlagn
    sudo modprobe iwlagn 11n_disable=1
    sudo ifconfig wlan0 up
    If this does not work let us know and we will go from there.
    Thank you

  10. #10
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,772
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't connect to wireless after 11.10 upgrade

    Hi, I had a typo in the last command, I fixed it, now run the commands again please.
    Thank you

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •