Page 1 of 4 123 ... LastLast
Results 1 to 10 of 119

Thread: Unity panel always displayed on top of fullscreen windows

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    424
    Distro
    Ubuntu

    Unity panel always displayed on top of fullscreen windows

    Annoyingly, when any kind of application is in full-screen, the text and icons on the panel are always visible (appmenu, indicators, the clock etc).

    Even more annoyingly, the mouse regards them as under the full-screen window (where they should be), so the indicator icons and application menus don't respond to clicks.

    Is there any way to stop the panel from being displayed on top of everything?

    I don't want to hide the panel, just have it properly covered when a full-screen window opens.

    Is there any setting for this in ccsm, gconf, or dconf?

  2. #2
    Join Date
    Nov 2009
    Beans
    117
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Unity panel always displayed on top of fullscreen windows

    What apps are you using that doesn't hide the panel? I haven't found any app with that behaviour, all my apps hides the panel when in fullscreen.

  3. #3
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,840
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    Hey i have seen issue like you got. some times this type of issues needs capture of problem . so please attach a screen shot and by the way follow this

    http://ubuntuforums.org/showthread.php?t=1654141

    All the best
    Google First your issue , if no solution then ask.

    రాజ శేఖర్ రెడ్డి

  4. #4
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    424
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by scarleo View Post
    What apps are you using that doesn't hide the panel?
    It is not a problem with the applications.

    The panel is displayed on top of every full-screen application of every kind.

    Please understand that I do not mean the launcher on the left side.

    I am talking about the panel across the top of the screen.


    Quote Originally Posted by raja.genupula View Post
    ...and by the way follow this...
    Thank you for the link, unfortunately this is not my problem. My problem has to do with full-screen applications.

    I'm attaching two screenshots.

    fullscreen.panel.1.png = a video in Totem.
    fullscreen.panel.2.png = a game in wine.
    Attached Images Attached Images

  5. #5
    Join Date
    Dec 2011
    Beans
    1

    Re: Unity panel always displayed on top of fullscreen windows

    I'm also having this problem.

    I am using Citrix Receiver to remote access another machine, and it tries to use the full screen but the Unity panel still appears at the top. I guess it's as a result of this that I still have a scrollbar on the RHS and the mouse is mis-placing all of my clicks within the screen.

    I should mention I'm using a fresh install of 11.10.

    Full screen is working fine with Firefox when I hit F11. With the citrix client F11 is just going through to the remote session though.
    Attached Images Attached Images
    Last edited by fwsober; December 3rd, 2011 at 07:18 PM.

  6. #6
    Join Date
    Mar 2007
    Location
    London, England
    Beans
    18
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Unity panel always displayed on top of fullscreen windows

    My solution was:

    If you have Compiz enabled (as in Unity by default):

    Code:
    sudo apt-get install compizconfig-settings-manager
    Then, in Control Center: Personal / CompizConfig Settings Manager
    check Utility / Workarounds / Legacy Fullscreen Support.

  7. #7
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    8,087
    Distro
    Ubuntu Development Release

    Re: Unity panel always displayed on top of fullscreen windows

    In full screen mode the windows are moving under the panel. That is what is happening and it should not happen.

    There is no intention to make the top panel disappear when a window is maximised. Remember, it is the intention with unity for the top panel to be the place for the max, min & close buttons of a window as well as for app indicators.

    I am using 12.04 development release and maximised windows stay below the top panel but up against it.

    we have the ability to bounce a window against the top panel and when we let go of the mouse button the window maximizes. Then when we move the mouse over the top panel the pointer should change to a hand icon so that we can grab the top of the maximized window and pull it down at which point the window snaps back to its original size. My point is that the maximized window should not be under the top panel. That is the problem and not the one of the top panel not disappearing.

    I do not know how you stop this from happening but my guess is that it is to do with a setting in CCSM. I cannot check this out as I am not using 11.10 but 12.04 and there are changes to CCSM in 12.04.

    Regards.

    P.S. It occurs to me that your thread title is a little misleading. This is not a problem with maximized windows. Is it? It is a problem with playing video in full screen mode. Is it not?
    Last edited by grahammechanical; February 12th, 2012 at 06:06 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  8. #8
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    424
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by grahammechanical View Post
    It occurs to me that your thread title is a little misleading. This is not a problem with maximized windows. Is it? It is a problem with playing video in full screen mode. Is it not?
    The thread title is the best I could do.
    I was expecting communcation difficulty when I started the thread.

    It is not a problem with maximized windows.
    It is not a problem with the windows.
    It is not a problem with watching videos.

    It is a problem with the panel along the top edge of the screen, which should not (in my opinion) be visible while an application is in full-screen. This is affecting applications of all kinds: media players, games, web browsers, etc...

    Furthermore, if the panel is going to be visible anyway, it should at least be usable but it is not.
    While the panel can be seen at all times, when displayed on top of a full-screen window it cannot be clicked.

    I know this confusing.

    By full-screen I do not mean "maximized".
    Maxmized windows are still windows and have a titlebar with close, minimize, and restore buttons.

    Full-screen means occupying 100% of screen space.

    With Unity, there is always a panel at the top, even when an applicatio should be completely covering the screen.

    Quote Originally Posted by sleepyhollows View Post
    THeres no settings anywhere in unity. No right click -> hide on icons, no drag to move... I dont get it. I can't find the settings for anything.
    Because they are in Compiz. You need to install compizconfig-settings-manager (ccsm). There are only a few configurable items.
    But i'm sure it will be ironed out..
    Never lose that faith.
    Your issue sounds pretty drastic and I would suggest unique. I doubt the release would have gone out with a ghost panel stuck over the top of full windows. If I am understanding correctly.
    It isn't unique. Everyone using unity should be experiencing this.

    The release indeed went out "with a ghost panel stuck over the top of full[-screen] windows". I've seen this in three differet installs of Ubuntu on two differen computers.
    Last edited by quequotion; February 13th, 2012 at 07:51 AM.

  9. #9
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    2,668
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Unity panel always displayed on top of fullscreen windows

    It sounds like possibly a specific video card, chip or driver issue. Things like full screen flash video should really go full screen. But for some reason something is not layering properly and your inactive top bar remains visible.

    What video card or chip do you have, and which driver.
    i5 650 3.2 GHz, 8 GB, nvidia GTX 750 Ti, 32" 1080p | i7-4700MQ, 8 GB, Intel HD 4600/nvidia GTX 765M, 15.6" 1080p | etc.

  10. #10
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    424
    Distro
    Ubuntu

    Re: Unity panel always displayed on top of fullscreen windows

    Quote Originally Posted by efflandt View Post
    It sounds like possibly a specific video card, chip or driver issue. Things like full screen flash video should really go full screen. But for some reason something is not layering properly and your inactive top bar remains visible.

    What video card or chip do you have, and which driver.
    I honestly don't think so.

    Can you provide a screenshot of anything in full-screen (not maximized) with no panel at the top? (I should not be able to see the application name or menu nor the indicator icons, the clock, or the user and system menus)

    Desktop: nVidia GT 220, using the proprietary drivers.

    Laptop: Intel 315M (or something like that)

    I have tried several versions of the nvidia driver and always had this issue.

    I have tried the nouveu driver as well and had the same issue in addition to general horribleness.

    *UPDATE*
    Found another thread about this issue. It looks like there were the same communication problems and ultimately it just came to an end.... in July 2011.
    Last edited by quequotion; February 13th, 2012 at 01:57 PM.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •