Results 1 to 10 of 22

Thread: Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

Hybrid View

  1. #1
    Join Date
    Mar 2011
    Beans
    3

    Wink Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

    Hi everyone,

    I've recently purchased a Dell Vostro 3350 with 2 integrated graphics card
    1 - Intel HD
    2 - AMD (ATI) Radeon 470M HD

    No problem installing Ubuntu 11.04 64 bit using a CD (not USB)
    i just needed to add noapic options.

    After the first reboot no problem occurred, but after some try it freeze at startup with a black screen (also no baklight!).

    That's happen also after a variable number of reboot, then it starts normally, then no more!

    That's is due to the unsupported ATI card by the radeon open driver, maybe it's too new

    DAMN!

    Some searching in this formu and than I've solution that's right for me.

    Once you boot don't start normally but choose a shell.

    Instead of removing the module with

    Code:
    rmmod radeon
    I prefer to blacklist that module by

    Code:
    echo "blacklist radeon" > /etc/modprobe.d/blacklist-radeon.conf
    I need to alert you that's a problem by choosing this way:
    it seems that you've both the videocard POWERED ON so if you need to keep the consuption low you need to chose a different solution.

    Any idea about that?

    Maybe here but I can't understan very well:
    http://ubuntuforums.org/newreply.php...ply&p=10832728

    Bye Bye

  2. #2
    Join Date
    Jun 2011
    Beans
    1

    Re: Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

    Hi, I recently bought the the same Laptop and I am also having these issues.
    So I'll share my experience so far.

    It seems as if the open source radeon driver* is crashing on boot, therefore doing the
    Code:
    echo "blacklist radeon" > /etc/modprobe.d/blacklist-radeon.conf
    indeed solves part of the problem.

    I am not sure why this happens (sry, forgot to make a copy of the dmesg output, where the crash is logged), but so far it seems that the radeon module succeeds to load afterwards:
    Code:
    sudo modprobe radeon
    With the module loaded, it is possible to switch, enable and disable the two graphic cards using "switcheroo' that comes into play when the driver is loaded:

    Code:
    sudo su -c 'echo ON > /sys/kernel/debug/vgaswitcheroo/switch; echo IGD > /sys/kernel/debug/vgaswitcheroo/switch; echo OFF > /sys/kernel/debug/vgaswitcheroo/switch'
    This statement turns on the integrated graphics card, and disabled the radeon.
    More details can be found here: https://help.ubuntu.com/community/HybridGraphics

    In my case, the fan that was running all the time stopped within a few seconds.
    Hope this helps.

    ps:
    In regard to https://help.ubuntu.com/community/HybridGraphics
    . The problem of the fan running at full speed after reboot does not apply to my notebook, so I infer it does not apply to the whole series.
    . The initramfs script, which should switch to the integrated graphics card, did not work for me, because at the time initramfs is executed, the radeon module has not been loaded yet, therefore '/sys/kernel/debug/vgaswitcheroo/switch' does not exist.
    Note however, that the link points to a wiki page, so it might be updated soon.

    * There is also the official catalyst one, but version 11.5 did not find the device.
    I did not try to figure out if there was a workaround for this.
    Last edited by RavenArkadon; June 8th, 2011 at 12:25 AM.

  3. #3
    Join Date
    Jun 2011
    Beans
    1

    Re: Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

    Hello,

    I just bought the vostro 3350 and I got the same black screen issue at times after booting.
    I installed ubuntu 11.04 from a cd alongside windows 7.

    I tried to run the echo blacklist command like you described at the boot time (I pressed the key c on the screen where I choose the os to run) but I got a syntax error.
    I believe this might be because I could not see any blacklist-radeon.conf file in the /etc/modprobe.d directory (I see some others like blacklist-firewire.conf, blacklist-watchdog.conf etc).

    I've noticed something that looks weird to me about the graphic card.
    In windows 7, it says it is the radeon 6490 but when I ran the command to list the pci devices via a terminal in ubuntu the radeon seems to be the 6450?!

    Any ideas?

    Thanks in advance for your help.

    ps. my knowledge of linux/ubuntu is close to zero. I've tried to read some forums here and there to try to understand a bit more about the way to fix this issue.

  4. #4
    Join Date
    Jul 2011
    Beans
    10

    Re: Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

    I have the same problems with the same laptop.
    Details here: http://ubuntuforums.org/showthread.php?t=1800160
    My solution, for the moment (I'm at my first interactions with linux and my level of expertise in PC is zero):
    1. when in GRUB (I have a dual boot system) I select the OS and press E
    2. in the third line of the menu -
    set gfxpayload=$linux_gfx_mode
    I put a "#" in front of this line (it ignores this line, someone explained me);
    3. Press F10 and it boots properly, but with the ATI/Radeo deactivated.

    I'm curious if and how could I save this modification, so I don't have to enter this menu every time I boot.

    I also have problems with the fingerprint reader and with the sound. Do you? If yes, have you managed to solve them?
    Last edited by AlexValex; July 15th, 2011 at 05:18 AM.

  5. #5
    Join Date
    Dec 2008
    Beans
    33

    Re: Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

    http://ubuntu4beginners.blogspot.com...n-problem.html

    This solved the black screen of death for me

  6. #6
    Join Date
    Jul 2011
    Beans
    8

    Re: Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

    Hello everyone!

    first of all, I am new to this forum and although I have some experience with linux I would regard myself as a beginner.

    Two weeks ago I bought a DELL vostro 3350 with i5-2410M with hybrid graphics and when trying to install Ubuntu 11.04, 64 bit version, I face the same problems as many other users do.

    I have seen that some people found ways to circumvent the problem. Despite, I am not even able to install Ubuntu.

    I tried to follow the instructions recommended by engrin
    (http://ubuntu4beginners.blogspot.com...n-problem.html). According to that, you should be able to choose the "nomodeset" option, which should enable you to install Ubuntu without black-screen.
    The problem is, that when I try to install it, there are no options to select. As I read in other posts, the options should appear after pressing F6, but unfortunately they do not, which is why I am stuck.


    I downloaded the following versions at ubuntu.com and created a USB bootable device with the recommended software:

    ubuntu-11.04-desktop-i386.iso
    ubuntu-11.04-desktop-amd64.iso
    ubuntu-10.04.2-desktop-amd64.iso


    I think the instructions are intended for Lucid/Maverick. Is it possible to choose "nomodeset" with Ubuntu 11.04 (64bit) as well? If yes, could you please tell me exactly how to do it?

    Thank you for your help in advance!

    Peter

  7. #7
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    16,064
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Dell vostro 3350 Radeon 6470M HD black screen on boot - Ubuntu 11.04 64bit

    Old thread closed.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •