Results 1 to 10 of 10

Thread: compiz Application Switcher mouse/screen focus issues

Hybrid View

  1. #1
    Join Date
    Sep 2009
    Beans
    20

    compiz Application Switcher mouse/screen focus issues

    Under Natty, it seems there's a huge bug with the Compiz Application Switcher. Not the Ring Switcher, Shift Switcher, or Static Application Switcher, just the standard "Application Switcher." Whenever I enable it, if you switch between windows using "ALT+Tab," mouse and keyboard events in the switched-to window don't register on the screen. But, if you minimize and restore the window, or maximize restore it, the problem is fixed and you can see the mouse and keyboard events did actually occur.

    Here's an example: if both firefox and gedit are running and I use "ALT-Tab" to switch over to gedit, I can type a sentence and nothing appears in gedit. I can click on the "File" menu and it won't display. But, if I minimize or restore the window and bring it back, everything I typed will be there.

    Interestingly, it's not universal to everything on the screen. In my example, if I switch back to firefox, using "Ctrl+Tab" to switch between open tabs does nothing, except you can actually see the title bar of firefox change to match the tab it should be switching to. If you minimize firefox and bring it back, it will actually be on the tab you switched to.

    Since the events seem to occur, but not appear on the screen, I'm not sure if this is a compiz bug, a natty bug, or display driver bug (I'm using the fglrx driver for my ati card). I have found the problem exists in both Unity and gnome session. Disabling the Application Switcher in CompizConfig Settings Manager eliminates the issue.

    The behavior has persisted through about 3 clean installs of Natty (64-bit). Has anyone else seen this happen with the Application Switcher or found a setting to fix it? Thanks.

  2. #2
    Join Date
    Feb 2008
    Beans
    3
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: compiz Application Switcher mouse/screen focus issues

    I was looking through the forums to see if there was a fix for this problem, and I see someone else has it as well.

    I have tried "Reset to Defaults" in ccsm and "gconftool-2 --recursive-unset /apps/compiz-1" but that has not fixed it. This only occurs on one of my three PC's however. I am running 32-bit. My video driver is also fglrx. But one of my other working PC's has the same configuration.

    Thanks in advance for any help with this.

  3. #3
    Join Date
    Jun 2011
    Beans
    1

    Re: compiz Application Switcher mouse/screen focus issues

    I also have this problem - when switching between different applications, my keyboard intermittently works. With enough clicking around, it seems to work again - I still haven't figured out exactly when this is happening, or what is fixing it. From what I can tell, it usually happens when I go between different workspaces.

    Any ideas?

  4. #4
    Join Date
    Jan 2011
    Location
    Kansas City, KS
    Beans
    1,273
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: compiz Application Switcher mouse/screen focus issues

    This latter problem I have on 10.10 as well. It's unrelated to the (rather serious) Application Switcher bug in Natty. Does it only seem to happen with certain applications? I can consistently cause input fields in Opera not to work by switching workspaces using the Viewport Switcher plugin (but opening a menu in Opera or switching to another application and back on the same workspace, or even going out to Expo view and back, all return things to normal.)
    ~ I know I shouldn't use tildes for decoration, but they always make me feel at home. ~

  5. #5
    Join Date
    Mar 2010
    Beans
    19

    Re: compiz Application Switcher mouse/screen focus issues

    This problem seems to also exist on Mint 11 running Compiz standard setting, and with Chrome open

  6. #6
    Join Date
    Feb 2008
    Location
    Sydney, Australia
    Beans
    3
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: compiz Application Switcher mouse/screen focus issues

    I too have this exact same problem after I upgraded from Ubuntu 10.10 to 11.04. Unsure if its Compiz or Unity but I'm using fglrx drivers. At least compiz actually works for me in 11.04, I never got fglrx and compiz to play nice in 10.10.

    Thank you Nisitiiapi for the workaround.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •