Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: HOWTO: Super Meat Boy + Game Controller

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Location
    ニッポ&
    Beans
    719
    Distro
    Ubuntu 10.10 Maverick Meerkat

    HOWTO: Super Meat Boy + Game Controller

    Super Meat Boy 1.0.u3 + Game Controller


    Install wine

    sudo apt-get install wine
    [For best results use version 1.3.7.]

    Install steam


    wget http://steampowered.com/download/SteamInstall.msi
    wine msiexec /i SteamInstall.msi

    Install Super Meat Boy
    Use steam to download & install Super Meat Boy which includes the directx files.

    Apply the fixes
    wine regedit
    HKEY_CURRENT_USER > Software > Wine > AppDefaults > SuperMeatBoy.exe > Direct3D

    DirectDrawRenderer = opengl
    VideoMemorySize = 896
    [VideoMemorySize = Your video card ram]

    Login and Run Super Meat Boy
    wine 'C:\Program Files\Steam\Steam.exe'
    Enjoy
    [You may need to run wine within an emulated desktop]
    wine explorer /desktop=Steam,1920x1080 Steam.exe



    Game Controllers [Gamepads]
    Most game controllers will be auto detected within Linux and the game should auto-detect it as well.

    Game Controllers reported to work within Windows' box:
    Logitech Chillstream [Confirmed]
    Xbox 360 Controller
    Logitech F710
    Streetfighter gamepad
    Logitech F310
    Logitech Wireless Rumblepad 2
    http://forums.steampowered.com/forum....php?t=1626320

    Note:
    You may want to increase the idle time, because the game controller won't active the game or your desktop.
    System > Preferences > Screensaver
    "Regard the Computer as idle after"


    Youtube Trailer:
    http://www.youtube.com/watch?v=MzNKe_nQ1As

    Super Meat Boy 1.0.u3
    Wine Version 1.3.7
    Ubuntu 10.10 x64
    Nvidia Drivers 260.19.06

    Cheers,
    Sugi
    Attached Images Attached Images
    Last edited by Sugi; December 5th, 2010 at 11:56 PM. Reason: Added more images.
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues
    アンディモリを聞いてください。

  2. #2
    Join Date
    Apr 2007
    Location
    ニッポ&
    Beans
    719
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Super Meat Boy + Game Controller

    Troubleshooting:
    - The Regedit may not be needed for everyone, as others have reported getting the game to work without it.
    - I have tried versions 1.0 and 1.0.1 stand-alones [non-steam], but I couldn't get the game to load. I believe it was linked to a directX issue.
    - "Emulated desktop" fixes the problem of the black screen with music.
    Attached Images Attached Images
    Last edited by Sugi; December 5th, 2010 at 11:36 PM.
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues
    アンディモリを聞いてください。

  3. #3
    Join Date
    Oct 2006
    Location
    Canada
    Beans
    67
    Distro
    Ubuntu

    Re: HOWTO: Super Meat Boy + Game Controller

    Do you have speed issues? My game loads and runs but it seems to be running at about double speed.

    I'm using wine 1.2 so that might be the problem. I'll try that.

    Also, "HKEY_CURRENT_USER > Software > Wine > AppDefaults" does not exist so I cannot edit the video memory size.

  4. #4
    Join Date
    Apr 2007
    Location
    ニッポ&
    Beans
    719
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Super Meat Boy + Game Controller

    Hello Kimos,
    Oops, I should have made a note about that. In the regedit, if it doesn't exist, you either have to create it yourself and auto make one. winecfg > "Add an Application" and navigate to your ~/.wine/drive_c/Program Files/Steam/steamapps/common/SuperMeatBoy.exe

    I have also woundered if my start menu within Super Meat Boy was a bit fast, but ingame results with normal speed.

    Sugi
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues
    アンディモリを聞いてください。

  5. #5
    Join Date
    Jun 2007
    Beans
    1

    Re: HOWTO: Super Meat Boy + Game Controller

    I tried the method described and it works fine. But some levels don't show up correctly sometimes, which is weird because it seems to happen randomly. And I can atest to the fact that the menu is really fast, but in game it's all fine.

  6. #6
    Join Date
    Apr 2007
    Location
    ニッポ&
    Beans
    719
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Super Meat Boy + Game Controller

    Here, try some of these regedit tweaks. I have not gotten any of these graphical errors. I have only gotten 2 crashes within 10 hours of play.

    HKEY_CURRENT_USER > Software > Wine > AppDefaults > SuperMeatBoy.exe > Direct3D
    > Multisampling
    enabled
    > DirectDrawRenderer
    gdi
    opengl
    > RenderTargetLockMode
    disabled
    readdraw
    readtex
    > StrictDrawOrdering
    enabled
    > OffscreenRenderingMode
    backbuffer
    fbo
    > UseGLSL
    enabled
    > VideoPciDeviceID
    lspci -n [To find your video]

    For more information, check out winehq wiki:
    http://wiki.winehq.org/UsefulRegistryKeys

    Please keep us informed about your findings.
    Sugi
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues
    アンディモリを聞いてください。

  7. #7
    Join Date
    Dec 2010
    Beans
    1

    Re: HOWTO: Super Meat Boy + Game Controller

    i need help
    i cannot play super meat boy
    thanks

  8. #8
    Join Date
    Oct 2006
    Location
    Canada
    Beans
    67
    Distro
    Ubuntu

    Re: HOWTO: Super Meat Boy + Game Controller

    Quote Originally Posted by geoovani View Post
    i need help
    i cannot play super meat boy
    thanks
    That's almost no information to go on. No configuration, error output, version numbers, install method, or anything. Not much anyone can do for you.

    Start here:
    http://appdb.winehq.org/objectManage...estingId=59410
    Last edited by Kimos; December 16th, 2010 at 08:12 PM.

  9. #9
    Join Date
    Jan 2009
    Beans
    6

    Re: HOWTO: Super Meat Boy + Game Controller

    I could not find either "AppDefaults" or /Program Files/Steam

    when i get to Program Files the only two folders that are available are Common Files and Internet Explorer

    I am running winecfg as the root user btw

    also, when i start thee game through steam, all that is shown are the white letters and a completely black screen
    Last edited by andrex316; December 21st, 2010 at 06:16 AM.

  10. #10
    Join Date
    Apr 2007
    Location
    ニッポ&
    Beans
    719
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Super Meat Boy + Game Controller

    andrex316, You can NOT run wine EVER as root. You must uninstall wine and reinstall wine. You did not install steam or super meat boy as well or you installed it to somewhere else other your wine/drive_c/Program Files.

    Code:
    sudo apt-get remove wine
    Then follow the guide again and you should be set.

    Sugi
    WINE: Super Meat Boy // Far Cry 2 // Lineage 2
    VirtualBox: Snapshots // OSE Issues
    アンディモリを聞いてください。

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •