Results 1 to 10 of 69

Thread: Left mouse button stops working in 10.10

Hybrid View

  1. #1
    Join Date
    Apr 2006
    Location
    Austin, TX
    Beans
    6
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Red face Left mouse button stops working in 10.10

    I'm having a problem with gnome. When I press a multimedia key on my keyboard (or obstensibly other hotkeys although I haven't figured out exactly what). My left-mouse button stops responding. The right mouse button works fine and the mouse tracks fine. I can go into the mouse control panel and switch it to a left handed mouse and the left mouse button works, but not the right.

    I ran 'xinput test "HP Mouse"', and I can see the left mouse clicks coming through. So X11 at least thinks it's coming through. I've got nothing interesting that I can find in /var/log.

    This is really generic USB hardware. HP Mouse and Microsoft Digital Media Keyboard.

    I'm really stumped as to where to continue with my troubleshooting. Any thoughts?

  2. #2
    Join Date
    Nov 2009
    Beans
    1

    Re: Left mouse button stops working in 10.10

    updated to 10.10 today. Same problem, but left button stops working after keyboard layout switching (through hotkeys or indicator) =\

  3. #3
    Join Date
    Apr 2006
    Location
    Austin, TX
    Beans
    6
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Left mouse button stops working in 10.10

    I have fixed it temporarily by alt tabbing to a terminal and running:

    sudo rmmod usbhid; sudo mobprobe usbhid

    I'd like to be able to use my hotkeys again though.

  4. #4
    Join Date
    Oct 2010
    Beans
    2

    Re: Left mouse button stops working in 10.10

    Have the same problem.
    Stops working when switching keyboard layouts.
    "sudo rmmod usbhid; sudo mobprobe usbhid" does not help. Restarting xorg helps. xinput test also shows events when button is clicked.

  5. #5
    Join Date
    Oct 2010
    Beans
    2

    Re: Left mouse button stops working in 10.10

    Is mouse from A4Tech?

    Here is issue in bug tracker: https://bugs.launchpad.net/udev/+bug/637208 that also contains temporary workaround:

    Some solution, that solve our problem.
    1) xinput --list
    It will show you your input devices, our A4Tech mouse have id, for example, there are
    ⎜ ↳ A4TECH USB Device id=11 [slave pointer (2)]
    ⎜ ↳ A4TECH USB Device id=10 [slave pointer (2)]
    2) xinput set-int-prop %id% "Device Enabled" 8 0
    , where %id% is one of id's of your mouse. In my case it was 10. Generally, this is the second id of list. This command will disable advanced built-in keyboard of A4Tech mouse.
    If you want to enable back, use
    xinput set-int-prop %id% "Device Enabled" 8 1.
    Workaround works for me. My mouse is A4Tech K3-230.

  6. #6
    Join Date
    Apr 2006
    Location
    Austin, TX
    Beans
    6
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Left mouse button stops working in 10.10

    My mouse is a pretty generic HP USB Mouse. Disabling and re-enabling via xinput does not work for me. Xinput does show the left mouse button being clicked. Only thing that works so far is restarting X or rmmod-ing usbhid (which I'm guessing is not so much a solution as taking a sledgehammer to the problem).

  7. #7
    Join Date
    Oct 2007
    Location
    Victoria, BC, Canada
    Beans
    9
    Distro
    Xubuntu 7.10 Gutsy Gibbon

    Re: Left mouse button stops working in 10.10

    Thanks for tracking that down! The workaround may have killed my multimedia keys, but having a working left-click is more than worth it. Hopefully we'll get a real fix sometime soon.

    Quote Originally Posted by ungzd View Post
    Is mouse from A4Tech?

    Here is issue in bug tracker: https://bugs.launchpad.net/udev/+bug/637208 that also contains temporary workaround:

    Some solution, that solve our problem.
    1) xinput --list
    It will show you your input devices, our A4Tech mouse have id, for example, there are
    ⎜ ↳ A4TECH USB Device id=11 [slave pointer (2)]
    ⎜ ↳ A4TECH USB Device id=10 [slave pointer (2)]
    2) xinput set-int-prop %id% "Device Enabled" 8 0
    , where %id% is one of id's of your mouse. In my case it was 10. Generally, this is the second id of list. This command will disable advanced built-in keyboard of A4Tech mouse.
    If you want to enable back, use
    xinput set-int-prop %id% "Device Enabled" 8 1.
    Workaround works for me. My mouse is A4Tech K3-230.

  8. #8
    Join Date
    Oct 2007
    Location
    Sweden
    Beans
    15
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Left mouse button stops working in 10.10

    Quote Originally Posted by ungzd View Post
    Is mouse from A4Tech?

    Here is issue in bug tracker: https://bugs.launchpad.net/udev/+bug/637208 that also contains temporary workaround:

    Some solution, that solve our problem.
    1) xinput --list
    It will show you your input devices, our A4Tech mouse have id, for example, there are
    ⎜ ↳ A4TECH USB Device id=11 [slave pointer (2)]
    ⎜ ↳ A4TECH USB Device id=10 [slave pointer (2)]
    2) xinput set-int-prop %id% "Device Enabled" 8 0
    , where %id% is one of id's of your mouse. In my case it was 10. Generally, this is the second id of list. This command will disable advanced built-in keyboard of A4Tech mouse.
    If you want to enable back, use
    xinput set-int-prop %id% "Device Enabled" 8 1.
    Workaround works for me. My mouse is A4Tech K3-230.
    This one worked for me. Thanks. Seems to be a driver-problem with the A4Tech devices?

  9. #9
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •