Page 1 of 3 123 LastLast
Results 1 to 10 of 42

Thread: Known Lucid Lynx issues/bugs with workarounds

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,860
    Distro
    Ubuntu Development Release

    Known Lucid Lynx issues/bugs with workarounds

    Disclaimer : The purpose of this thread is to list known Lucid Lynx issues and bugs, and give the corresponding workarounds and launchpad entries.

    Feel free to propose other known Lucid Lynx bugs to be listed here but please provide a link to the workaround and a link to the corresponding launchpad entry.

    -------------------------------------------------
    Warning: Before upgrading or attempting a reinstall make sure you backup essential files.
    Please read the Release Notes:-

    http://www.ubuntu.com/getubuntu/releasenotes/1004

    Upgrade 8.04 -> 10.04 can break apt-get.
    The package flashplugin-nonfree has been problematic when upgrading 8.04 -> 10.04 and breaks apt-get;

    Bug Report

    For those not wanting to read the bug report in detail, the fix is :

    Code:
    sudo rm /var/lib/dpkg/info/flashplugin-nonfree.prerm
    
    sudo dpkg --remove --force-remove-reinstreq flashplugin-nonfree
    sudo dpkg --purge --force-remove-reinstreq flashplugin-nonfree
    Nautilus location bar, bread crumbs vs text based.
    Breadcrumbs is now the default. The button to switch between the two has been removed. Users can switch with ctrl+l and then esc to revert to breadcrumbs. To permanently switch to text users have to use gconf-editor from a terminal. Note: gconf-editor has been removed from the menus. The key is.
    apps>nautilus> preferences> always_use_location_entry


    Minimize, Maximize and Close button placement.
    A decision has been taken to move the placement to the left. Mark Shuttleworth explained that this was because "something" is going to be placed in the right hand area in the next release. Moving the buttons now would help enable this change.
    [Update ]http://www.markshuttleworth.com/archives/333

    The buttons are in the old location on all default themes apart from Ambiance,Radiance and Dust, If you still want the Ambiance ,Radiance or Dust theme but with buttons on the right, choose one of those other themes and use the Customize button to achieve what you want. e.g.
    1. System > Preferences > Appearance
    2. Select the theme icon "New Wave"
    3. Click the button "Customize.."
    4. Select tab "Controls" and select "Ambiance"
    5. Select tab "Window border" and select "Ambiance"
    6. Select tab "Icons" and scroll down and select "Ubuntu-mono-dark"
    7. Select "Save Theme" to your choice.
    Using gconf-editor is not the right approach as this could bork future themes. This change makes it easier for themes to do interesting things with window borders. Unfortunately, if the wrong approach spreads, they won't be able to do that.


    Problem with Huawei and possibly other usb mobile broadband dongles.
    Please see this bug report and click the affects me button if you have this bug.
    Try this first
    Code:
    sudo apt-get install usb-modeswitch
    A fix is committed. https://bugs.launchpad.net/ubuntu/+s...ux/+bug/446146.
    Also fix/workaround here. https://bugs.launchpad.net/ubuntu/+s...ux/+bug/509547 See post #32


    Bootup/Plymouth.
    Users should experience a much faster boot however some users may experience problems with Plymouth after the nVidia graphics driver has been enabled. Users may experience plymouth using lower graphics resolution.
    https://bugs.launchpad.net/ubuntu/+s...th/+bug/551013

    Graphical solution : http://news.softpedia.com/news/How-t...4-140810.shtml

    Command line :
    (Some of the fixes put forward dont work for everyone.)
    One that works for nVidia and to try is this.
    Code:
    gksu gedit /etc/default/grub
    and add the line in BOLD.
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    GRUB_GFXPAYLOAD_LINUX=1680x1050 Save the file and run
    Code:
    sudo update-grub
    The resolution chosen should be your monitors native resolution.

    Other graphics card users including nVidia may get a black screen with flashing cursor and then a very short duration plymouth.
    https://bugs.launchpad.net/ubuntu/+s...th/+bug/540801
    One fix for this is to create this file.
    Code:
    gksu gedit /etc/initramfs-tools/conf.d/splash
    and add this option FRAMEBUFFER=y, save the file.
    Then
    Code:
    sudo update-initramfs -u
    Plymouth now has a hard dependency on mountall thus trying to remove Plymouth would remove half the OS. The advice is, if you don't want a graphical boot then uninstall any plymouth themes.

    If the problem is a slow boot, and you have no floppy drive, disable the floppy in the bios. This has been reported as a fix to this.
    https://bugs.launchpad.net/ubuntu/+s...ks/+bug/539515 FIX Released.
    https://bugs.launchpad.net/ubuntu/+s...ks/+bug/551712

    If the problem is plymouth not displaying, and a black screen from grub to gdm, this could be due to graphics drivers needing to be loaded quicker. This is bugged.
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/539787

    Plymouth is installed with 2 themes by default you can install more via synaptic.
    To change themes this code is used.
    Code:
    sudo update-alternatives --config default.plymouth
    Java.
    Sun java has been deprecated. Openjdk is now the default, i.e installing ubuntu-restricted-extras with recommends will install openjdk and the icedtea plugin. Openjdk has been certified by Java SE Test Compatibility Kit (TCK) and is compatible with the Java(TM) SE 6 platform on the amd64 (x86_64) and i386 (ix86) architectures. However sun-java is in the partner repo.
    There's a bug regarding the icedtea plugin and certain applets.
    https://bugs.launchpad.net/ubuntu/+s...-6/+bug/551328.
    Not fixed yet. Workaround may be to create a new Firefox profile.


    Boot options hidden by default on Desktop and Netbook LIVECDs
    The Ubuntu 10.04 LTS Desktop and Netbook CDs feature a new boot interface that is non interactive by default.
    To configure advanced boot options, press any key at the first boot screen.


    Scrolling with ALPS Laptop Touchpads
    Various users who have ALPS touchpads have reported that scrolling no longer works in the final release. A bug report is already open on the case, and the current workaround is to run:
    Code:
    sudo rmmod psmouse
    sudo modprobe psmouse proto=imps
    If this works, you can make it permanent by putting:
    Code:
    options psmouse proto=imps
    At the bottom of the file /etc/modprobe.d/options


    Ubuntu shuts down after unplugging Laptop power cord
    A problem known with MSI wind and some Vostro users.

    Current workaround is to open gconf-editor and browse to:
    Code:
    /apps/gnome-power-manager/general
    And de-select the option use_time_for_policy

    There is no need to restart, just close the configuration editor.
    Last edited by philinux; June 17th, 2010 at 12:13 PM. Reason: Udisks floppy problem fix released.

  2. #2
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Known Lucid Lynx issues/bugs with workarounds

    A lot of users are overwriting their windows boot sector due to a confusing message with the grub2 install. It says something like 'Choose where to install grub. If you are not sure select all partitions'. And this leads some to select their windows partition.

    NOTE: if you are reading this before you upgrade, the only place you should install grub is to the drive you are booting from. For most people it's /dev/sda . If you installed from within windows (a WUBI install), do not install the grub2 bootloader - leave all boxes unchecked.

    The fix and diagnosis is at: http://sourceforge.net/apps/mediawik...ms:Boot_Sector courtesy of meierfra.

    This is not the same as the bug that caused the re-release of certain iso's. That had to do with the windows not being listed in the grub menu. In this case, the windows option is listed but fails to boot.

    Links to launchpad bug(s);
    https://bugs.launchpad.net/ubuntu/+s...b2/+bug/571893
    https://bugs.launchpad.net/ubuntu/+s...b2/+bug/576724
    Last edited by bcbc; June 8th, 2010 at 10:01 PM. Reason: add more info

  3. #3
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Known Lucid Lynx issues/bugs with workarounds

    Another issue - when upgrading to 10.04 from a wubi install (not sure if it affects normal upgrades) it gets into a tight loop. What it says is 'Preparing memtest86+' and if you click on the terminal windows it just shows the line 'found linux image linux-2.6.xxxx' repeating.

    Anyway, if you hit CTRL+C it continues successfully. Some people have tried rebooting or canceling the install which leaves their ubuntu broken.

    Here's a link with a picture: http://ubuntuforums.org/showthread.php?t=1467754


    Looks like this is the launchpad bug for it: https://bugs.launchpad.net/ubuntu/ka...in/+bug/540579

    Edit: I can confirm I didn't get this with a normal (non-wubi) upgrade.
    Last edited by bcbc; May 3rd, 2010 at 05:03 AM. Reason: Add launchpad ref; new comment

  4. #4
    Join Date
    Oct 2007
    Beans
    26

    Re: Known Lucid Lynx issues/bugs with workarounds

    mount.cifs won't mount shares; set uid bit not set

    https://bugs.launchpad.net/ubuntu/+s...ba/+bug/563805

    the fix

    sudo chmod +s `which mount.cifs`
    sudo chmod +s `which umount.cifs`

  5. #5
    Join Date
    Jan 2009
    Location
    Toronto, Canada
    Beans
    214
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Known Lucid Lynx issues/bugs with workarounds

    In the initial post

    Code:
    gksu /etc/default/grub
    should be

    Code:
    gksu gedit /etc/default/grub
    /luigi

  6. #6
    Join Date
    May 2007
    Beans
    33
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Known Lucid Lynx issues/bugs with workarounds

    We also have a common bug if you have not encountered it. FSCK hangs or crashes on bootup.

    Related bug reports:
    https://bugs.launchpad.net/ubuntu/+s...ll/+bug/571707
    https://bugs.launchpad.net/ubuntu/+s...th/+bug/572786

    Essentially if it hangs, it may finish in about 5 minutes or more. Sometimes hitting an arrow key around the 85% mark I believe helps it continue for some reason. This bug needs more investigation, but it will definitly bother many people. Just to test it, you can sudo touch /forcefsck and see if you have the problem on bootup. Thanks for making this post a sticky, keeping common bugs together for everyone to see.

  7. #7
    Join Date
    Sep 2009
    Beans
    101
    Distro
    Xubuntu 11.04 Natty Narwhal

    Re: Known Lucid Lynx issues/bugs with workarounds

    If Pitivi gives errors, and the gstreamer packages have been installed, reinstall pitivi from synaptic.

    Also, thanks for the gconf min-max-close syntax.

  8. #8
    Join Date
    Aug 2008
    Beans
    17
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Known Lucid Lynx issues/bugs with workarounds

    Hi, there is a rather permanent problem with the propietary ati drivers. Maximizing and unminimizing is terribly slow with compiz enabled. There are several workarounds, however. You could either try the no-backfill xserver, the back-clear patch or enable Direct2D.

    Direct2D can be enabled with the following steps:

    1. backup your current xorg.conf

    ~$ cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak


    2. delete the contents of xorg.conf

    3. let aticonfig make an initial configuration:

    ~$ sudo aticonfig --initial

    4. then enable Direct2D:

    ~$ sudo aticonfig --set-pcs-str=DDX,Direct2DAccel,TRUE

    I personally prefer the backclear patch as I noticed that although the maximizing issue is reolved with Direct2D, scrolling in for example emacs becomes totally sluggish. You can find more information on the backclear patch here:

    http://www.phoronix.com/forums/showthread.php?p=125046

    log out and in and enjoy your fancy desktop. hope it helps.

  9. #9
    Join Date
    Apr 2006
    Location
    Galax,Va. USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Known Lucid Lynx issues/bugs with workarounds

    This has to do with the problem Brasero is having not being able to burn an audio CD using an mp3 play-list from Rhythmbox or using nautilus.

    The problem with Brasero has been fixed upstream. Below is a link to the bug report and at the end of the report is a link to a Brasero build with the fix applied. Thanks to all who helped.

    https://bugs.launchpad.net/ubuntu/+s...ro/+bug/543892
    Last edited by Eddie Wilson; May 25th, 2010 at 03:55 PM.
    Iguana

    Registered Linux User #490719

  10. #10
    Join Date
    Jul 2007
    Beans
    9

    Re: Known Lucid Lynx issues/bugs with workarounds

    Sound: Weird/broken surround-sound volume control

    Since Karmic (9.10), a lot of people had and still have problems with correctly changing the volume of their speakers within a surround sound setup. An according launchpad link is https://bugs.launchpad.net/ubuntu/+s...io/+bug/410948.

    The background is PulseAudio trying to make everyone's life easier and providing simpler volume controls, which hide the actual hardware controls, as these are often not to easy to understand for the average user, and different settings may lead to the same output volume but with different quality (see here: http://pulseaudio.org/wiki/PulseAudioStoleMyVolumes). Unfortunately, this good approach seems to have trouble with certain sound cards, e.g., with my SoundBlaster Live. I do not know who is to blame for that (PulseAudio, Alsa, Hardware), and this question is clearly beyond the scope of this guide.

    The problem is known (e.g., see launchpad link above, or http://ubuntuforums.org/showthread.php?t=1234894&page=3), and several workarounds can be found, e.g., https://wiki.ubuntu.com/DebuggingSou...ge%20anomalies, but none did suffice for me, as they all left me with some channel controls disabled.

    I think I found another workaround which has not been posted here yet. The post is rather long. I'm sorry for that, but I wanted to provide at least a little background information, as well as a (hopefully) foolproof step-by-step guide to this workaround (ment to be usable by the average or even beginning user).

    My (sound) system setup
    • Ubuntu 10.04 (Lucid)
    • Sound Blaster Live Value, a PCI card with two 2channel analog output jacks
    • a traditional surround-4.0 speaker setup, i.e., two front and two rear speakers


    What I want
    The traditional 4.0 surround sound and the ability, to control the individual speakers properly.

    What I get
    The sound preferences gui lets me choose "Analog 4.0 output and Mono input", which matches my physical setup so far. All speakers are indeed working, but changing the volume results in very strange changes of the individual channel volumes: The rear speakers reach a high volume very quickly, and only after that, the front speakers catch up and finally even drown out the rear ones.

    Running "alsamixer" from a terminal reveals: Among others, my sound card has controls named Master, PCM, and, Surround. The first strange thing is: Master only controls the front speakers, Surround only the back speakers, and PCM both, but not in the same way. When increasing only the PCM control, the front speaker volume is actually increasing (much!) more than the rear speaker volume!

    Anyway, this first strangeness is totally up to ALSA, and not PulseAudio. In fact, PulseAudio correctly identifies the responsible channels. However, when increasing the volume via PulseAudio (now using the volume applet at the panel), at first, PCM is JUMPING to a high level, shortly afterwards followed by Surround, and finally, followed by Master. Furthermore, all unused channels (for me: Center and LFE) are set to 100% by PulseAudio.

    Apparently, this strange behavior has been observed many times before (see links provided above). Starting with Ubuntu 9.10 (Karmic), it happens each time, anything else than classical stereo sound is used.


    Which workarounds did NOT work
    If you don't understand everything/anything in here, don't mind, and skip to the next section.

    1. Passing "ignore_dB=yes" to module "module-udev-detect" or to module "module-alsa-card". This resulted in PulseAudio only controlling the master channel, i.e., my front speakers.
    2. Restrict controls to PCM-only, as has been proposed by others before. First of all, I want to control ALL of my four channels. Second of all, my PCM control itself is weird (as mentioned above).
    3. Using "module-detect" instead of "module-udev-detect". I didn't manage to get surround sound then, even if the number of channels has been set to 4 in daemon.conf.


    What finally DID work
    The solution for me was to deactivate any auto-detection and to use "module-alsa-sink" instead of "module-alsa-card" (which is used as the result of auto-detection via "module-udev-detect").

    Step-by-Step guide:

    1. Please start with a clean system, i.e., you have not tampered with any files in "/etc/pulse/", "~/.pulse/", "/usr/share/pulseaudio", or "/usr/share/alsa" (if you don't know what that is, you haven't).
    2. Open a terminal (Applications->Accessories->Terminal). From this point, any commands have to be typed in there, if not stated otherwise.
    3. Find the ALSA number of your sound card. If you only have one sound card, it is "0". Otherwise, run "aplay -l | grep card" (within the terminal, without the qoutes). See the word "card" followed by a digit followed by a string with the name of the sound card? Pick the digit. And don't worry that the same card is there multiple times.
    4. Run "cp /etc/pulse/default.pa ~/.pulse/". Now run "gedit ~/pulse/default.pa". A text editor with that file opened should pop up.
    5. Within the text editor, find line ".ifexists module-udev-detect.so". Outcomment this line by prepending a "#" to it. From this line, outcomment all following lines until the first ".endif", inclusively (you should now have typed in five "#" letters).
    6. Still within the text editor, and after the ".endif" line you just outcommented, add a line "load-module module-alsa-sink device=surround40:0" (without the qoutes, of course). Change the digit after the colon to the one of your card (see step 3). Change the "surround40" to your speaker setup accordingly. For example, for two front, one center, and two rear speakers, as well as a subwoofer (that has a separate jack at the sound card), change it to "surround51". Don't forget to save.
    7. Restart pulseaudio by running within the terminal "killall pulseaudio". PulseAudio will restart immediately with the new configuration. Please note, that any previous volume adjustments within the panel volume applet need to be done again (from PulseAudio's view, we now have a new device, for which no user settings exist yet).
    8. Make the terminal window wider and run "alsamixer". Now move the panel applet's volume slider around. If everything is ok, the sliders within alsamixer do NOT move, i.e., the hardware sliders do not move, but the volume is nevertheless actually changing. This means, PulseAudio now does the volume control in software, but this volume cannot exceed the maximum hardware settings. Therefore, within alsamixer, adjust the sliders to the balance and maximum volume you desire. For example, I have chosen Master and Surround to be 87%, and PCM to be 65%.


    Congratulations, you made it.

    Shortcomings of the approach
    Is this a solution? No, it is merely a workaround with several issues:
    1. Probably most severe, we now have a static setup. So forget your usb headset plugged in during runtime. Actually, currently we don't even have setup any static input (microphone).
    2. Volume control is done in software instead of hardware, which may result in suboptimal noise-loudness ratios.
    3. A verbose log showed that this method neither allowed for memory-mapped IO, nor for PulseAudio's timer-based scheduling method, although my card actually provides the required capabilities (shown in a log with the original flawed method). This means, both CPU load and latency may be suboptimal.
    4. From a user's point of view, setting up such a workaround is inacceptable.


    So lets hope that this issue is actually resolved eventually (it's known for over half a year now, *sigh*). Unless this isn't done, I will have to stick to the workaround.

    I hope this will help at least some of you.
    May the force be with you

    Best wishes,
    -- Stefan
    Last edited by stefan_g; May 26th, 2010 at 06:34 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •