Page 1 of 2 12 LastLast
Results 1 to 10 of 21

Thread: Asus Eee 1201n Microphone

Hybrid View

  1. #1
    Join Date
    Dec 2009
    Location
    ~hank
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Asus Eee 1201n Microphone

    HI folks,

    Hope there is some advice out there.

    I have an Asus Eee 1201n which is running Karmic very well, had a couple of issues with wireless but thanks to Realtek support for Linux they released a driver that works perfectly with more recent kernels (2.6.31-20). Quick side note, if you are running this netbook do yourself a favor and try "rtl8192se_linux_2.6.0015.0127.2010" before you use NDISWrapper etc.

    OK, back on topic. Last thing I have left is the built-in microphone (NVIDIA ION HD Audio). GNOME Alsa Mixer sees it, so does the GNOME sound panel, Skype sees it as well but no go. I have tried Alsa backports to no result. There is a thread in these forums for a script (Alsa upgrade script) and although I thank the dude who wrote it I am paranoid as he explicitly says:

    "The script is not in line with Debian/Ubuntu rules for package handling. It just overwrites existing files. You won't see any changes on the ALSA package-ids within Synaptic!"

    And this scares me just a bit. I am about to try this script as I am just plain tired of Skype with a BT headset (my wife calls me a cyborg) so before I kick it off I thought I would ping the "Gurus" and see if there are any other suggestions out there.

    Thanks in advance!

    Hank.

    Solved... Installed the pulseaudio utility and set the 2nd mic channel to 0.
    Last edited by hsoulen; April 7th, 2010 at 03:18 PM.

  2. #2
    Join Date
    Feb 2010
    Beans
    1

    Re: Asus Eee 1201n Microphone

    Hello,

    I have the same computer and the same problem. Could you please give me the steps you took to installing pulseaudio util and using it. I am a noob but am learning a lot. Sadly I just can't figure out how to set those settings to zero like you said.

    Thank you for your help and time!

  3. #3
    Join Date
    Dec 2009
    Location
    ~hank
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Asus Eee 1201n Microphone

    Quote Originally Posted by scstubbs View Post
    Hello,

    I have the same computer and the same problem. Could you please give me the steps you took to installing pulseaudio util and using it. I am a noob but am learning a lot. Sadly I just can't figure out how to set those settings to zero like you said.

    Thank you for your help and time!
    Sure man, hope this helps:

    I am not sure of your level of Linux experience so don't take any offense if these instructions are too verbose.

    1) Open Synaptic Package Mananger from System->Administration
    2) Search for a package with a name like "linux-backports-modules-alsa-karmic-generic" (it will have the name of your distribution, karmic if you have 9.10, lucid if you are running the 10.04 LTS Beta etc.) and mark it for install
    3) Still in Synaptic, search for a package called "pavucontrol" (PulseAudio Volume Control) and mark it for install as well
    4) Hit "Apply" and after the packages have downloaded and installed, reboot linux
    5) Once you log back in, go to Applications->Sound & Video and run "PulseAudio Volume Control"
    6) Click the "Input Devices" tab and you will see your mic but it will have two channels (stereo) a Front Right and Front Left. Well this is just plain wrong! A mic is a mono device, so go ahead and set that Front Right slider all the way to "Silence" (you can leave Front Left at about 80-90%)

    Exit PulseAudio Volume Control and you should now have a working mic in all applications including Skype if you use it.

    Cheers,

    Hank

  4. #4
    Join Date
    Apr 2008
    Location
    Winchester, UK
    Beans
    263
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Asus Eee 1201n Microphone

    Thanks Hank,

    I have an ASUS Eec PC 1001P.

    Following your advice got my sound recorder to record sound. However Skype still does not record.

    Mike

  5. #5
    Join Date
    Dec 2009
    Location
    ~hank
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Asus Eee 1201n Microphone

    Quote Originally Posted by welshmike View Post
    Thanks Hank,

    I have an ASUS Eec PC 1001P.

    Following your advice got my sound recorder to record sound. However Skype still does not record.

    Mike
    Hi Mike,

    Glad we got something working

    Quick question, under Skype->Options->Sound Devices, what does it show? It should show "PulseAudio Server (local)" for all options, also I found that "Allow Skype to automatically adjust my mixer levels" does NOT WORK! In order for my mic to work in Skype I have to un-check that option.

    Also what version of Skype are you using? I am on Beta 2.1.0.81.

    Let me know if this helps, if not we can take a deeper look.

    Hank

  6. #6
    Join Date
    Apr 2008
    Location
    Winchester, UK
    Beans
    263
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Asus Eee 1201n Microphone: actually I have a 1001P

    Quote Originally Posted by hsoulen View Post
    Hi Mike,

    Glad we got something working

    Quick question, under Skype->Options->Sound Devices, what does it show? It should show "PulseAudio Server (local)" for all options, also I found that "Allow Skype to automatically adjust my mixer levels" does NOT WORK! In order for my mic to work in Skype I have to un-check that option.

    Also what version of Skype are you using? I am on Beta 2.1.0.81.

    Let me know if this helps, if not we can take a deeper look.

    Hank
    Hi Hank,

    Apologies from the following long post but it may help other forum members.

    I'm also on Skype Beta 2.1.0.81.

    I believe that it is not a Skype problem but a PulseAudio one.

    Skype did show "PulseAudio Server (local)" for all options. There were no other options.
    I unchecked "Allow Skype to automatically adjust my mixer levels".
    No recording made from inbuilt microphone (using Echo / Sound Test Service"

    Ubuntu System > Preferences > Sound > Input shows no Input level bar movement when I speak into builtin microphone.
    However when I plugged in an external microphone the bars moved.
    Great - It worked and so did Skype sound recording.
    So I looked at Ubuntu System > Preferences > Sound > Input > Choose a device for sound input and it showed "Internal Audio Analog Stereo"
    That looks correct for the builtin mike. So I ask myself why does external one worK???
    Hardware showed Internal Audio 1 Output/1 Input Analog Stereo Duplex.
    When I click Sound Effects > Choose an alert sound: I get the appropriate sound I click like Default or Bark, etc.

    When I boot ASUS Express Gate (which I believe is a tiny Linux based distro) and select Skype I found that the Sound devices that worked are
    Sound In: HDA Intel (hw:Intel.0)
    Sound Out: HDA Intel (hw:Intel.0)

    Maybe I have a sound driver problem?.

    So being a retired R&D system software engineer I had a play around:
    Using Ubuntu Software center
    - I removed all PulseAudio stuff - problem unsolved.
    - Installed Default Sound Card (ALSA) - problem unsolved
    - Installed GNOME ALSA Mixer. I noticed Mic Boos was at bottom of slider and balance (left right) could not be moved. Capture Rec was ticked - problem unsolved. I unticked Rec - problem unsolved. I reticked Rec - PROBLEM SOLVED. SKYPE RECORDING WORKS ON INTERNAL MIKE!!!
    Just to be sure I rebooted Ubuntu.
    Skype recording still works on internal Mike.
    Tried my external boom mike It works but lots of buzzing even at no or less than amplified input. It is fine on my old laptop but needs input amplified.

    Regards
    Mike

  7. #7
    Join Date
    Dec 2006
    Location
    Blacksburg, VA
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Talking Re: Asus Eee 1201n Microphone

    Quote Originally Posted by hsoulen View Post
    Sure man, hope this helps:

    I am not sure of your level of Linux experience so don't take any offense if these instructions are too verbose.

    1) Open Synaptic Package Mananger from System->Administration
    2) Search for a package with a name like "linux-backports-modules-alsa-karmic-generic" (it will have the name of your distribution, karmic if you have 9.10, lucid if you are running the 10.04 LTS Beta etc.) and mark it for install
    3) Still in Synaptic, search for a package called "pavucontrol" (PulseAudio Volume Control) and mark it for install as well
    4) Hit "Apply" and after the packages have downloaded and installed, reboot linux
    5) Once you log back in, go to Applications->Sound & Video and run "PulseAudio Volume Control"
    6) Click the "Input Devices" tab and you will see your mic but it will have two channels (stereo) a Front Right and Front Left. Well this is just plain wrong! A mic is a mono device, so go ahead and set that Front Right slider all the way to "Silence" (you can leave Front Left at about 80-90%)

    Exit PulseAudio Volume Control and you should now have a working mic in all applications including Skype if you use it.

    Cheers,

    Hank
    This worked perfectly for me with my 1201N running 10.04 thanks!

  8. #8
    Join Date
    May 2009
    Location
    Michigan
    Beans
    177
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Asus Eee 1201n Microphone

    Unfortunately, neither of these solutions worked for me. I can record sounds in the "Sound Recorder" application, but not in Skype. I tried using the PulseAudio and GNOME ALSA Mixer, but neither worked. Any other suggestions?
    T

  9. #9
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Asus Eee 1201n Microphone

    Quote Originally Posted by temporos View Post
    Unfortunately, neither of these solutions worked for me. I can record sounds in the "Sound Recorder" application, but not in Skype. I tried using the PulseAudio and GNOME ALSA Mixer, but neither worked. Any other suggestions?
    Try this. Try this. Use a terminal="Applications->Accessories->Terminal"
    Enter these commands, one line at a time:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    Reboot.

  10. #10
    Join Date
    Aug 2011
    Beans
    1

    Exclamation Re: Asus Eee 1201n Microphone

    I had the same microphone issue in skype on ubuntu 11.04. however, i could not apply the fix because no left/right channels were shown for the microphone. they do exist. until i chose to 'show all except monitors', however, i could not see them. THIS FIX WORKS IN UBUNTU 11.04 TOO but it seems pulseaudio volume control interface has been reworked from previous major release. hope this helps
    Attached Images Attached Images

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •