Results 1 to 10 of 38

Thread: Enable Wireless - unchecked and greyed out

Hybrid View

  1. #1
    Join Date
    Sep 2009
    Beans
    5

    Enable Wireless - unchecked and greyed out

    Hi everyone,

    I'm hoping you can help with a query. I'm running Ubuntu Linux 9.10 and have been connected to my wireless modem/router (linksys) without any trouble.

    Until today, when I foolishly decided to change my system password. I was prompted for my network password which I thought I had correct, but apparently didn't. Now, when I click on my icon for internet connections the 'enable wireless' button is unchecked, and greyed out, so I can't click it back on.

    I logged into my modem/router and re-set the password, and that's all okay.

    In the meantime I'm connected via the cable to the router.

    I checked the settings and my network is disabled as per below. I've unplugged and restarted the linksys, and also my laptop several times.

    I know this set up works, I just need to find the 'switch' to turn the wireless networking back on.

    Thanks for your help!
    Lisa

    lisa@lisa-laptop:~$ sudo lshw -C network
    [sudo] password for lisa:
    *-network DISABLED
    description: Wireless interface
    product: AR5001 Wireless Network Adapter
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:01:00.0
    logical name: wmaster0
    version: 01
    serial: 00:15:af:1e:a5:bf
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
    configuration: broadcast=yes driver=ath5k latency=0 multicast=yes wireless=IEEE 802.11bg
    resources: irq:19 memory:dc7f0000-dc7fffff
    lisa@lisa-laptop:~$ ^C
    lisa@lisa-laptop:~$ ^C
    lisa@lisa-laptop:~$

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,099
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Enable Wireless - unchecked and greyed out

    *-network DISABLED
    description: Wireless interface
    product: AR5001 Wireless Network Adapter
    I just need to find the 'switch' to turn the wireless networking back on.
    That's exactly what it looks like. Please post:
    Code:
    rfkill list
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Sep 2009
    Beans
    5

    Re: Enable Wireless - unchecked and greyed out

    thanks for your help

    is this what you are after?

    lisa@lisa-laptop:~$ rfkill list
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    lisa@lisa-laptop:~$

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,099
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Enable Wireless - unchecked and greyed out

    Yes! This means there is a hardware switch or slider somewhere on your laptop that switches the wireless on and off. It is switched off.
    lisa@lisa-laptop:~$ rfkill list
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    Find it, switch it and be back in business.
    I just need to find the 'switch' to turn the wireless networking back on.
    Totally.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    May 2010
    Beans
    18

    Re: Enable Wireless - unchecked and greyed out

    I have the exact same problem!

    The command
    Code:
    rfkill list
    gives the following for me:

    Wireless Hardware Switch On
    0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no


    Wireless Hardware Switch Off
    0: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    1: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes


    Wireless Hardware Switch On Again
    0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no


    Wireless Hardware Switch Off Again
    0: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    1: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    and so on....

    Any idea why this is happening? I have another Gateway Laptop where I have no problems at all connecting to wireless networks. So is this some driver problem or a bug?

    Any quick fixes?

    I'm on Ubuntu 10.04 and my Wireless Card is:
    Intel Wireless 6200 AGN

  6. #6
    Join Date
    Jan 2007
    Location
    Ciudad Juarez
    Beans
    47
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Enable Wireless - unchecked and greyed out

    I have a Dell Inspiron 1720 where, if I reboot my computer with the wifi switch turned ON, I cannot connect to any wifi networks, the "enable wireless" is unchecked and grayed out. However, if I make sure to have my switch in the OFF position when it's rebooting, once I log in, I turn ON my wifi and I am able to connect. It really sucks having to remember to turn off my wifi, or even worse, having to reboot my computer just because I forgot to turn it off. This happens to me with both Broadcom drivers. Here are some outputs:
    Code:
    lspci | grep Broadcom
    03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
    0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
    Code:
    rfkill list
    0: hci0: Bluetooth
    	Soft blocked: yes
    	Hard blocked: no
    1: dell-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    2: dell-bluetooth: Bluetooth
    	Soft blocked: yes
    	Hard blocked: yes
    Any help is really appreciated.

    EDIT: After reading a few more posts, I found that by running "sudo rmmod -f dell-laptop" I am able to turn on the wifi.
    Last edited by arqbrulo; July 5th, 2010 at 12:01 AM. Reason: Solved
    "Yo no soy cobarde, Padre, yo soy pacifista, que no es lo mismo. Odio el derramamiento de sangre inutil, y tambien el util. Por eso yo odio la guerra. La guerra fria, la guerra caliente y la guerra fria." -- Tin Tan

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •