Results 1 to 2 of 2

Thread: octave modules dependencies

Hybrid View

  1. #1
    Join Date
    Dec 2007
    Location
    In the lab
    Beans
    122

    Dependencies of octave modules/toolkits (3.0 or 3.2)

    Hi

    I installed octave 3.2. Later, I also installed some modules (statistics and image modules to be more exact) and noticed that these have octave 3.0 as dependencies. When I now run octave it's version 3.0 not 3.2.
    Is there any reason for the modules to require octave 3.0? Would they not work in 3.2?
    Thanks in advance

    EDIT 1: I was told by a friend (MatLab user) that the "modules" should actually be referred as toolkits. I'm a new user of this languages, all I knew was Perl.

    EDIT 2: I'm using ubuntu 9.10
    Last edited by carandraug; February 13th, 2010 at 08:16 AM.

  2. #2
    Join Date
    Dec 2007
    Location
    In the lab
    Beans
    122

    Re: octave modules dependencies

    I got it working. Seems that they are actually different. The modules/toolkits/packages in the repositories seem to be for octave 3.0 only. When I was running octave from the terminal it would choose to run 3.0 instead of 3.2 because it had both installed. This can be solved by running
    Code:
    /usr/bin/octave3.2
    instead of just
    Code:
    octave
    This however does not solve the fact that I couldn't use the packages. They are, however, fairly easy to install manually. Just download the packages you want from http://octave.sourceforge.net/packages.php and then from the octave prompt run
    Code:
    pkg install package_file_name.tar.gz
    some packages may have other packages as dependencies but they should be listed in the package details page.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •