Page 1 of 2 12 LastLast
Results 1 to 10 of 45

Thread: Boot problem - "Gave up waiting for root device.", (initramfs)

Hybrid View

  1. #1
    Join Date
    Feb 2010
    Beans
    8

    Boot problem - "Gave up waiting for root device.", (initramfs)

    Hello:

    I installed Ubuntu 9.10 and things were working fine. Today however my laptop will not boot. It shows me the GNU GRUB screen asking me to choose between any kernel version 2.6.31-[14, 16, 17, 19]-generic both normal versions and "recovery mode" versions (before it chose one of these options automatically after a few seconds).

    If I choose the non-recovery mode kernels (any version), it eventually gets stuck in a black screen. After pressing any key, I get this message:

    ------------
    Gave up waiting for root device. Common problems:
    ... ...(shows a list of three common problems)
    ALERT! /dev/disk/by-uuid/(a long id) does not exist. Dropping to a shell!
    BusyBox v1.13.3 ...
    (initramfs)
    ------------

    If I try one of the "recovery mode" kernel versions (any and all), I get the same message but the last few lines printed out before this same message are:

    -------------
    Begin: Waitin for root file system... ...
    Done.
    Gave up waiting for root device. (etc.)
    -----------

    Thanks in advance for your help.

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    joaqal,

    First, welcome to Ubuntu and the Ubuntu forums.

    Please boot the LiveCD and run the boot info script from the following link. Make sure to post the results inside "code" brackets by clicking the # icon in the post's menu.

    http://bootinfoscript.sourceforge.net/

    If you feel the need to experiment, you can try editing the menu entry in the Grub 2 menu. It may work and it wouldn't take long to try:

    1. Highlight an old, working kernel from the Grub 2 menu.
    2. Press "e" to open the menu entry for editing.
    3. Remove the entire "search" line. Use the Up/Dn cursor to place at the start of the line and hold the DEL key.
    4. On the "linux" line, change the part "root=UUID=<long number>" to "root=/dev/sdXY" with X being your Ubuntu drive and Y being your Ubuntu partition. Leave the rest of the line as is.
    5. CTRL-x to boot.

    If it doesn't work, post the script results. If it does, run "sudo update-grub" and then post the results if it doesn't reboot properly.

    Note: There are more detailed ways of trying to get to a bootable system from the Grub 2 menu. If you want to try them, refer to:
    https://help.ubuntu.com/community/Grub2#Command Line Rescue Mode
    GRUB2

    Retired.

  3. #3
    Join Date
    Feb 2010
    Beans
    8

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    Hi dsr305:

    Thanks! It is booting correctly now. I followed your advice precisely and editted th .16 kernel from the GNU GRUB boot menu. After updating grub, I tried kernels .16 and .19 and they both worked.

    For others who might be having the same problem: sdXY for me was "sda7" (so the X was a letter for me) and I could figure this out from the script output "RESULTS.txt" (it is one of the Linux partitions) and by mounting the available drives from the "places" menu from inside LiveCD (to see which partition is data and not an OS). After mounting, the drives had a long id, and the mapping from id to "sda7" was found in RESULTS.txt.

    Thanks again!

  4. #4
    Join Date
    Feb 2010
    Beans
    3

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    I tried as you had listed and it worked after i noticed i had made the edit to the .19 kernel the first time instead of the .14...
    Last edited by Danb5854; March 3rd, 2010 at 04:05 PM.

  5. #5
    Join Date
    Jan 2008
    Location
    Yonah Mountain
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    I am having the same problem. This is the second time that I have had boot problems after sudden shut down. Once from, I think a display freeze and one other time from a power failure without power backup. I have since learned about REISUB for an app. freeze.
    Anyway, is this problem because I have the root and home partition format as ext2? If that is the problem is there a way for me to make new partitions as ext3, then move the data to the new ext3 partitions?
    But first I need to rescue my root partition. Working......

  6. #6
    Join Date
    Jan 2008
    Location
    Yonah Mountain
    Beans
    28
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    I hope someone can help me. Gparted partition information does not show a label or UUID for my root partition. I am really in the weeds. Right now I am afraid to do anything without knowing what I am doing. I use this desktop PC for my business. I do have a backup from a couple of days ago of all my data, so I am OK with that respect. I do not relish the idea of having to rebuild my entire system.

  7. #7
    Join Date
    Dec 2005
    Location
    East of Paris - France
    Beans
    68
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    Excellent! I love this community!

    Thanks a lot for this.

    It took me some effort to convince my wife that her mum (who's not computer litterate at all, even barely litterate) should use ubuntu (UNR) over Windows 7 (on her new Samsung R730) for simplicity and after I completed the tuning for her the boot failed so I was on the grill again ...

    But here is the solution to the issue. I wish I understand where is the issue itself as I will not always be there to fix it.

    I my case, I used ext4. So I don't thing this is the problem.

    Anyone knows what's triggering this problem?

    JT

  8. #8
    Join Date
    Oct 2011
    Beans
    1

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    Quote Originally Posted by drs305 View Post
    joaqal,

    First, welcome to Ubuntu and the Ubuntu forums.

    Please boot the LiveCD and run the boot info script from the following link. Make sure to post the results inside "code" brackets by clicking the # icon in the post's menu.

    http://bootinfoscript.sourceforge.net/

    If you feel the need to experiment, you can try editing the menu entry in the Grub 2 menu. It may work and it wouldn't take long to try:

    1. Highlight an old, working kernel from the Grub 2 menu.
    2. Press "e" to open the menu entry for editing.
    3. Remove the entire "search" line. Use the Up/Dn cursor to place at the start of the line and hold the DEL key.
    4. On the "linux" line, change the part "root=UUID=<long number>" to "root=/dev/sdXY" with X being your Ubuntu drive and Y being your Ubuntu partition. Leave the rest of the line as is.
    5. CTRL-x to boot.

    If it doesn't work, post the script results. If it does, run "sudo update-grub" and then post the results if it doesn't reboot properly.

    Note: There are more detailed ways of trying to get to a bootable system from the Grub 2 menu. If you want to try them, refer to:
    https://help.ubuntu.com/community/Grub2#Command Line Rescue Mode
    Thanks a lot to drs305. It works for me.

  9. #9
    Join Date
    Jul 2011
    Beans
    1

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    Quote Originally Posted by drs305 View Post
    joaqal,

    First, welcome to Ubuntu and the Ubuntu forums.

    Please boot the LiveCD and run the boot info script from the following link. Make sure to post the results inside "code" brackets by clicking the # icon in the post's menu.

    http://bootinfoscript.sourceforge.net/

    If you feel the need to experiment, you can try editing the menu entry in the Grub 2 menu. It may work and it wouldn't take long to try:

    1. Highlight an old, working kernel from the Grub 2 menu.
    2. Press "e" to open the menu entry for editing.
    3. Remove the entire "search" line. Use the Up/Dn cursor to place at the start of the line and hold the DEL key.
    4. On the "linux" line, change the part "root=UUID=<long number>" to "root=/dev/sdXY" with X being your Ubuntu drive and Y being your Ubuntu partition. Leave the rest of the line as is.
    5. CTRL-x to boot.

    If it doesn't work, post the script results. If it does, run "sudo update-grub" and then post the results if it doesn't reboot properly.

    Note: There are more detailed ways of trying to get to a bootable system from the Grub 2 menu. If you want to try them, refer to:
    https://help.ubuntu.com/community/Grub2#Command Line Rescue Mode

    10x drs305!!
    Great post. Realy helped me out after my 2-days fight with my power cut problem. But i have one stupied question: after changing the GRUB settings and a successful boot, GRUB doesn't save my changes and i have to edit my kern every time i restart or shut down my laptop. 10x for the help in advance.

  10. #10
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Boot problem - "Gave up waiting for root device.", (initramfs)

    Quote Originally Posted by Tmpv View Post
    GRUB doesn't save my changes and i have to edit my kern every time i restart or shut down my laptop. 10x for the help in advance.
    In most cases, after booting, all you should have to do is run the following command to update the Grub menu. It will search your drives and update the UUIDs so that Grub looks in the proper location for the boot files.

    Code:
    sudo update-grub
    GRUB2

    Retired.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •