Results 1 to 10 of 27

Thread: Sharing files and Internet connection w/crossover cable & Win XP client

Hybrid View

  1. #1
    Join Date
    Oct 2007
    Beans
    668
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Sharing files and Internet connection w/crossover cable & Win XP client

    I just gave up trying to do it, because I couldn't make it work despite an hour or so of effort. Can someone please walk me through the process of sharing the Internet connection of an Ubuntu 9.10 machine with a Windows XP client, using a Cat5 crossover cable between the host and client?

    I would also like to be able to transfer files between the host and client. They both have gigabit NICs, so it should be faster than going through the router ("only" 100 megabit). That is, in fact, a big reason I'm using an Ethernet crossover cable instead of connecting the client to my router. The other reason is that I like to tinker with stuff, and can't stand the thought of my Ubuntu 9.10 box's extra NIC going unused.

    To clarify, here's the hardware involved:

    -Linksys BEFSX41 wired router, connected to my cable modem for Internet access.

    -Ubuntu 9.10 desktop (host), with two wired, gigabit Ethernet NICs (named by Ubuntu as eth0 and eth1, with eth1 being connected to the router via conventional Cat5 cable, eth 0 connected to the Win XP client via crossover cable)

    -Windows XP netbook, with wired, gigabit Ethernet NIC

    -One Cat5 crossover cable (to connect WinXP client to Ubuntu 9.10 host).

    FWIW, the NICs on the Ubuntu 9.10 machine are both Marvell 88E8056 PCI-E adapter, built into the motherboard (Asus P5E3 WS Pro). The netbook has an Atheros 8121-series NIC.

    I don't expect the router will require any configuration, since I am primarily concerned with getting the Windows XP machine to see the Ubuntu 9.10 machine's extra NIC, and vice versa.

    One other thing: Previously, the NetworkManager applet showed both NICs on my Ubuntu 9.10 machine, naming them eth0 and eth1, with eth1 being the one that was plugged into my router (and the Internet). Now, thanks to my attempt to follow the tutorial here (https://help.ubuntu.com/community/In...nectionSharing), the applet simply says "device not managed" where it used to say "auto eth0." How can I undo the damage I apparently did by trying to follow that tutorial, which didn't work anyway? Or is that not important?

  2. #2
    Join Date
    Dec 2009
    Location
    Panama City, FL, USA
    Beans
    543
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sharing files and Internet connection w/crossover cable & Win XP client

    Do both eth0 and eth1 show up in the output of ifconfig? If eth0 doesn't show up try typing "ifconfig eth0 up".

    Once you get your "auto eth0" option back in NetworkManager, right click the icon for it and go to Edit Connections. Highlight "auto eth0" and click Edit. Under IPV4 Settings select Shared to Other Computers from the method drop-down list. That should do what you want.

  3. #3
    Join Date
    Oct 2007
    Beans
    668
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Sharing files and Internet connection w/crossover cable & Win XP client

    It won't work. Despite ifconfig showing the following output:
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:22:15:2f:4f:11  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:18 
    
    eth1      Link encap:Ethernet  HWaddr 00:22:15:2f:4e:b5  
              inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::222:15ff:fe2f:4eb5/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:12913 errors:0 dropped:0 overruns:0 frame:0
              TX packets:10642 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:14040550 (14.0 MB)  TX bytes:1556586 (1.5 MB)
              Interrupt:19 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:1066 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1066 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:76420 (76.4 KB)  TX bytes:76420 (76.4 KB)
    there is no "Auto eth0" entry in the NetworkManager applet. Where I used to see Auto Eth0, it just says "device not managed" in grayed-out text.

    If I go to "Edit Connections" there is an entry called "Ifupdown (eth0)" but I can't edit it. What is that?

  4. #4
    Join Date
    Dec 2009
    Location
    Panama City, FL, USA
    Beans
    543
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Sharing files and Internet connection w/crossover cable & Win XP client

    If that's there but greyed out you'll need to edit your /etc/network/interfaces file and remove the eth0 section. Then do this:
    Code:
    sudo service networking restart
    You should get the option back in NetworkManager.

  5. #5
    Join Date
    Oct 2007
    Beans
    668
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Sharing files and Internet connection w/crossover cable & Win XP client

    eth0 is back, but I'm getting constant notifications in the upper right of my screen. It keeps popping up a window saying "Wired network Connection Established." It won't go away and is quite distracting. How do I get rid of that?

    Also, "sharing" the extra NIC (eth0) didn't work. My Windows XP machine can't connect to anything.
    Last edited by Objekt; January 23rd, 2010 at 10:14 PM.

  6. #6
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,906
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Sharing files and Internet connection w/crossover cable & Win XP client

    You didn't say the most important thing: Are you setting manual IP addresses to the ubuntu host and winxp client NICs?

    The connection towards your router is fine because your router DHCP is providing it with address.
    But the NICs connected with the crossover need manual addresses. Not to confuse it with your router home network which is probably in 192.168.x.x subnet, for the NICs use something like:

    Ubuntu host
    Address 10.0.0.1
    Netmask 255.255.255.0
    Gateway empty (if you are not using this NIC for internet, and you're not, I think gateway not needed)
    DNS empty (maybe, I've never tried this)

    WinXP client
    Address 10.0.0.2
    Subnet mask (netmask) 255.255.255.0
    Gateway 10.0.0.1 (you might be able to actually share internet this way)
    DNS best use OpenDNS servers 208.67.222.222; 208.67.220.220

    They should be able to see each other after that, confirm by trying to ping one address from the other computer.
    But as far as file sharing, you will have to figure out whether any firewall will be blocking you, whether files can just be shared like that between linux and windows (don't you need samba???), etc. I don't have a clue about that.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 7 Ultimate 64bit

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •