Results 1 to 9 of 9

Thread: ATI troubles...

Hybrid View

  1. #1
    Join Date
    Jan 2006
    Beans
    14

    Exclamation ATI troubles...

    I'm having some troubles installing ATI driver for my Radeon 9600XT 256MB
    I know there is alot of guides and stuff on this forum and all that but i have manedge to install the one from ATI's homepage but i don't know if I got the right one...
    I got the installer because i use Ubuntu so idont wanna mess with .rpm files.. so i downloaded this new installer and browsed to the file and typed "sh name_on_driver-8.21.7-installer.run" or whatever the name and the program starts.. i install the driver (I think) and nothing happens.. when I get a openGL and 3D-acceleration test it fails so I don't really know what the prob is...

    anyone else with this problem or anyone who had it and solved it??
    Would appreciate any helping answer!

  2. #2
    Join Date
    Jan 2006
    Beans
    15
    Distro
    Ubuntu Breezy 5.10

    Re: ATI troubles...

    A bit more info would be appreciated.

    Do you have the 32 or the 64 bits vesion of ubuntu?
    And run fglrxinfo and post the results here.

  3. #3
    Join Date
    Jan 2006
    Beans
    14

    Re: ATI troubles...

    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

    There's the resaults of fglrxinfo.. I have 32 bits version.

  4. #4
    Join Date
    Nov 2005
    Beans
    297

    Re: ATI troubles...

    follow this guide http://ubuntuforums.org/showpost.php?p=423584

    you already have the installer so it should be easy

    then run sudo dpkg-reconfigure xserver-xorg and select fglrx

  5. #5
    Join Date
    Jan 2006
    Beans
    15
    Distro
    Ubuntu Breezy 5.10

    Re: ATI troubles...

    Actually I would recommend the http://ubuntuforums.org/showthread.php?p=423589
    This one is easier...

    I have tried both with my Radeon 9800 pro AIW and only this one has worked flawlessly...

  6. #6
    Join Date
    Jan 2006
    Beans
    15
    Distro
    Ubuntu Breezy 5.10

    Re: ATI troubles...

    Please do tell how it went!

  7. #7
    Join Date
    Feb 2006
    Beans
    1

    Re: ATI troubles...

    I have the exact same error message in regards to fglrxinfo, and this is a fresh install. Somehow this never happened with my 5.04 install. Everytime I reboot, my X config is completely screwed (No device, etc) and I have to revert to my old 'ati' drivers. I own an ATI Radeon X850.

    fglrxinfo

    Xlib: extension "XFree86-DRI" missing on display ":0.0".
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
    I originally tried installing the driver using the HowTo on Ubuntu's wiki, to no avail. Trying the above two walkthroughs hasn't remedied the mesa issue either unfortunately, despite the system recognising that I have an ATI card

    lspci
    0000:01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4b49
    0000:01:00.1 Display controller: ATI Technologies Inc: Unknown device 4b69
    According to this, http://thinkwiki.org/wiki/Problems_with_fglrx, occasionally it can just be a softlink issue, but I checked everything and all of it is pointing to the right files.

    Anyone have any idea of what it could be?
    Last edited by Azmak; February 12th, 2006 at 11:12 AM.

  8. #8
    Join Date
    Feb 2006
    Beans
    2
    Distro
    Dapper Drake Testing/

    Re: ATI troubles...

    Quote Originally Posted by Azmak
    According to this, http://thinkwiki.org/wiki/Problems_with_fglrx, occasionally it can just be a softlink issue, but I checked everything and all of it is pointing to the right files.

    Anyone have any idea of what it could be?
    I had a similar problem. Looking around I found two versions of libGL.so.1.2, one in /usr/lib/ and another in /usr/X11R6/lib/

    Copied the more recent /usr/lib/ version into /usr/X11R6/lib/ (after taking a copy, of course) and presto.

  9. #9
    Join Date
    Nov 2005
    Beans
    297

    Re: ATI troubles...

    reading around im not entirely sure if your card works with the fglrx drivers

    read around here http://www.rage3d.com/board/forumdisplay.php?f=88

    and this thread http://www.rage3d.com/board/showthre...3844819&page=2
    Last edited by newuser111; February 12th, 2006 at 12:06 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •