Just an Update that this will install on Ubuntu 10.04 64 bit as well.
You need to correct the following lines from the original post.


sudo ln -s /usr/lib32/libexpat.so.1...