Have you tried installing wireless-compat?