Same problem here, same Ubuntu version. Anyone solved this without a full upgrade?