every time I tried to upgrade I get
"Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/feisty/universe/source/Sources.gz Sub-process gzip returned an error code (1)"
any ideas other than...