PDA

View Full Version : KDE4 Beta Seriously Broken



tripinva
December 2nd, 2008, 05:31 PM
Hello:

I attempted to upgrade my 8.10 in pieces to 9.04, and thus now am attempting to run KDE4.2. It may be that I've not upgraded something that needs upgrading, so I'm now running a full dist-upgrade on the system, but here are my symptoms:

Upon logging in, I get no taskbar. I get no title bars on windows. I have a Konsole set to autostart, which produces just solid gray plus dropdown menus. Pressing Al+F2 to get run gives me a box I cannot type in, and pressing Alt+Tab to try and switch tasks does nothing. Carrier autolaunches, however, and aside from the missing title bars, works fine.

Thoughts, in case my dist-upgrade doesn't fix it?

Thanks.

- Trip

STEVE555
December 2nd, 2008, 07:13 PM
Hi everybody,
I'm getting a similar problem.I'm using Kubuntu Jaunty Jackalope Alpha 1.The probelm is when I get to the KDM login screen,I type in my password and wait for KDE to load up.When it gets there,all I get is the mouse pointer! no taskbar or anything(well firefox loads up after my last session since the upgrade.The major breakage happened after I started upgrading from KDE-4.1.73 to KDE-4.1.80.

Luckily,I have the neon nightly builds that I installed sometime ago,and that is quite stable.I also have windows in dual-boot as well.

I guess I'll have to wait until the rest of the KDE packages get updated/fixed.

I would've posted a thread in the Kubuntu Forums,but they don't have a Jaunty Jackalope specific section yet.I have requested one,but I just have to wait and see.

Regards,
STEVE555

viikinki
December 2nd, 2008, 08:14 PM
I can blame only myself for trying to upgrade kde 4.2 beta1 before official announcement :/ I can confirm that the kwin and plasma are pretty much broken after the upgrade. I can use krunner by using alt+f2 and start applications from it but nothing else works. I will keep you posted when these problems has been corrected. Patience is a virtue (that I don't have);)

awakatanka
December 2nd, 2008, 09:30 PM
probably they updating all packages to 4.1.80 atm, just give it time and it should work again. Bad timing with the update for you ;)

tripinva
December 2nd, 2008, 09:38 PM
I've gone ahead and downgraded the essential packages back to 4.1.2 for now. I'll try upgrading again once there's an update or more packages to upgrade...

- Trip

xebian
December 4th, 2008, 10:33 PM
Everything is now at 4.1.80 and working.:)

kernco
December 5th, 2008, 04:54 PM
In case this helps in figuring out the problem: I've installed KDE 4.2 Beta 1 from experimental in Kubuntu 8.10 and it's working ok.

tripinva
December 6th, 2008, 03:05 AM
Alright, I'm going to attempt to upgrade again. *fingers crossed*

- Trip

tripinva
December 6th, 2008, 04:38 AM
It worked!

Wow, it's so pretty, and so functional. Stacked tasks and a Quicklaunch!

It's got plenty of bugs though. For example, while tasks stack in the Task Manager, items in the tray will start off stacked and then if a file transfer takes place, when it's over they'll end up in a single row which stretches outside of the box. My KMix icon is covering up a Quicklaunch icon. Image attached.

http://ubuntuforums.org/attachment.php?attachmentid=95414&d=1228534715

I also have an empty spot to the left of my Kickoff button. Not sure where that came from.

Otherwise, it's VERY promising and I cannot wait for all the bugs to be ironed out.

- Trip

TheUnabeefer
December 6th, 2008, 11:55 PM
I would just like to see the Quick Access plasmoid come back. I used that one a lot, and now it's gone. **sad**