PDA

View Full Version : Linux Generic Metapackage borked?



Nullack
November 29th, 2008, 12:04 PM
Cruft remover has a long way to go with testing. It turfed my test box and Im in the process of getting it back together.

X wont start because the NVIDIA module has problems, and I cant reinstall the nvidia module because I cant install the linux generic metapackage, which I need for the headers in the driver compile.

Anyone else got this? Hopefully it wont last long and the devs will fix it soon so I can get back to testing :)

Nullack
November 29th, 2008, 12:49 PM
Arg! DKMS fails to build the .28 nvidia kernel module on the linux .28-ub kernel revision.....

plun
November 29th, 2008, 01:02 PM
Arg! DKMS fails to build the .28 nvidia kernel module on the linux .28-ub kernel revision.....

See the kernel thread where autocrosser got the same.

tty is also probably broken for you..

No problem to install nVidia 180.08 within recovery.


Alberto is looking at this issue but it can take time, 180.08 is also a beta driver.

Nullack
November 30th, 2008, 03:05 AM
Its still broken, unmet dependencies exist when trying to install the linux metapackage for the .27 current kernel. It probably wont be fixed until Monday I gather now that the weekend has set in :(

plun
November 30th, 2008, 10:36 AM
Its still broken, unmet dependencies exist when trying to install the linux metapackage for the .27 current kernel. It probably wont be fixed until Monday I gather now that the weekend has set in :(

OK...

But what is broken....:confused:


sudo apt-get install ubuntu-desktop

sudo apt-get install linux


Or use aptitude for even better suggestions.....break risk.

The cruft thing is something special...I tested Grub 2 and it was also something.

Nullack
December 1st, 2008, 04:46 AM
linux-generic:
Depends: linux-image-generic but it is not going to be installed
Depends: linux-restricted-modules-generic but it is not going to be installed

linux-restricted-modules:
Depends: linux-restricted-modules-generic but it is not going to be installed

plun
December 1st, 2008, 09:01 AM
linux-generic:
Depends: linux-image-generic but it is not going to be installed
Depends: linux-restricted-modules-generic but it is not going to be installed

linux-restricted-modules:
Depends: linux-restricted-modules-generic but it is not going to be installed

I cannot see this breakage myself and one way is to follow it "deeper".

linux-restricted-modules-generic > output and so on.

Also to look at aptitude solutions.

DougieFresh4U
December 1st, 2008, 11:07 AM
linux-generic:
Depends: linux-image-generic but it is not going to be installed
Depends: linux-restricted-modules-generic but it is not going to be installed

linux-restricted-modules:
Depends: linux-restricted-modules-generic but it is not going to be installed

I installed the .28 generic last nite with out it bitchin about dependency hell and re-installed 'ubuntu-desktop' as well. Rebooted and all is good including sound. *fingers crossed*

'.28 linux-restricted-modules-generic' is not seen yet