PDA

View Full Version : [ubuntu] 8.10 Multiple auto eth0 problem



kierskoe
November 27th, 2008, 11:23 PM
Hi all,

Having a strange problem with the latest release. Every time I reboot another "auto eth0" connection is added. If I configure a static address within network manager it just ignores it on reboot and adds another dhcp one, if I rename the connection it doesnt work..... and if I edit the interfaces file the connection wont work on reboot but will manually come up and I can ping but it wont execute DNS requests and there is no icon in the panel.

Cheers

cariboo907
November 28th, 2008, 01:23 AM
If you are trying to set a static ip address, you have to disable dhcp. I simply uninstalled dhcp3-client and set up the interface in /etc/network/interfaces.


# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.200
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1

Of course your ip address and gateway will be different.

Jim

kierskoe
December 4th, 2008, 11:40 AM
Cheers for the reply but if you read my post I have already tried manually editing /etc/network/interfaces and run into problems... it seems the interface is active (I can ping locally and from another machine within the LAN) but it does not show in the tray, applications do not see it/cannot use it. The network config on the interface is correct, ip,dns,gateway and netmask. I know it sounds like a routing or dns issue but I have entered the correct entries.

I dont want to uninstall or disable DHCP, for a number of reasons but mostly I expect my OS to be able to correctly apply a static ip to an interface without uninstalling or disabling the DHCP service.

madverb
December 4th, 2008, 12:53 PM
I can ping but it wont execute DNS requests and there is no icon in the panel.

Make sure you add a nameserver to /etc/resolv.conf too!

It seems that once you make the IP static you lose the icon from the menubar. That's what happens to me too.

roundhay
December 7th, 2008, 12:30 PM
I am also having the same issue with 8.10. When I set up a static ip using the network settings it ignores the changes and gose back to DHCP after a restart.

If I make changes to the /etc/networking/interfaces files I lose all connections?

I removed the dchp client as mentioned above and ubuntu would not load after a restart!

Does anyone know how to sort this out?

madverb
December 9th, 2008, 11:51 AM
Add a DNS Server to /etc/resolv.conf and make sure you add a gateway in the interfaces file.

kierskoe
December 13th, 2008, 10:12 PM
Add a DNS Server to /etc/resolv.conf and make sure you add a gateway in the interfaces file.


I am an idiot.... I kept checking resolv.conf while the dhcp connection was up and after editing the interfaces file and the nameserver entry was there... but never after rebooting.

Cheers matey