PDA

View Full Version : [ubuntu] CUPS 1.3.9-2 downgrade



timboellis
November 26th, 2008, 11:12 PM
How can i either downgrade or reinstall cups with an older version?

tgalati4
November 27th, 2008, 01:00 AM
How did you install the 1.3.9-2 version in the first place?

If you added a new repository, then you should be able to do the following:

>sudo apt-get remove cupsys

Go into synaptic repositories and uncheck or remove the offending repository.

Then add cups back through synaptic or close synaptic and:

>sudo apt-get install cupsys

This should restore cups to the default, supported version of cups. Remember, cups is closely tied to your kernel. Change one or the other and breakage occurs.

timboellis
November 27th, 2008, 01:07 AM
Well the problem is that the version of cups does not work on my PC as get a child error 1 .

However been looking around and found that going to a previous version wil resolve the issue