View Full Version : [ubuntu] [SOLVED] Upgrades fail to install. How to remove from command line?

November 25th, 2008, 05:14 AM
The latest package of 15 upgrades for OpenOffice and Pidgin failed to install due to " missing newline.". They can't be removed with synaptic since it produces the same error. How can this last, uninstallable failed 236 meg upgrade be removed from Hardy 8.04 using the command line?
Is there an Ubuntu "system restore" equivalent?

November 26th, 2008, 05:14 AM
This turned out to be bug #108189 in dpkg(Ubuntu):

APt-get, adept, and the restricted drivers manager might halt installing packages when one or more of the files in:
is corrupt.
The error shown will be either:
files list file for package `*' is missing final newline
files list file for package `*' contains an empty filename

Where * start is a random but steady "per install" package name.

described here:
I followed the solution here:

and after a fun 2 hours of carefully following directions, the problem is solved and we are back in business!