View Full Version : [ubuntu] Installing Ubuntu on Optiplex 320

November 24th, 2008, 08:13 PM
Has anyone had any luck installing any version of Ubuntu on this computer? I can go through the installation just fine, but when it reboots into the installed system, I just get a blank screen. Any help?

November 24th, 2008, 08:22 PM
Has anyone had any luck installing any version of Ubuntu on this computer? I can go through the installation just fine, but when it reboots into the installed system, I just get a blank screen. Any help?

computer specs would be helpful. cpu speed, amount of ram, and hard drive size. and version of ubuntu you're using.

November 24th, 2008, 08:39 PM
Intel Pentium D 4945MHz, 1GB RAM, 160GB hard drive, I'm trying to install Ubuntu 8.04 - 8.10 with no luck...

November 25th, 2008, 05:37 AM
Looks like this might work...


December 1st, 2008, 04:08 AM
Hi all,

I have been facing problems similar to a lot of other people (or so it seems from reading all these posts in the forum).

My situation is actually kind of funny -- I tried to install Ubuntu 7.04 sometime around late-May-early-June-ish last year on this (then) newly bought Optiplex 320 (specs: Intel Core 2 Duo, 2GB RAM, 160GB Harddrive) and following Stateman's post (http://ubuntuforums.org/showpost.php?p=2463643&postcount=4) managed to solve the issue (I am a fairly newbie to Linux and most of the time I just blindly followed the suggested steps). Well that worked and I was happy.

From about a month ago I have been trying to make a clean install (my computer got slower -- so didn't try through Synaptic) first of 8.04 and then of 8.10 using the Live CD (verified and tried on other computers where it worked). The Live CD wouldn't even start installing/run Ubuntu from the Live CD without making any change but my computer would just stall -- blank screen -- I have tried some of the suggestions posted elsewhere on this forum but with no luck whatsoever (I find this very disturbing since with 7.04 it at least installed the thing)

Well, I came to know about Wubi eventually, reinstalled Vista (which I hated to do but without any other options left out), installed Wubi and installed 8.10. Now the problem is I don't know of any way to get rid of the Vista, and in the current setting Ubuntu apparently uses only 20GB of the available 160GB. I would never use the Vista and I just want to get rid of it !

I have tried to go through most of the post related to my problem (however being new to the stuff, I might have missed something important from reading through them) but so far I have not been able to find an appropriate solution.

All I want is to make a clean install of 8.10 and just it (i.e no dual boot etc). Any suggestion will be greatly appreciated.

Thanks a bunch in advance,

-- JB

February 4th, 2009, 08:58 PM
Ok, I've got this exact system and the only way I could get it to work was to amend the boot options. When you're presented with the first Ubuntu menu hit [TAB] and put all of the following behind the last word, but before the -- (make sure the -- stays intact and ONE space past your last letter... I don't know why this is so, but it's very cantankerous):

noapic nolapic noacpi pci=noacpi all_generic_ide hpet=disable pnpbios=off

And yes, that is a lot to type every time... that's why you'll want to throw it behind all the options in your /boot/menu.list
Best of luck and let us know how it goes.

Running Mint5 (Ubuntu based distro) Check the new version 6 out at www.linuxmint.com

February 19th, 2009, 12:50 PM

At first I was very happy to see this post. It allowed to -- finally -- move from Gutsy's kernel. But now I realized that with these options, I only get one core running.

Can anyone please comment on which of the options caused this, and how I can restore the second core?


February 19th, 2009, 02:51 PM
Well, I solved my own problem...

I found out by some reading that the likely culprits are the noapic and nolapic parameters. Somewhere in the log of a successful (Gutsy-kernel) boot, I saw that the kernel expected up to 6 extra plug-n-play cores, so I also suspected pnpbios=off.

So my first attempt (with a live-cd) was to just kill all those three, and it worked. My parameters now are just

noacpi pci=noacpi all_generic_ide hpet=disable

And things seem to be working just fine. Two cores.

One little note -- on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/138305 it looks like several people were pleased with just hpet=disable. I wasn't -- I didn't have sound; YMMV.

February 19th, 2009, 02:59 PM
Surprise surprise -- this also fixed a problem I was having with VirtualBox -- a windows VM used to freeze in start-up...

February 25th, 2009, 05:23 AM
Finally! I was looking for some way of installing Mint on a friends Optiplex 320. Thanks a lot to all, this worked great!