PDA

View Full Version : [ubuntu] Tilde (~) character in Courier appears as dash



vertigo23
November 21st, 2008, 10:48 PM
I noticed that the tilde character ("~") appears as a dash ("-") in the Courier New and Courier Pitch fonts, at least when used in gnome-terminal. I really really like using Courier in terminal applications, and the tilde is kind of an important character in Linux and Unix, so what gives?

If this isn't fixable, can anyone recommend a good *serif* monospace font? I hate sans-serif monospace.

THanks!

ciscosurfer
November 21st, 2008, 10:50 PM
Try increasing the text/font size in the Terminal.

popeiler
February 10th, 2013, 01:01 AM
My apologies for exhuming this thread, but it is high on search results. I have found a solution that is a bit preferable to Cisco's above suggestion of increasing font size.

I was able to resolve this issue on my system by adjusting the subpixel hinting and/or DPI setting located in:

Settings > Setting Manager > Appearance > Fonts

set hinting=[slight]
set DPI=[102]

This will increase the effective font size slightly, but it looks much sharper than size 11 or 12 fonts do. Alternatively, changing hinting to something other than slight can resolve the issue.

QIII
February 10th, 2013, 01:17 AM
Please do not resurrect threads that are so old. It dilutes the effectiveness of the Forums.

Thread closed.