PDA

View Full Version : [gnome] 8.10 font problem



mentallysilent
November 21st, 2008, 06:07 PM
Hi,

In 7.10 (Gutsy) I used to be able to set my system fonts to the bitstream series and everything looked nice, including the terminal and firefox.

I can't do this anymore in 8.04 or 8.10. The terminal looks especially hideous. Any way to restore this? And I strongly prefer not to install MS fonts.

Thanks :)

Keyper7
November 21st, 2008, 06:39 PM
When I tried 8.10, I've noticed that for some reason my fonts weren't smoother with the option "subpixel antialiasing" anymore. The option "best shapes" was better. You can try changing your usual font setting and see i it helps.

mentallysilent
November 21st, 2008, 07:40 PM
I have tried all combinations. Actually the only reason I have not upgraded from 7.10 has been the font problem with 8.04 and now 8.10.
such a bummer :(

magnusbb
November 21st, 2008, 07:46 PM
I was recently having the same problem until I did the following:

1. Open a terminal.

2. Type "sudo dpkg-reconfigure fontconfig-config". This will allow you to change the default settings of the font manager.

3. Choose "Autohinter" instead of "Native". As for the other options, use the defaults.

4. Restart your X server (Ctrl + Alt + Backspace).

5. In GNOME, the following font settings work well for me: Smoothing = Grayscale, Hinting = Slight (in the Fonts control panel). I am using it together with the default Ubuntu font (Sans).

Let me know if it worked for you!

Good luck.

mentallysilent
December 6th, 2008, 07:50 PM
Thanks so much. This made a lot of improvement. Still not as good as I used to get it in 7.04
Any suggestions for setting up firefox fonts? I used to follow the instruction on the Gentoo wiki site for antialiasing fonts in firefox.

Zorael
December 7th, 2008, 02:54 AM
Have you toyed around with your ~/.fonts.conf file yet? You can define what fonts make up Serif, Sans-serif and Monospace in there, along with toggling antialiasing, hinting, subpixel rendering, bitmaps, and font replacements.

If you don't have one, here's mine to get you started.

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">

<fontconfig>
<alias>
<family>serif</family>
<prefer>
<family>Times New Roman</family>
<family>DejaVu Serif</family>
<family>Kochi Mincho</family>
<family>Sazanami Mincho</family>
</prefer>
</alias>
<alias>
<family>sans-serif</family>
<prefer>
<family>DejaVu Sans</family>
<family>Kochi Gothic</family>
<family>Sazanami Gothic</family>
</prefer>
</alias>
<alias>
<family>monospace</family>
<prefer>
<!-- <family>Courier New</family> -->
<family>DejaVu Sans Mono</family>
<family>Kochi Gothic</family>
<family>Sazanami Gothic</family>
</prefer>
</alias>

<match target="font" >
<edit mode="assign" name="embeddedbitmap">
<bool>true</bool>
</edit>
</match>

<match target="font" >
<edit mode="assign" name="rgba">
<const>rgb</const>
</edit>
</match>

<match target="font" >
<edit mode="assign" name="autohint">
<bool>false</bool>
</edit>
</match>

<match target="font" >
<edit mode="assign" name="hinting">
<bool>true</bool>
</edit>
</match>

<match target="font" >
<edit mode="assign" name="hintstyle">
<const>hintfull</const>
</edit>
</match>

<match target="font" >
<edit mode="assign" name="antialias">
<bool>true</bool>
</edit>
</match>

<!-- Disable autohint for bold fonts
<match target="font">
<test name="weight" compare="more">
<const>medium</const>
</test>
<edit name="autohint" mode="assign">
<bool>false</bool>
</edit>
</match> -->

<!-- Font Replacement -->
<match target="pattern" name="family" >
<test name="family" qual="any" >
<string>Verdana</string>
</test>
<edit mode="assign" name="family" >
<string>DejaVu Sans</string>
</edit>
</match>

<!-- Location of local fonts
<dir>~/.fonts</dir> -->

</fontconfig>
It assumes you have msttcorefonts, the DejaVu fonts, ttf-kochi-mincho-naga10, ttf-kochi-gothic-naga10, ttf-sazanami-mincho and ttf-sazanami-gothic installed. I guess you could do without the last four, but you need msttcorefonts and DejaVu. (msttcorefonts and the -naga10 packages are nonfree software.)


$ sudo aptitude install msttcorefonts ttf-dejavu ttf-kochi-mincho-naga10 ttf-kochi-gothic-naga10 ttf-sazanami-mincho ttf-sazanami-gothic

This setup is aimed towards having subpixel (LCD) rendering, with antialiasing and bitmaps on. So if you don't have an LCD screen, might end up funky. It looks gorgeous on my laptop, running Intrepid (well, Felicia). I "replaced" Verdana with DejaVu Sans; Verdana was fuzzy in Firefox at some sizes, and after seeing the results I don't regret the change one bit.

After saving that file (or making any changes to it, for that matter), just open up a new application to see your new results. If you open up a new instance of an already running app it may not take effect; not sure.

mentallysilent
December 19th, 2008, 11:36 PM
What if I don't have that file in my home. Can I just create it?

Actually here is what I want:

- Application font: Bitstream Vera Sans Roman 10
- Document font: same
- Desktop font: same
- Window title font: same
- Fixed-width font: Bitstream Vera Sans Mono Roman 10

Rendering:
- Sub pixel smoothing (I do have an LCD)
- Hinting: Full

I have noticed in 8.04, these last two can't be enabled simultaneously. If I set to SPS, it autotmatically defaults to Slight hinting. I'm not sure if this is even a good setup but it sure looks good on my machine.

At any rate, I'd rather just work with .conf files anyways. Thanks so much for your conf file. Can I modify it to reflect my preferences?