PDA

View Full Version : [ubuntu] Poor Performance



apollyon0810
November 16th, 2008, 08:46 PM
I have a laptop I would very much like to use Linux on for my day-to-day. It is a Toshiba Satellite A215-S7472. Specs:

AMD Turion 64 X2 2.2Ghz
2 GB DDR2 RAM
250GB HDD
Mobility Radeon HD2400 64mb dedicated, up to 255 mb shared.

I really don't have any GLARING issues with my installation. I just suffer from poor performance. Ibex x64 installs without a hitch, and the restricted drivers manager installs fglrx fine. Compiz-Fusion loads without error and gives me all the eye-candy I want. But the OS is slow slow slow... slow response times, especially when switching between tabs in Firefox.

I really want to use Linux, but as far as performance goes, Vista blows Ubuntu out of the water. Please tell me that I'm doing something wrong and that I'm not just stuck.

Therion
November 16th, 2008, 09:00 PM
Humor me and try using Ubuntu 8.04 (Hardy Heron) instead.

apollyon0810
November 16th, 2008, 09:04 PM
Humor me and try using Ubuntu 8.04 (Hardy Heron) instead.

I had the same issue with Hardy Heron. :(

malfist
November 16th, 2008, 09:35 PM
Perhaps install htop and watch what uses the most cpu when switching tabs, and let us know...

apollyon0810
November 16th, 2008, 09:52 PM
Perhaps install htop and watch what uses the most cpu when switching tabs, and let us know...

Firefox was just an example. This happens with all programs and windows. Just an overall laggy system.

malfist
November 16th, 2008, 10:04 PM
Yes, but it could be something with Xorg, or possibly one core is turned off, or everything is throttled. Let us know.

apollyon0810
November 16th, 2008, 10:59 PM
Yes, but it could be something with Xorg, or possibly one core is turned off, or everything is throttled. Let us know.

I installed htop. Not really sure exactly what I'm looking at, but I can say that both cores are working. The cores won't both "max out" at the same time. Either both at 50%, or one or the other at 100% when quickly cycling through the tabs. Normal usage on both when just idling.

CholericKoala
November 16th, 2008, 11:01 PM
I installed htop. Not really sure exactly what I'm looking at, but I can say that both cores are working. The cores won't both "max out" at the same time. Either both at 50%, or one or the other at 100% when quickly cycling through the tabs. Normal usage on both when just idling.

If you can, you can go into your bios and make the core FSB static so that it wont change/throttle.

RMClock is a software solution for windows that can make your FSB static. I dunno what it would be for linux, but thats what you need to do. Good luck. :popcorn:

bobnutfield
November 16th, 2008, 11:25 PM
I cannot tell if there is anything wrong with your install from what you have posted, but my laptop is the same model and spec. I am running Intrepid 8.10 32bit and the system is fast and smooth. I did have some sluggishness with the live 64bit cd, but I just attributed that to running from the cd. In any case, I have always a happier system running 32bit Ubuntus.

apollyon0810
November 16th, 2008, 11:31 PM
I cannot tell if there is anything wrong with your install from what you have posted, but my laptop is the same model and spec. I am running Intrepid 8.10 32bit and the system is fast and smooth. I did have some sluggishness with the live 64bit cd, but I just attributed that to running from the cd. In any case, I have always a happier system running 32bit Ubuntus.

Did you have to do anything special while installing the ATI driver? I AM running the 64 bit version. I have a 32-bit version burned, but it kept freezing when I tried to install it. 64 bit version didn't complain.

bobnutfield
November 17th, 2008, 09:32 AM
Did you have to do anything special while installing the ATI driver? I AM running the 64 bit version. I have a 32-bit version burned, but it kept freezing when I tried to install it. 64 bit version didn't complain.

No, I simply enabled it from the System>Administration>Hardware Drivers. I started with this installation while Intrepid was in Alpha 5 and followed the updates through to its release. I have never had good luck with a 64bit distro on my laptop, though I have successfully run 64bit Fedora on my AMD64 desktop. Even if I were to install it with no issues, there is only very minimal performance improvements. The only reason I can think of when you MUST use 64bit is when you have 4GB or grreater of memeory as the 32bit will only utilize 3GB.

EV500B
November 17th, 2008, 11:42 AM
Could it be an bios misconfiguration, like the laptops' "Low mode" which decrease its energy consomation and performance. Or something like that?