PDA

View Full Version : [ubuntu] 8.10 Nvidia Issues



Amalgamayne
November 16th, 2008, 08:20 AM
Hello:

I just recently upgraded from 8.04 to 8.10, and I am having some issues with it. I can only log into safe graphics mode (800 X 600), even though I was able to have my nice 1440 X 900 res on 8.04.

Here are some more aspects of the problem:

***the 177 driver says it is activated but not in use (system->admin->hardware drivers). Have rebooted many times to try to get this to work, but no workie.

***i have also configured xorg.conf to what it was in 8.04, but that hasn't worked, either

***i am using GeForce 6150SE nForce 430 (rev a2) as my card.

***i can only VNC into this desktop, as I am halfway across the country of where the desktop is. If I have to restart X (ctrl+alt+backspace, I believe), I would prefer not to unless I have someone at home sit there and follow any commands.

Thanks for your help!

jimmy the saint
November 16th, 2008, 09:21 AM
Use the lower nvidia driver (I forget the number but you should have two choices) A lot of people have had issues with the 177 driver forcing them into low graphics mode.

Amalgamayne
November 16th, 2008, 09:36 PM
So I am able to get the 173 driver activated, but Ubuntu says it is not currently in use. How do I get this to happen?

Thanks for your help!

jimmy the saint
November 16th, 2008, 09:43 PM
Have you activated the appropriate repositories in Synaptic?
Open Synaptic (System>Administraion>Synaptic) click on Settings>repositories and make sure that the proprietary drivers box is checked. Also, if you go to "Download From" select "other" and Select best server, You will automatically end up using the faster server, which solved that for me when I installed hardy and the main servers were to busy to give me the driver!

Good Luck

oldsoundguy
November 16th, 2008, 09:53 PM
This is a major issue with 8.10 that too many of those that could help seem to ignore. (that includes NVida itself)

I had to use the 96 driver in order to get resolution for my cinema wide screen, but that is it .. no rotation, no eye candy programs, just basic vanilla. The 173 driver worked fine for standard LCD, but again, just to run the display!
To activate go to System> administration> hardware drivers to activate the driver you installed.

Only hope right now is that Envy will get the drivers written SOON. (since NVida no longer writes the drivers for anything no longer sold off the shelf that is 6 months old or older.)

Check the blog at Envy for more details

Amalgamayne
November 17th, 2008, 12:20 AM
Thanks for all the help, but still of no avail. The driver is still not being used, though activated. I even tried Envy to be able to get the driver to still work, but of still no avail. Any other suggestions? Will I have to buy a better card?

oldsoundguy
November 17th, 2008, 12:39 AM
The driver situation WILL get fixed .. as I noted, read the blog on the Envy site.

Scunizi
November 17th, 2008, 01:39 AM
Activation of the restricted driver requires restart of GDM at minimum.. typically it likes a system restart. I have a 8200 card on the AMD motherboard that I just picked up. I activated the 177 driver but screen writes are horribly slow. The system (Ibex) just feels much slower than Hardy but I attribute that to the video.

Skripka
November 17th, 2008, 02:01 AM
This is a major issue with 8.10 that too many of those that could help seem to ignore. (that includes NVida itself)


I think that is because it is a combination of Gnome/Compiz/Ibex/Nvidia is the problem--not wholly Nvidia's.. Kubuntu users don't seem to be having issues with the 177.xx drivers, at least not the major issues Gnome users are reporting, I state this based on completely unscientific data based on observations of reported Nvidia problems here, mind you. Bear in mind that KDE does not use a seperate Compiz--it is all integrated into the window manager.


Just sayin'

ElroyJetson
December 6th, 2008, 04:37 PM
my 2 cents...

After upgrading to 8.10, my "Monitor Resolution Settings" panel under "Rotation" only had "Normal" and "Upside Down", not "Left" and "Right" anymore. My monitor rotates 90-degrees, and I use this from time to time. That panel also calls my screen "Unknown" in the configuration.

After hunting around on the forums here, I discovered that the "nvidia-settings" command bringing up the nvidia control panel does have "Rotation Settings" and it works to rotate the view. For now, I will have to use this to rotate instead of the gnome resolution panel.

Hope this helps others in the same situation!

Running Ubuntu 8.10, nvidia driver version 177.80, on GeForce 7300 GS with Gateway FPD2485W (24" widescreen with rotation). (single monitor)

phidia
December 6th, 2008, 04:55 PM
This is a major issue with 8.10 that too many of those that could help seem to ignore. (that includes NVida itself)

I had to use the 96 driver in order to get resolution for my cinema wide screen, but that is it .. no rotation, no eye candy programs, just basic vanilla. The 173 driver worked fine for standard LCD, but again, just to run the display!
To activate go to System> administration> hardware drivers to activate the driver you installed.

Only hope right now is that Envy will get the drivers written SOON. (since NVida no longer writes the drivers for anything no longer sold off the shelf that is 6 months old or older.)

Check the blog at Envy for more details

I agree and from some research I've done 6 series cards (the OP's card is a 6) are no longer supported-this is an nvidia problem since the current drivers don't support that card series anymore.

**Sort of off topic: It's funny how things change. ATI may end up being more supportive of linux while nvidia seems to be letting things slide.

oldsoundguy
December 6th, 2008, 05:25 PM
That requires that I use the NVidia X driver .. if I install that I lose my display and cant even run terminal. (could be because I have to run a 5500 legacy card as no AGP or PCIe on the board.)

WORK still needs to be done.

Wiebelhaus
December 6th, 2008, 06:03 PM
It's not Nvidia , it's the lack of displayconfig-gtk , if that was available the fix would take 5 minutes.

Dragonflyoh
January 18th, 2009, 09:35 AM
Did you ever get the problem resolved? I have a GeForce 7100 and have tried every suggestion I could find including removing every Nvidia file with the package manager, using EnvyNG for installation, I tried all three of the drivers listed in EnvyNG and I still get the driver is activated but not currently in use message. When I boot up I get a message that says (EE) Nvidia(0) Failed to load kernel module. Any thoughts would be appreciated.

Leo Dragonheart
January 18th, 2009, 10:00 AM
This is what worked for me... I used the recommended driver and activated it then followed these instructions...


First you need to open your xorg.conf file in Gedit, like this:

Go to Main Menu>Accessories>Terminal...then cut and paste, or type in the (Bold Type)code below...

Code:

sudo gedit /etc/X11/xorg.conf

You'll have to enter your password to gain editing privileges.

Some say you should back up the file first, but I found gedit does this automaticaliy, and right now your original file isn't doing you much good anyway.

Next, you have to add a few lines to specific sections of your xorg.conf file. BUT DO NOT CHANGE ANYTHING ELSE!

In the Monitor section add the lines that appear in bold:
Code:

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 31.0 - 65.0
VertRefresh 51.0 - 90.0
EndSection

Note that these are the specs that fit my particular monitor. They'll probably work for yours also - but if you want to you can replace the VertRefresh and HorizSync values with your monitor's actual data if you know what they are.

Next, in the Screen section add the lines that appear in bold, right before the EndSection line.

Code:

SubSection "Display"
Depth 24
Modes "1280x1024_60"
EndSubSection

This set my monitor to my desired resolution which is 1280X1024. You can substitute the resolution data to suit your needs. Reboot your computer and you should have a high resolution display. Next, you should run the NVIDIA settings program to fine tune your system.

If this doesn't work, then you can boot in recovery mode and select the fix x-server option. This will give you a high resolution display but no special effects, etc.

I hope this helps.

Dragonflyoh
January 18th, 2009, 12:21 PM
Thank you for the help. I ended up removing all drivers, going to the recovery mode and fixing the x server and then making the changes you gave me with my monitor specs to the xorg.conf file. I attempted the changes with the driver installed and could not get high resolution display. Is it the card that has the problem or is it just 8.10? I would go back to 8.04 except this is a backend for MythTV and I don't wish to start that over. Thanks again for the help.
Forgot one item. In the xorg.cong file I entered my monitor resolution of 1440 x 900 and when I go to System/Preferences/Screen Resolution all it shows is 1024 x 768.