PDA

View Full Version : [ubuntu] Permissions



Europa7
November 12th, 2008, 03:40 PM
Hi everyone.
I just installed the latest version of Ubuntu a few days ago. I am trying to install skins for the music player audacious and getting an error message that I don't have the permissions to do so. I went into the audacious folder settings and it says Root is the owner and I am not the owner. I opened terminal and logged in as root by typing sudu su, left terminal open, and reattempted the process without success.

How do I sign on as root so I have the permission to add the new skin?

Thanks!

tuxxy
November 12th, 2008, 03:42 PM
You could right click the folder > properties > permissions and add you as group having read/write access should work

Europa7
November 12th, 2008, 03:57 PM
When I go into folder > properties > permissions, it doesn't allow me to make any changes. It says Owner: root and Group: root and the drop down boxes are greyed out and not accessible. It says "you are not the owner, so you cannot change permissions".

tuxxy
November 12th, 2008, 04:03 PM
ok open a terminal window and type this command


sudo nautilus /home/user/

Remember to edit the /home/user/ dir with the location of your folder, now you should be able to edit permission on any folders

Europa7
November 12th, 2008, 04:11 PM
Thanks a lot! Problem solved.

tuxxy
November 12th, 2008, 04:12 PM
hehe np glad it worked for you, you can mark the thread solved now too :)

mister_pink
November 12th, 2008, 04:58 PM
For future reference, the solution to not having permission to something is generally not to give yourself permission - there is, after all, a reason your usual user doesn't have access to the system files.

The correct thing to do would be to run "gksudo nautilus --no-desktop" and use that to copy the files as root. Be careful with that though, you can mess things up. Its safest to use terminal (sudo mv -i source destination) as this is nice and explicit (you can't accidentally do anything).