PDA

View Full Version : [ubuntu] help please with resolution ibex



eddietours
November 8th, 2008, 07:11 PM
l can't get a higher resolution then 800x600 is driving me crazy
is a integrated video card via chip set

hictio
November 8th, 2008, 07:44 PM
Have you tried going to "System -> Preferences -> Screen Resolution", just to see if you have other resolutions listed there/



is a integrated video card via chip set


Which video card do you have? Get the model like this, open a Terminal (Applications -> Accesories -> Terminal), and type:


lshw -c display


You'll see something like this:


esteban@tango:~$ lshw -c display
WARNING: you should run this program as super-user.
*-display
description: VGA compatible controller
product: GeForce 7000M (rev a2)
vendor: nVidia Corporation
physical id: 12
bus info: pci@0000:00:12.0
version: a2
width: 64 bits
clock: 66MHz
capabilities: bus_master cap_list
configuration: driver=nvidia latency=0 module=nvidia
esteban@tango:~$


I have an NVIDIA GeForce 7000M on my laptop.

eddietours
November 8th, 2008, 08:38 PM
this what l get also the screen resolution is only two option 800x600 and 600x480:confused:

eddie@eddie-desktop:~$ lshw -c display
WARNING: you should run this program as super-user.
*-display UNCLAIMED
description: VGA compatible controller
product: CN700/P4M800 Pro/P4M800 CE/VN800 [S3 UniChrome Pro]
vendor: VIA Technologies, Inc.
physical id: 0
bus info: pci@0000:01:00.0
version: 01
width: 32 bits
clock: 66MHz
capabilities: bus_master cap_list
configuration: latency=32 mingnt=2

DrDagostino1
November 8th, 2008, 08:43 PM
Go to Terminal and enter the command:

sudo gedit /etc/X11/xorg.conf

Then post the file contents please.

eddietours
November 8th, 2008, 08:48 PM
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

hictio
November 8th, 2008, 09:00 PM
What is your Ubuntu box? Is it a laptop or a desktop? If its a desktop, what monitor do you have?

DrDagostino1
November 8th, 2008, 09:06 PM
Try adding:


SubSection "Display"
Modes "1024x768"
EndSubSection

Exactly so that the last section looks like:


Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Except where it says "1024x768" put whatever resolutions you want with a space separating each resolution.
After doing this you will need to restart and then you should be able to change the screen resolution to whatever you put for the ones above.

eddietours
November 8th, 2008, 09:06 PM
is a desktop p4 and the monitor is my tv 32 inch samsung
l had upgrade to ibex from hardy and thats when everything went low resolution so decide to do a clean install but still the same problem :confused:

Martin Fierro
November 8th, 2008, 09:15 PM
Hi Eddietours,
if you have upgraded to ubuntu 8.10 be aware that many users are facing problems with nvidia drivers.
I was using also an integrated chipset Unichrome into my P4M900 motherboard with problems in refresh rate. I changed the video card to an GeForce7200GS in an attempt to fix my problem but instead I dropped into a new one (the nvidia bug). I hope the issue will be fixed soon (couple of day, I hope). Please be patient, or alternatively return to hardy in the mean time if you need your machine to work.
My best regards.

hictio
November 8th, 2008, 09:16 PM
is a desktop p4 and the monitor is my tv 32 inch samsung


Ok, do you have the tech specs for that monitor?
What is the exact model?
Specifically, Horizontal & Vertical refresh rates.

So, if not another option, like DrDagostino1 says, you can add that info to the xorg.conf file (as well as the one on resolution, of course)

eddietours
November 8th, 2008, 09:42 PM
is resolution 1280x1024 HF 63.981 VF 60.020
l also add the 1024x768 suggested by DrDagostino1 but still nothing

hictio
November 8th, 2008, 10:03 PM
After editing the xorg.conf file, are your restarting X Window/ Gnome?
If you didn't save and close anything that you might open, logout, and type: Ctrl + Alt + Backspace to do so.

This is a copy of my xorg.conf file, from my desktop:


#xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "PS2 / USB Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "NV11 [GeForce2 MX/MX 400]"
Driver "nvidia"
Option "NoLogo" "False"
EndSection

Section "Monitor"
Identifier "Samsung SyncMaster 920NW"
VendorName "Samsung"
Modelname "920NW"
Horizsync 30-81
Vertrefresh 56-75
EndSection


Section "Screen"
Identifier "Default Screen"
Monitor "Samsung SyncMaster 920NW"
Device "NV11 [GeForce2 MX/MX 400]"
Defaultdepth 24
Option "AddARGBGLXVisuals" "True"

SubSection "Display"
Depth 24
Modes "1440x900" "1280x1024" "1280x960" "1024x768" "800x600"
Viewport 0 0
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection

Section "Module"
Load "glx"
EndSection

# EoF #

eddietours
November 8th, 2008, 10:21 PM
l just try that but still 800x600 should l just wait for the fix this so frustrating :(

eddietours
November 8th, 2008, 10:39 PM
guys l switch the integrated card for a nvidia 6800 well at least l get 1024x768 is way better then 800x600 hopefully a update will come soon
thanks for all the help thank you very much :D

hictio
November 8th, 2008, 10:49 PM
What I find a bit of a distress, not to say a PITA, is that a 32 inches monitor can only give you 1024x768???? What gives, did you had a better resolution before?

I mean, 32" is a lot of screen real state, but at a higher resolution it will be amazing, IIRC, the Apple 30" monitors can deliver something around 1600???

eddietours
November 8th, 2008, 11:03 PM
yes before it would give a higher resolution but after only 1024x768 l also have a mac mini witch gives a 1440x900 on the same monitor could be a bug in ibex?

eddietours
November 8th, 2008, 11:11 PM
also on the nvidia -settings resolution right on top of 1024x768 theres only 1152x864 and 1360x768 but no 1280x1224

eddietours
November 8th, 2008, 11:17 PM
opps mean 1024

hictio
November 8th, 2008, 11:58 PM
also on the nvidia -settings resolution right on top of 1024x768 theres only 1152x864 and 1360x768 but no 1280x1224

Sorry, I did not understand that. Do you have a "System -> Administration -> NVIDIA X Server Settings" entry on you menu?

eddietours
November 9th, 2008, 12:05 AM
yes but theres no 1280x1024 option weird right

hictio
November 9th, 2008, 12:26 AM
And you have the NVIDIA drivers installed? Or in use? Check "System -> Administration -> Hardware Drivers".

eddietours
November 9th, 2008, 12:32 AM
here the xorg file


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024"
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

eddietours
November 9th, 2008, 12:55 AM
the drivers are install

hictio
November 9th, 2008, 01:40 AM
You don't happen to have an old xorg.conf from before, right? I mean, when the 1280x resolution used to work on Hardy.

The values that you posted for your monitor in here (http://ubuntuforums.org/showpost.php?p=6132786&postcount=11), are those form the manual, or the webiste of your monitor manufacter, right?

eddietours
November 9th, 2008, 01:48 AM
no my bad i did not backup the old xorg file
yes the spec are from the manual l still have it

hictio
November 9th, 2008, 02:23 AM
One thing, regarding the refresh rates, they should be range, and not just one value for the Vertical, and another for Horizontal.
Are sure those are the only values?

Ok, lets make a backup of the actual xorg.conf file, open a Terminal, and type:



sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back-08112008-00


And then, open the file like DrDagostino1 said, and replace the contents with this:



## Sat 08 Nov 2008 11:12:04 PM ARST
Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Horizsync 63.98
Vertrefresh 60
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024"
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

# EoF #


Logout, and type Ctrl + Alt + Backspace to force a re-init.

eddietours
November 9th, 2008, 02:46 AM
Dude you the man holy cow is back to 1280x1024 Thanks how can l repay you master yoda :guitar:

hictio
November 9th, 2008, 03:05 AM
Ja ja ja, that's ok, I'm glad it worked.

Please, make sure about what I mentioned of the Vertical & Horizontal refresh ranges!
Look for them on the manual, or Google them with the exact model of your monitor.

eddietours
November 9th, 2008, 03:19 AM
ok will do thanks again:D