PDA

View Full Version : USN-664-1: Tk vulnerability



rss-bot
November 6th, 2008, 08:30 PM
Referenced CVEs:
CVE-2008-0553


Description:
================================================== ========= Ubuntu Security Notice USN-664-1 November 06, 2008 tk8.0, tk8.3, tk8.4 vulnerability CVE-2008-0553 ================================================== ========= A security issue affects the following Ubuntu releases: Ubuntu 6.06 LTS Ubuntu 7.10 Ubuntu 8.04 LTS This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu. The problem can be corrected by upgrading your system to the following package versions: Ubuntu 6.06 LTS: tk8.0 8.0.5-11ubuntu0.1 tk8.3 8.3.5-4ubuntu1.2 tk8.4 8.4.12-0ubuntu1.2 Ubuntu 7.10: tk8.3 8.3.5-6ubuntu3.1 tk8.4 8.4.15-1ubuntu1.1 Ubuntu 8.04 LTS: tk8.4 8.4.16-2ubuntu1.1 In general, a standard system upgrade is sufficient to effect the necessary changes. Details follow: It was discovered that Tk could be made to overrun a buffer when loading certain images. If a user were tricked into opening a specially crafted GIF image, remote attackers could cause a denial of service or execute arbitrary code with user privileges.





More... (http://www.ubuntu.com/usn/USN-664-1)