View Full Version : [ubuntu] 8.10 & ATI fglrx blank screen problem

November 3rd, 2008, 09:23 PM
After very smooth clean install from the Ubuntu 8,10 32bit desktop CD on an fresh partition I tried to activate ATI proprietary fgrlx driver (System/Admin) and after required rebooting there was only black screen!

On other partition Ubuntu 8.04 with ATI fglrx & Compiz works without any problems.

I looked around, there was a lot of black screens with 8.10 and ATI fglrx (mostly unsolved), but none of proposed solution worked for me.

Please help.

HW: AMD 2200+; MB: Chaintech Zenith CT-7NJS, with CMedia 8738 sound on board; GC : ATI Radeon HD2400 AGP; RAM : 2GB; Monitor: Samsung 244T (1920x1200)

November 3rd, 2008, 09:55 PM
Boot into recovery mode from GRUB menu (if you don't see the menu, press ESC to bring it up) and reconfigure your X server again.

dpkg-reconfigure -phigh xserver-xorg
shutdown -r now

November 3rd, 2008, 10:21 PM
Hi Taurus,

sorry for not be quite clear in my explanation. My problem is, how to make 3D/2D/video HW acceleration and Compiz to work in Ubuntu 8.10 with ATI Radeon HD2400.

It seems that new X server and latest ATI driver in 8.10 are not best friends in my system, but I can't figure out, why.

Suggestions are very welcomed.

November 3rd, 2008, 10:55 PM
I have a somewhat similar problem with fglrx after upgrading to Intrepid. I don't have the black screen but I can't get the effects to work. After searching all day today, it seems the problem is related to compatibility of the fglrx driver to the new version of Xorg (7.4). The driver that is in the repos right now is still a beta according to other sites and is quite buggy.

November 5th, 2008, 06:56 PM
Yah, seems that the fglrx driver isnt working at all.

04:00.0 VGA compatible controller: ATI Technologies Inc RV610 [Radeon HD 2400 XT]

i can get it workign in low-graphics mode only, and even so i get a popup at the start witha list of errors.

-given depth(8)not supported by fglrx
-preinit visual failed
-preinit failed
-screens found but non have a useable resolution.