PDA

View Full Version : [ubuntu] How To Set Up NVIDIA After Upgrade 8.04 -> 8.10



Sarek
November 2nd, 2008, 04:01 PM
Hello,

I have been looking around in forums but could not find any helpful post. I hope you can help me.

I run a Dell 1520 with Nvidia graphics.


-ubuntu:~$ sudo ddcprobe
vbe: VESA 3.0 detected.
oem: NVIDIA
vendor: NVIDIA Corporation
product: G84 Board - p410h1b Chip Rev
memory: 14336kb
mode: 640x400x256
mode: 640x480x256
mode: 800x600x16
mode: 800x600x256
mode: 1024x768x16
mode: 1024x768x256
mode: 1280x1024x16
mode: 1280x1024x256
mode: 320x200x64k
mode: 320x200x16m
mode: 640x480x64k
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
edid:
edidfail

In general it seems to work out fine; I have got graphics and the resolutions seems to be the highest. But, as it looks to me, there is some generic driver in use. I wish, however, to use the nvidia driver which seems to be around.

I called System -> Administration -> Synaptics Pkg Mgr to make sure that all nvidia177 modules were installed. They were.

Then I called System -> Administration -> Hardware Drivers. Nvidia 177 was not active and I could not activate it.

System -> Administration -> Nvidia X Server Settings told me: "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

Here is my xorg.conf.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


Any ideas?

Many thanks!

skankster
November 2nd, 2008, 08:37 PM
Check that the generic headers are installed for your kernel (assuming you're using generic). That was my problem, with similar symptoms.

aikiwolfie
November 2nd, 2008, 08:54 PM
Any ideas on how to do that. I'm having this problem to. It happens on both the 64-bit and 32-bit version of 8.10. The only way I can fix it is by rolling back to 8.04.1.

I might point out that my desktop current has no GUI because of this problem. I thought Bulletproof X was meant to stop that from happening?

SteveDee
November 2nd, 2008, 08:57 PM
I had similar Nvidia problems because I failed to answer one of the upgrade "install questions" correctly. The result was that Grub still loaded the old 2.6.24-19 kernel. If this is also your problem, just edit /boot/grub/menu.lst and add 2.6.27-7-generic.

Campingman
November 2nd, 2008, 09:22 PM
Hi,
I could do with some assistance on this one too, I have checked the kernel and I too had the incorrect one loading. Edited grub so i am now loading the correct one but still cannot get nvidia drivers to function (worked perfectly on all previous versions?). Any suggestions?

SteveDee
November 2nd, 2008, 09:48 PM
Hi,
I could do with some assistance on this one too, I have checked the kernel and I too had the incorrect one loading. Edited grub so i am now loading the correct one but still cannot get nvidia drivers to function (worked perfectly on all previous versions?). Any suggestions?

Suggestions:-
1. make sure your card is supported. For 177 take a look at this list: http://us.download.nvidia.com/XFree86/Linux-x86/177.80/README/appendix-a.html
2. Check your xorg log file for clues: /var/log/Xorg.n.log
3. If still no joy you may have to wade thru the readme at: http://us.download.nvidia.com/XFree86/Linux-x86/177.80/README/index.html

skankster
November 2nd, 2008, 10:08 PM
Any ideas on how to do that. I'm having this problem to. It happens on both the 64-bit and 32-bit version of 8.10. The only way I can fix it is by rolling back to 8.04.1.

I might point out that my desktop current has no GUI because of this problem. I thought Bulletproof X was meant to stop that from happening?

Open Synaptic and search on "headers". Make sure that the generic headers package for your kernel is checked green. For example, I'm using 2.6.27-7 and my linux-headers-2.6.27-7 package was installed but not linux-headers-2.6.27-7-generic. After I installed linux-headers-2.6.27-7-generic, I was able to enable nvidia 177 using "Hardware Drivers".

From what I've seen this may not be the only reason for this problem, but it's a quick one to check.

Sarek
November 3rd, 2008, 07:05 AM
Open Synaptic and search on "headers". Make sure that the generic headers package for your kernel is checked green. For example, I'm using 2.6.27-7 and my linux-headers-2.6.27-7 package was installed but not linux-headers-2.6.27-7-generic. After I installed linux-headers-2.6.27-7-generic, I was able to enable nvidia 177 using "Hardware Drivers".

From what I've seen this may not be the only reason for this problem, but it's a quick one to check.

Installing the headers did the trick. Many thanks!