View Full Version : [ubuntu] 8.10 upgrade: Not in Grub menu

October 31st, 2008, 12:59 AM

There seem to have been a lot of posts today, but I haven't been able to find anything on this problem.

I tried to upgrade my Dell M1330 laptop from 8.04.1 to 8.10 using the upgrade manager. On restarting, as prompted, I found my Grub menu hadn't changed (its latest kernel is only version 2.6.24-21, labelled as Ubuntu 8.04.1).

I can only boot in recovery mode. In looking in the /boot/ directory, there are files corresponding to 2.6.24-21 and 2.6.22-14, but nothing for -27.

Did the upgrade work? What should I do now? I hope I have given enough information; I started with version 7.x but I'm not too experienced with this. Any help is much appreciated.

November 1st, 2008, 04:55 AM
What is in /etc/lsb-release? If the upgrade completed, you will have different desktop wallpaper, changes on the menus, and /etc/lsb-release will look like


It doesn't sound like your upgrade worked completely. You might try

sudo apt-get update; sudo apt-get upgrade --fix-broken
and see if that makes any difference.

Also, some people are having better luck with fresh installs than with upgrades. I upgraded two systems and didn't have any major problems myself.

November 1st, 2008, 08:33 PM
Thanks for your reply; it was very helpful and I at least got my system back. I did have 8.10 in my /etc/lsb-release file. I ran

apt-get update
apt-get upgrade --fix-broken
apt-get dist-upgrade

and I can boot Ubuntu all the way now. However, I'm still on the old kernel and video and networking aren't working properly. So I think I'll just try a fresh install and go from there.

For anyone reading, this thread includes discussion of the same problem: