PDA

View Full Version : SLi using 177 driver in Intrepid



bean72
October 22nd, 2008, 07:02 PM
Hi there,

I recently installed Intrepid from scratch a couple days ago, and so far I am very happy with it. An issue I seem to be having trouble with is getting the SLi configured.
I notice under nvidia-settings that it is showing that SLi is working properly as both GPU's are assigned to X screen 0. But when I enable the SLi HUD load graph it is not showing any load on either GPU. I also notice that there is a clear difference in framerate between hardy and intrepid.

Is nvidia-settings showing that SLi is enabled, but is not actually working?

Here is my xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Wed Oct 1 15:12:53 PDT 2008

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Device"
Identifier "Device0"
VendorName "NVIDIA Corporation"
BusID "PCI:07:00:00"
Driver "nvidia"
Option "NoLogo" "True"
Option "SLI" "AFR"
EndSection

At the same time I would like to know if there are any errors, or anything that needs to be added. I heard that X server is leaning towards a zero-config setup, so I tried to edit only what was necessary.

Appreciate the help,
Jeff

autocrosser
October 22nd, 2008, 08:34 PM
I run SLI--I'm at work right now, but you could look back thru my posts --I've posted my settings a couple of times within the last month or so. You need to set which busid your main card is & a few other settings. The new xorg.conf is not needing very much anymore, but the info required is very specific........

AFR is not the way to go--you need to run split-screen mode.

EDIT: the post you need to look at: http://ubuntuforums.org/showthread.php?t=946984

bean72
October 23rd, 2008, 12:22 AM
Perfect, I set it to split-screen rendering and things seems to be running alot smoother now.
The SLi heads up display still doesnt show any load on the GPU's, but I'm sure if it wasn't working properly my screen would only show half a picture.

Thanks for your help.

autocrosser
October 23rd, 2008, 03:56 AM
Split-screen is the fastest render I've found :) And I've not seen the heads-up to be very helpful....

You also need to read:
http://www.nvnews.net/vbulletin/showthread.php?t=120679

http://www.nvnews.net/vbulletin/showthread.php?t=118088

That will REALLY help the speed of your SLI setup!!!!!!

bean72
October 24th, 2008, 02:00 AM
Looks like when I use:

# nvidia-settings -a InitialPixmapPlacement=2
it ends up making the top bar on my focused window white (could also be caused by the theme I'm using). I'll give these other settings a try and see if I notice better video performance.

Thanks,
Jeff