PDA

View Full Version : [ubuntu] No sound on my Lenovo laptop



R2D2!
October 6th, 2008, 03:48 AM
I don't know ıf somebody else has had thıs problem, but I can't hear anythıng from my Lenovo 3000 N200 laptop. I have dısabled mute, and trıed to ınstall alsa-driver-1.0.17, but wıth an error ın sudo make:

CC [M] /home/ilhuitemoc/Aplicaciones/alsa-driver-1.0.17/soc/soc-dapm.o
In file included from /home/ilhuitemoc/Aplicaciones/alsa-driver-1.0.17/soc/soc-dapm.c:2:
/home/ilhuitemoc/Aplicaciones/alsa-driver-1.0.17/soc/../alsa-kernel/soc/soc-dapm.c: En la función ‘dapm_pop_time_store’:
/home/ilhuitemoc/Aplicaciones/alsa-driver-1.0.17/soc/../alsa-kernel/soc/soc-dapm.c:834: error: declaración implícita de la función ‘strict_strtoul’
make[3]: *** [/home/ilhuitemoc/Aplicaciones/alsa-driver-1.0.17/soc/soc-dapm.o] Error 1
make[2]: *** [/home/ilhuitemoc/Aplicaciones/alsa-driver-1.0.17/soc] Error 2
make[1]: *** [_module_/home/ilhuitemoc/Aplicaciones/alsa-driver-1.0.17] Error 2
make[1]: se sale del directorio `/usr/src/linux-headers-2.6.24-19-generic'
make: *** [compile] Error 2
ilhuitemoc@ilhuitemoc-laptop:~/Aplicaciones/alsa-driver-1.0.17$


I have kernel 2.6.24-19, and my Ubuntu ıs ınstalled IN Wındows Vısta, wıthout a dedıcated partıtıon.

Any ıdeas?

—Ilhuıtemoc δ

Temüjin
October 6th, 2008, 06:57 AM
There is a script to do it for you.
http://ubuntuforums.org/showthread.php?t=820959

martinlall
October 6th, 2008, 10:51 AM
Hi there!

I had same problem. It solves the problem, if you haven't broken anything by installing and uninstalling everything yet:

http://ubuntuforums.org/showthread.php?p=5290526

Cheers!

Or, install 8.10 beta,

Works great!

R2D2!
October 6th, 2008, 01:27 PM
There is a script to do it for you.
http://ubuntuforums.org/showthread.php?t=820959

Thanks, now I have sound!

—Ilhuıtemoc δ