PDA

View Full Version : [all variants] nvidia twin view + blender



micba
October 3rd, 2008, 03:02 PM
Greetings,

I have a problem similar to the one described here (http://ubuntuforums.org/showthread.php?t=416249). The thread as well as the twin view How To (here (http://ubuntuforums.org/showthread.php?p=1773584)) gave me an idea of what to edit, but unfortunately I couldn't solve the problem yet.
That's the xorg.conf I'm using atm and which is working fine, besides blender does not start properly.



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Thu Feb 14 18:21:33 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de,el"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Iiyama PLE2200WSV"
HorizSync 30.0 - 84.0
VertRefresh 55.0 - 77.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce Go 7400"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT: nvidia-auto-select +1280+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 16
EndSubSection
EndSection

Thx for the help in advance.

Hobo Joe
October 6th, 2008, 12:39 AM
I've found the best solution is to set EVERYTHING to windowed mode, and then for when it's needed use the 'set fullscreen' hotkey for the window manager.

In the specific case of Blender, which has windowed mode problems, you need to force the window to a certain resolution. For example, mine reads:



home/<username>/.blender/blender -p 5 225 1024 768


This means it's offset from the right edge of the screen by 5 pixels, 225 pixels from the top edge, and the window itself is 1024x768 pixels. Of course, you can set this to whatever you want, the numbers really aren't important. Once Blender has been started up with this method, you can resize the window all you want it it works just fine.

So simply set your Blender launcher (right-click > Properties), and paste the above command, being sure to replace the '<username>' with your username.



Good luck!