PDA

View Full Version : [ubuntu] Requesting help setting up Big Desktop on Ubuntu 8.04 for Radeon x1300



Braeden2
October 3rd, 2008, 01:39 AM
I am pretty new to linux and am having some trouble getting my graphics drivers / xorg.conf file sorted out.

I have a Radeon x1300 Pro 256Mb, with a veiwsonic VA1912W (desired resolution 1440x900) and an Acer AL1717 (desired resolution 1280x1024).

Veiwsonic on the left of the Acer, idealy Veiwsonic would be the primary monitor.

So far I have spent upwards of 9 hours trying to get this to work / reading man pages / forums for solutions.

I have enabled the proprietary ati driver and it is currently enabled.

After much tinkering to my xorg.conf file I came across a post recommending


sudo aticonfig --initial=dual-head


be run. I did this and a restart later I had dual monitors working (Not Big Desktop). I was stoked (this was about 2:30 last night). So I decided to try and add a few options, screen modes (resolutions) to my xorg.conf file.

Being the fool that I am, I busted it....

I blew away my working xorg.conf without having made a backup.

Currently all I am getting is mirrored 800x600 on both monitors using the following:



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
Screen "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[1]"
Driver "fglrx"
Screen 1
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection



Oh, and another thing. Since I lost my working file I have tried numerous different xorg.conf settings, so any backup that ubuntu makes for me... also gone. :(


One thing I would note is that when I got dual monitors working I would swear 'fglrxinfo' returned something about 'fglrx' rather than what it is now:


braeden@braeden-desktop:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.3-rc2)


Any help anyone could give would be greatly appreciated.

Thanks


Braeden

Azazel
October 3rd, 2008, 03:15 AM
your fglrxinfo output means that you are not using the ati drivers anymore. you may only need to uninstall the mesa driver, but a re-install of ati drivers may be needed.

this link (http://wiki.cchtml.com/index.php/Ubuntu_Hardy_Installation_Guide#Method_2:_Manual_M ethod_.28installing_Catalyst_8.8_or_8.9.29) may help (in particular the section on removing mesa)

also in the terminal type aticonfig to get a list of all the options, use them with the sudo command. I know there is one in there somewhere about a big desktop if thats what you want. Also pay particular attention to the examples at the bottom, one of them shows you how to do the resolution.

I hope this helps!

Braeden2
October 3rd, 2008, 04:54 AM
Thanks For your reply Azazel.

Whilst that link was not helpful in itself in removing my Mesa drivers your observations were correct. A quick Google for removing Mesa drivers led me to a post that worked for me.

Here is the post:

http://ubuntuforums.org/showthread.php?t=853377&page=5


After a reboot this set the screens to mirrored at 1280x1024. I could set the resolution to 1440x900 using Syster/prefs/screen resolution.

I then ran:


aticonfig --dtop=horizontal --overlay-on=1

To enable Big Desktop.

This was not quite the end however. I also added the following to my xorg.config file:



Section "ServerFlags"
Option "Xinerama" "true"
EndSection


The result of this is both screens are active as part of a Big Desktop, however, at the moment whatever resolution I set is used for both. i will continue to try and edit xorg.conf to manualy determine each of their resolutions. in addition to that, dialogs which pop-up are half on each screen, I have been told that this is because I ¨forgot to compile it with xinerama support".

Any help you can give on either point would be greatly appreciated.

Cheers


PS: Here is my xorg.conf as it stands.



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "alt-intl"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
Option "DesktopSetup" "horizontal"
Option "OverlayOnCRTC2" "1"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Braeden2
October 3rd, 2008, 07:33 AM
I have solved my issue completely.

As stated above, what I did resulted in a Big Desktop and being able to set one resolution for both monitors.

After trying a few things I found that running the line to setup dual monitors did the trick.


aticonfig --initial=dual-head --screen-layout=right

This resulted in the veiwsonic being the primary monitor at 1440X900, the acer being an extension of the desktop at 1280X1024 and dialog boxes etc appearing centred in the middle of the primary monitor.

Initialy my understanding was that running in 'dual head' mode resulted in not being able to drag windows between monitors etc. However I now find that first setting up big desktop mode using


aticonfig --dtop=horizontal --overlay-on=1

and the addition to xorg.conf I listed in my previous post,

THEN

running the dual desktop command I get a fully working Big desktop.

Details on the various commands can be found by typing aticonfig as Azazel said.

One thing I will add is that I believe the line:


Option "Mode2" "1280x1024"

In the First Device section below to be a remnant of a previous attempt to set the resolution on the 17' Acer.

Current xorg.conf:



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
Screen "aticonfig-Screen[1]" RightOf "Default Screen"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "alt-intl"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
Option "DesktopSetup" "horizontal"
Option "OverlayOnCRTC2" "1"
Option "Mode2" "1280x1024"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[1]"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection



Good luck everyone and thanks again Azazel.

markbuntu
October 4th, 2008, 12:19 AM
You should really be using the Catalyst Control Center to set that up.